Huge Amazon device sale! Shop all the discounts now

08-04-2014 04:06 PM
60 123
tools
  1. morgaes's Avatar
    One of my picture folders on OneDrive is not showing up in the "OneDrive Albums" folder in the Photo hub. This folder is called "Pictures" and is my cloud backup of all the pictures on my laptop. I'm running WP 8.1 on a Lumia 930 with Cyan and the OneDrive app is up to date. I've double checked that the folder type is set as "Pictures", I've tried soft resetting, I've tried changing the folder name and then soft resetting, I've tried deleting temporary files and then soft resetting and am now out of ideas. Anyone know how I can get that folder to show up in the Photo hub?

    I've tried creating a new folder and uploading a picture to it and that shows up just fine so it seems like it's selectively not syncing that one folder for some reason. I could try to delete the folder and resync it from my laptop to OneDrive but I'd rather avoid it since it'd take way too much time.
    AgentEXE likes this.
    07-22-2014 05:22 PM
  2. Nerdy Woman's Avatar
    On my OneDrive, Camera Roll, Mobile Uploads, and Saved Pictures are all subfolders of the OneDrive default folder, "Pictures." When you access your OneDrive in a browser window, do you have a Pictures folder at the root level? And is that your laptop archive? Or do you have a separate Pictures folder, perhaps as a subfolder of Documents?

    I don't know if this will fix it, but perhaps... find the laptop archive folder "pictures," rename it (archive or something), then move it within onedrive to be a subfolder of the same folder, at the same level, as the camera roll folder. It won't have to rebuild, it will just rename at the server level.
    Laura Knotek likes this.
    07-22-2014 05:47 PM
  3. morgaes's Avatar
    Thanks for your reply. As the attachments show, the "Pictures" folder is at the root level of OneDrive and contains "Camera Roll", "Mobile Uploads" and "Saved Pictures" along with all of my archived pictures (sorted in various folders). The problem is basically that all these folders within "Pictures" are not being synced properly to the Photo hub.

    The weird thing is that I've got my old Lumia 800 next to me and it works perfectly there.

    capture.jpg
    capture2.jpg
    07-22-2014 06:18 PM
  4. Nerdy Woman's Avatar
    Thanks for your reply. As the attachments show, the "Pictures" folder is at the root level of OneDrive and contains "Camera Roll", "Mobile Uploads" and "Saved Pictures" along with all of my archived pictures (sorted in various folders). The problem is basically that all these folders within "Pictures" are not being synced properly to the Photo hub.
    Notice the white squares on some of the folders? That designates the contents as pictures. Apparently, file type properties in OneDrive aren't automatically inherited by child folders. It may be a quirk when the folders are created on your C: then uploaded...

    Check the box to the left of one of the years, then right click and choose properties. In the Details pane at the right, you can see folder type... and a change link. Specify folder type Pictures for any of the folders that don't have the little picture icon on them...
    Laura Knotek likes this.
    07-22-2014 06:30 PM
  5. morgaes's Avatar
    Thanks for the tip, but no luck. The ones that already had the "pictures" folder type weren't appearing in the "OneDrive Albums" folder in the Photo hub and changing all the others didn't seem to have any effect. Also, it'd be strange if that were the problem since it's working flawlessly on my Lumia 800. Another odd thing I noticed is that the "OneDrive Albums" thumbnail is a picture from the root of the "Pictures" folder but when I open the album it's still completely empty.
    07-22-2014 06:46 PM
  6. Nerdy Woman's Avatar
    Thanks for the tip, but no luck. The ones that already had the "pictures" folder type weren't appearing in the "OneDrive Albums" folder in the Photo hub and changing all the others didn't seem to have any effect. Also, it'd be strange if that were the problem since it's working flawlessly on my Lumia 800. Another odd thing I noticed is that the "OneDrive Albums" thumbnail is a picture from the root of the "Pictures" folder but when I open the album it's still completely empty.
    I found an article in the MS Community that might be relevant...

    I can't access photos on my skydrive through the photo hub - Microsoft Community

    If you go to settings > email + accounts and tap/hold on your log in account, you can force a resync of everything...
    AgentEXE and Laura Knotek like this.
    07-22-2014 07:01 PM
  7. Blackadder_100's Avatar
    If you are using version 4.2.0.0 of the OneDrive app, updated on 22nd July, you may find that this has broken the photo hub integration.
    Last edited by Blackadder_100; 07-23-2014 at 08:08 AM.
    07-22-2014 07:17 PM
  8. morgaes's Avatar
    Thank you, but no luck with that one either. I'm wondering if a hard reset is in order, though that seems excessive seeing as I've only had the device for about a week.
    07-22-2014 07:20 PM
  9. morgaes's Avatar
    If you are using version 4.2.0.0 of the OneDrive app, updated on 22nd July, you may find that this has broken the photo hub integration. I
    Do you mean this is a known problem others are having or are you just suggesting that the recent update might be the cause?
    07-22-2014 07:23 PM
  10. Nerdy Woman's Avatar
    Do you mean this is a known problem others are having or are you just suggesting that the recent update might be the cause?
    If what blackadder says is true, it might be peculiar to L930. I've got an L920, running 8.1 DP 8.10.12397.895 and OneDrive 4.2.0.0 without any problem.

    Based on the Community article I linked to, and particularly since you are "reusing" an MS ID that was formerly syncing with a different phone, it sounds like the password reset indicated in the community thread is in order... I'm assuming that since you just got this phone, the pics were viewable on your old phone, but have never been viewable on the 930?
    morgaes likes this.
    07-22-2014 07:32 PM
  11. morgaes's Avatar
    If what blackadder says is true, it might be peculiar to L930. I've got an L920, running 8.1 DP 8.10.12397.895 and OneDrive 4.2.0.0 without any problem.

    Based on the Community article I linked to, and particularly since you are "reusing" an MS ID that was formerly syncing with a different phone, it sounds like the password reset indicated in the community thread is in order... I'm assuming that since you just got this phone, the pics were viewable on your old phone, but have never been viewable on the 930?
    I did try the password reset but everything's still the same. Actually, a couple of folders were viewable when I first got the phone, but now even they are not available. This really is a peculiar problem.
    07-22-2014 07:37 PM
  12. Blackadder_100's Avatar
    Certainly in my case the update on 22nd July is the cause (unable to view OneDrive picture folders in the photo hub). You could check the version of the OneDrive app in your Lumia 800. I have reverted to version 3.5 after a hard reset and by disabling "update apps automatically" in the store settings and can now view online pictures again in the photo hub. I believe the OneDrive update is for WP8.1 DP at present, which is what I have. Hope this helps.
    morgaes likes this.
    07-22-2014 07:38 PM
  13. morgaes's Avatar
    Certainly in my case the update on 22nd July is the cause (unable to view OneDrive picture folders in the photo hub). You could check the version of the OneDrive app in your Lumia 800. I have reverted to version 3.5 after a hard reset and by disabling "update apps automatically" in the store settings and can now view online pictures again in the photo hub. I believe the OneDrive update is for WP8.1 DP at present, which is what I have. Hope this helps.
    Ok, thank you very much. The Photo hub in Lumia 800 (WP 7.8) doesn't rely on the OneDrive app so it makes sense that the app in WP 8.1 might be causing the trouble. I'll try a hard reset when I get the time to, seeing as all other less drastic measures seem to be exhausted.

    And thank you again, Nerdy Woman, you've been really helpful. I appreciate it :)

    I'll make sure to check in here with the results in case anyone stumbles in with a similar problem.
    Nerdy Woman likes this.
    07-22-2014 07:54 PM
  14. TheNet Avenger's Avatar
    Certainly in my case the update on 22nd July is the cause (unable to view OneDrive picture folders in the photo hub). You could check the version of the OneDrive app in your Lumia 800. I have reverted to version 3.5 after a hard reset and by disabling "update apps automatically" in the store settings and can now view online pictures again in the photo hub. I believe the OneDrive update is for WP8.1 DP at present, which is what I have. Hope this helps.

    I am also seeing this problem since the last OneDrive App update on WP8.1. My main 'Pictures' folder is missing from the Albums, yet any other folder I create and mark as 'Pictures' on OneDrive appear properly.


    Interesting is that on the first view inside OneDrive, these appear:
    Camera Roll, OneDrive Albums, Recent Photos, Saved Pictures, Shared With Me


    Yet Saved Pictures is empty even though it has a picture for its Thumbnail and OneDrive Albums shows a Thumbnail from the Pictures folder that is missing when OneDrive Albums is open.


    Using the OneDrive App directly, everything displays fine. This problem only happens when accessing OneDrive from inside Photos on the WP8.1. This is a problem, as it also affects the 'file selector' on the phone, as the missing Pictures folder are not able to be selected from OneDrive.



    Everyone needs to check how OneDrive appears in Photos on WP8.1 and if things are missing, complain to MS to ensure they know of the problem.
    AgentEXE likes this.
    07-22-2014 08:05 PM
  15. grandmalfunk's Avatar
    I have a 1020 with Win 8.1 developers preview. Everything with the Photo hub was working just great until the new Onedrive app was updated. Now I only have one Onedrive folder showing up. I have tried the "sync" option through the settings, and still no go. I have no problem seeing the folders from within the actual Onedrive app, but no luck through the photo hub.
    AgentEXE likes this.
    07-23-2014 12:06 AM
  16. AgentEXE's Avatar
    This is happening to me as well. It seems to have started a day or two ago, shortly after updating my OneDrive extra space subscription. Hmm. From my phone I can see all my picture albums in the OneDrive app, but from any other app, like Photos, or 6tag there is nothing in the "OneDrive Albums" folder. :( Boooo!
    07-23-2014 01:18 AM
  17. AgentEXE's Avatar
    If you are using version 4.2.0.0 of the OneDrive app, updated on 22nd July, you may find that this has broken the photo hub integration. I
    This must be the problem. I got an update to OneDrive yesterday to 4.2.0.0, and now photos integration is indeed broken.
    07-23-2014 01:24 AM
  18. Deutscher2's Avatar
    If you are using version 4.2.0.0 of the OneDrive app, updated on 22nd July, you may find that this has broken the photo hub integration. I
    After the Update, I've the same Problem on my 1020. Some OneDrive Folders in the Photo Hub don't load correct.
    07-23-2014 05:16 AM
  19. PJLips's Avatar
    I'm experiencing the same problem. The update has indeed broken the integration. Hoping for a quick fix now...
    07-23-2014 06:28 AM
  20. multo's Avatar
    Just chiming in to see if there are any developments. Happened to me as well. Same scenario. 1520 on dp8.1. My 1020 on black is ok
    07-23-2014 07:29 AM
  21. vonkzilla's Avatar
    Same issue, photos load in onedrive app but once im in my photos hub app they wont load from the ondrive albums although thumbnails are visible.

    Can anyone post a link to report this to microsoft for all of us comment on>?

    thanks
    07-23-2014 04:13 PM
  22. Brandon McLean's Avatar
    I have this issue too. The last update to OneDrive broke it on 8.1.
    Sent from my RM-927_nam_vzw_100 using Tapatalk
    07-23-2014 04:14 PM
  23. K_lando's Avatar
    Same issue, just now noticed it. Its not just Photo Hub, when I go to settings to change my tiles background, the same folders missing from the pictures hub no longer showing up. Yet if I use the Onedrive app, all folders are there.
    Last edited by K_lando; 07-23-2014 at 06:51 PM.
    07-23-2014 06:12 PM
  24. K_lando's Avatar
    SOLUTION

    Access Onedrive via web portal (PC)
    I created a 2nd root folder I named Pictures B (you can name it whatever you want).
    I then moved all my subfolders from the default 'Pictures' folder to the new 'Pictures B' folder.
    Then I had to go through and change the properties of each and every subfolder, one at a time, to 'Pictures' type.

    To be clear, all the properties/file types were already set to 'Pictures' when they were under the default Pictures folder, but moving the folders reset the properties to Documents. So it is indeed a bug to begin with, but one that is fixable.

    After all done, I went back and deleted the original (and now empty) default Pictures folder... however, when you reload OneDrive, it auto-creates that default Pictures folder, so its always there.
    Last edited by K_lando; 07-23-2014 at 07:01 PM.
    07-23-2014 06:47 PM
  25. morgaes's Avatar
    I just did a hard reset and didn't update the OneDrive app and now the Photo hub integration works just fine. Is there any way to report this problem to MS other than leaving a review on the app?
    07-23-2014 06:59 PM
60 123

Similar Threads

  1. A Few questions from a New Icon Owner
    By nikholaspappas in forum Windows Phones
    Replies: 9
    Last Post: 07-24-2014, 02:31 PM
  2. Facebook Beta Tile Photo
    By 6029KingStephen in forum General Phone Discussion
    Replies: 2
    Last Post: 07-23-2014, 04:46 AM
  3. Airyware music tuner for Windows Phone drops from $4.99 to just $0 with myAppFree
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 07-22-2014, 01:11 PM
  4. transfer Songs and Photos
    By spec_8 in forum Windows Central Archive
    Replies: 1
    Last Post: 07-22-2014, 11:43 AM
  5. Replies: 0
    Last Post: 07-22-2014, 11:38 AM
LINK TO POST COPIED TO CLIPBOARD