1. ronteral2k's Avatar
    I bought a class 10 64gb Samsung micro SD card for my phone and for some unknown reason it keeps corrupting the memory card. I though it was a problem with the SD card so i got a new one and it does the same thing. Is a class 10 SD card too good for the ativ s neo or do i have a faulty device?
    11-07-2013 02:55 PM
  2. Laura Knotek's Avatar
    What brand of cards are these? Where did you purchase them?

    Do these cards work ok in your PC card reader?
    11-07-2013 09:42 PM
  3. Kmn3's Avatar
    Ronteral2k - Have had the same issue. Got an Amazon 16GB card and it worked flawlessly in both my old Android phone and laptop. I have had my card get corrupted 3 times now listening to music through the XBOX application. With some many people having this issue, it is most likely an OS issue.
    11-09-2013 02:05 PM
  4. BitPusher2600's Avatar
    I'll throw some stuff at the dartboard here.

    I have a class 4 32gb Sandisk, and I got my Neo about a week after they were released. I have had zero problems here. I don't know if there's a bug with 64gb cards specifically or if its those buying class 10 cards, which is something I can't understand people putting in a smartphone and thinking they can remotely use that. Class 4 or 6 are perfectly capable of capturing 1080p video, let alone lagless switching between media stored on it. Smartphones can't presently utilize the maximum read/write speed of a class 10 card anyway because its not necessary, it makes about as much sense as sticking a USB 3.0 flash drive in a USB 1.* port.

    Kmn3 isn't using one like that so I don't know. I listen to music alot, and since that is read from the memory card and there seems to be no way to kill it off completely after exiting the music app, I fire up an app called Kill My Music to fully shutdown the media player and take it off my volume indicator. Wonder if that's what's prevented me from having issues up until now?

    If it matters, I did not install the advance release of GDR3.
    11-10-2013 09:04 AM
  5. Kmn3's Avatar
    BitPusher2600, I did not know about the exiting from the music app. Maybe there is a constant "connection" between the OS and SDcard, and when that gets interupted, it causes the SD card to think it was physically ejected?

    Has anyone with GDR3 installed experience the SD card failure in the Neo now that they have the ability to manually close programs?
    11-11-2013 09:23 AM
  6. ronteral2k's Avatar
    What brand of cards are these? Where did you purchase them?

    Do these cards work ok in your PC card reader?
    These are Samsung SD cards that i purchased from bestbuy. Haven't tried them in a PC card reader, only in the phone and my digital camera. It worked perfectly in my Digital camera and it also worked for about a week in my phone before the phone fully corrupted it
    11-12-2013 06:52 PM
  7. ronteral2k's Avatar
    I'll throw some stuff at the dartboard here.

    I have a class 4 32gb Sandisk, and I got my Neo about a week after they were released. I have had zero problems here. I don't know if there's a bug with 64gb cards specifically or if its those buying class 10 cards, which is something I can't understand people putting in a smartphone and thinking they can remotely use that. Class 4 or 6 are perfectly capable of capturing 1080p video, let alone lagless switching between media stored on it. Smartphones can't presently utilize the maximum read/write speed of a class 10 card anyway because its not necessary, it makes about as much sense as sticking a USB 3.0 flash drive in a USB 1.* port.

    Kmn3 isn't using one like that so I don't know. I listen to music alot, and since that is read from the memory card and there seems to be no way to kill it off completely after exiting the music app, I fire up an app called Kill My Music to fully shutdown the media player and take it off my volume indicator. Wonder if that's what's prevented me from having issues up until now?

    If it matters, I did not install the advance release of GDR3.
    The reason i'm using a class 10 is because i can't seem to find a class 4 64gb SD card. I would think that since it's a higher class then it would work better but i guess that's not the case. But to answer the question, that's probably why people are using class 10's because they can't find a class 4 64gb card (not at a decent price anyway)
    Last edited by ronteral2k; 11-12-2013 at 07:20 PM.
    11-12-2013 06:59 PM
  8. flyedf's Avatar
    i'm using a class 10 64gb patriot card. so far no issues, w videos, pictures, but I have had some hang ups while playing mp3s. but a simple power cycle put everything back in order. going to go to smaller card 16gb card, b/c I want to use the 64 for a tablet for movies. and I'll let you know if there's any difference, meaning that the 64gb was likely the problem. or could be more related to the card manufacturer
    11-15-2013 06:18 AM
  9. Kmn3's Avatar
    I will add one more thing - the only time that my SD card became corrupted was when I had my entire library on random (since there really doesn't seem to be a way to craft playlists in the music app!!!). Not sure if that had something to do with it.

    And for those that state that it is a "card," "manufacturer," "size," or "speed" issue, it is just coincidence that all or our various cards failed when moving to windows phone, right...?
    11-16-2013 09:40 AM
  10. dinoBa's Avatar
    The same happens to my recorded videos on L520. I can play them back maybe once, after that there's "Sorry, we can play this file on your device". I think it might be cause I have a class 10 card (16 GiB).
    11-16-2013 10:12 AM
  11. JoeRollerfan's Avatar
    I'm using a SanDisk Ultra 64 GB class 10 card with GDR3, no problems no far.
    11-19-2013 04:25 PM
  12. Kmn3's Avatar
    Well, it has been almost a month (keeping fingers crossed) and not corruption issues. I turned off the xbox music crap (don't have that service anyways) and have not selected "play all on shuffle." While I am happy that no card corruption has occurred, I am very disappointed that I have to limit my phone, which is already limited with the inability to create playlists in the music program, just to ensure that I have something to listen too...
    11-27-2013 01:19 PM
  13. dorelse's Avatar
    I'm using a SanDisk Ultra 64 GB class 10 card with GDR3, no problems no far.
    I'm using the same card and mine corrupted about 10 days ago. I had to completely hard reset the phone for it to recognize that music was music and movies were movies...

    I hadn't touched the card since I put it in on day 1, just decided one day to not work...formatting the card didn't work, both in the phone and/or computer...the only solution I had to was complete hard reset so it would see the card as 'new' and then it magically worked again.
    11-28-2013 08:38 AM
  14. Kmn3's Avatar
    Just figured I would update this thread - I still have not had my SD card corrupt since the beginning of November. However, since that time, I have not listened to all music on random&repeat and have left all xbox music settings off. In reality, I don't trust my phone to [I]not[I] corrupt my card, so I haven't used it as much as I otherwise would have (TuneIn, when it works, has been my goto). I really don't think this is what I would call "success" over this issue.
    12-15-2013 08:52 AM
  15. Kmn3's Avatar
    ....And my SD card is corrupted. Oddly, just the pictures, music files seems fine. This happen to anyone else???
    12-21-2013 09:06 AM
  16. Rod Iron's Avatar
    I have a Centon 32 GB class 10, only bought it because it was on sale. I don't think there's much on it but it seems to be working just fine.
    12-23-2013 12:47 AM
  17. Palm_forlackofchoice's Avatar
    My son had the same problems with his Android Samsung Galaxy S3. He had to go down to a class 4 card.
    12-28-2013 09:12 AM
  18. ronteral2k's Avatar
    So i switched to a 32gb class 4 Micro SD card and haven't hand any problem since. So i guess class 10 cards just don't work for long in the Ativ S Neo...
    12-31-2013 01:35 PM
  19. Vicious Enzyme's Avatar
    Same issue, two class 10's dead, got told to try a class 6 for compatability reasons and I haven't had any problems so far (a months usage), hopefully that's the issue.
    No speed problems so I assume the device or os is built for class 6 and under.
    Both class 10's were SanDisk (grey red), the class 6 is a Samsung card (worth a try I thought).
    03-11-2015 10:31 PM
  20. NuAngel's Avatar
    I thought it was just me, and I've spent a fortune on new cards as I kept thinking I was doing something to them. A class 10 and 2 other cards (class unknown) have all given me the same issue. Trick I've learned, though - when the warning window comes up (whether randomly or just after a reboot), and it asks to scan your card for errors, just say no. Saying no saves a ton of a time (the "check disk" feature can take a while if you have a lot of apps installed and other data on the card - saying no *should* instantly re-mount the SD Card). I have had no problems with any of my apps by continuing to ignore this "error."
    04-08-2015 09:52 AM
  21. K3max85's Avatar
    So I am actually "Kmn3", but my account does not seem to be active to sync now...
    NuAngel, are you actually having the corruption issues on 8.1 update? If so, this must be something on Microsoft's (or even Sprint's) back end that is causing this then. I upgraded to 8.1 over wifi, and have only used the phone on wifi (I went to a Moto-X almost a year and a half ago), though most of the time without any network connection at all as just an MP3 player, and have not had the issue with the same 16gb amazon SD card so far. I thought the upgrade to 8.1 fixed the issue, but maybe it did not? That is no good, because I was thinking of switching back to my Neo for my daily driver for a while to see how 8.1 suits me on an everyday basis. No guarantee that my music collection will survive at work does not make me feel optimistic about that now...
    05-10-2015 11:17 AM
  22. Rod Iron's Avatar
    Looks like mine crapped out too! I hadn't even noticed till I started plying round with it one night. Ahhh well looks like it's time for a lower class.

    Posted via the Windows Central App for Android
    04-04-2016 12:44 AM

Similar Threads

  1. Sync-ing with Windows XP?
    By JLomba1 in forum Nokia Lumia 928
    Replies: 7
    Last Post: 04-04-2014, 01:53 AM
  2. Problems With Live Tiles and Facebook Profile Pictures
    By Isaiah Quino in forum Nokia Lumia 810
    Replies: 7
    Last Post: 11-14-2013, 04:56 PM
  3. How to purchase apps and games in wp8 store without credit card?
    By Manoj Verma1 in forum Nokia Lumia 520
    Replies: 4
    Last Post: 11-12-2013, 02:07 AM
  4. Problem with my music app
    By akhileshnag in forum Nokia Lumia 625
    Replies: 4
    Last Post: 11-11-2013, 10:40 PM
  5. Lumia 928 issues
    By isdefective in forum Nokia Lumia 928
    Replies: 4
    Last Post: 11-06-2013, 10:22 PM
LINK TO POST COPIED TO CLIPBOARD