1. StorminOkie's Avatar
    As some of you may or may not know but in Sprint's latest ROM update for the Mogul (RUU_TITAN_SPRINT_WWE_3.56.651.0_RS_3.42.02_SPCS2.0 4_PPST_0619), there is NO ROAMING ONLY option under the Roaming settings. The only options are Sprint Only and Automatic. That is it! It appears Sprint is trying to cut back on all of the Roaming. Well after looking at the programming and the registy, I quickly learned that the Roaming Only option will work if you put the proper registry settings back on. Well, I have those settings for you ...

    Before you can do any of this, you will need a Registry Editor. If you are unsure of what a Registry Editor is or have no clue about the registry, you should probably not be attempting this ... LOL

    First thing you will need to do is go to ...
    \HKEY_LOCAL_MACHINE\SOFTWARE\OEM\PhoneSetting\NetworkService
    After highlighting ...\NetworkService, you will see the list with the first line saying "ItemCount". You will need to highlight this line and go into changing the value. You will want to change the Value Data from 2 to 3. After clicking OK, you should see under Name: ItemCount and Data: 3 (0X000003).

    The second thing you need to do is create a New String Value. Once you have done this, you will see Value Name and Value Data. Under Value Name, enter "ItemName3" and under Value Data enter "Roaming". After finishing this, you should now see this entry under Name: ItemName3 and Data: Roaming.

    The last thing you need to do is create a New DWord Value. Once you have done this, you will see Value Name, Value Data, and a box that says Base with Binary, Decimal, and Hexidecimal as options. Under Value Name enter "ItemValue3" and under Value Data enter "3". Make sure that under the Base option box that Decimal is checked. After finishing this, you should see another new entry under Name: ItemValue3 and Data: 3 (0X000003).

    That is it !!! You will now be able to force Roaming whenever you need to without having to put up with dropped calls when you are between service areas. I hope this helps and if you have any further questions, please PM me. Good luck ...
    :D
    Last edited by StorminOkie; 06-25-2008 at 12:28 PM.
    06-25-2008 05:16 AM
  2. StorminOkie's Avatar
    As some of you may or may not know but in Sprint's latest ROM update for the Mogul (RUU_TITAN_SPRINT_WWE_3.56.651.0_RS_3.42.02_SPCS2.0 4_PPST_0619), there is NO ROAMING ONLY option under the Roaming settings. The only options are Sprint Only and Automatic. That is it! It appears Sprint is trying to cut back on all of the Roaming. Well after looking at the programming and the registy, I quickly learned that the Roaming Only option will work if you put the proper registry settings back on. Well, I have those settings for you ...

    Before you can do any of this, you will need a Registry Editor. If you are unsure of what a Registry Editor is or have no clue about the registry, you should probably not be attempting this ... LOL

    First thing you will need to do is go to ...
    \HKEY_LOCAL_MACHINE\SOFTWARE\OEM\PhoneSetting\NetworkService
    After highlighting ...\NetworkService, you will see the list with the first line saying "ItemCount". You will need to highlight this line and go into changing the value. You will want to change the Value Data from 2 to 3. After clicking OK, you should see under Name: ItemCount and Data: 3 (0X000003).

    The second thing you need to do is create a New String Value. Once you have done this, you will see Value Name and Value Data. Under Value Name, enter "ItemName3" and under Value Data enter "Roaming". After finishing this, you should now see this entry under Name: ItemName3 and Data: Roaming.

    The last thing you need to do is create a New DWord Value. Once you have done this, you will see Value Name, Value Data, and a box that says Base with Binary, Decimal, and Hexidecimal as options. Under Value Name enter "ItemValue3" and under Value Data enter "3". Make sure that under the Base option box that Decimal is checked. After finishing this, you should see another new entry under Name: ItemValue3 and Data: 3 (0X000003).

    That is it !!! You will now be able to force Roaming whenever you need to without having to put up with dropped calls when you are between service areas. I hope this helps and if you have any further questions, please PM me. Good luck ...
    My post above does have some flaws so I guess my first post isn't is informative as I originally thought ...

    Unfortunately this does not hold after the phone is rebooted. It will reset the settings back to the original so I will look at this some more and see what I can do to make this stick (if I can).

    If anyone else has any ideas, please let me know. Thanks ...
    Last edited by StorminOkie; 06-25-2008 at 05:20 PM.
    06-25-2008 12:35 PM
  3. silicon's Avatar
    Try those settings in this registry entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\OEM\InitProv\PhoneSetting

    Worked after reboot for me. Hope this helps.

    -silicon
    06-25-2008 02:24 PM
  4. StorminOkie's Avatar
    WOW !!! I was just about to post the same thing. Thanks Silicon !!!
    06-25-2008 05:23 PM
  5. cubear's Avatar
    What registry editor software are you using to get this done? I downloaded a few online but nothing worked :-/ I have a Motorola VE20 with Sprint, trying to modify the registry so the phone can get on roaming as I have very poor reception in my room. Thank you
    09-03-2009 03:08 PM
  6. Dave Blake's Avatar
    What registry editor software are you using to get this done? I downloaded a few online but nothing worked :-/ I have a Motorola VE20 with Sprint, trying to modify the registry so the phone can get on roaming as I have very poor reception in my room. Thank you
    That is not a Windows Mobile Phone so the reg edits wont work for you. I don't really know where to tell you to look. :hmm:
    09-04-2009 06:58 PM
  7. SCFenceMan's Avatar
    Try those settings in this registry entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\OEM\InitProv\PhoneSetting

    Worked after reboot for me. Hope this helps.

    -silicon
    silicon,

    i don't have HKEY local MACHIN Esoftware oem...

    i have sprint samsung intrepidwith wm6.5 proffesional and ceos 5.2.21743 build 21743.5.0.26!

    any isea where i put your hkey changes for roam?
    Last edited by SCFenceMan; 12-01-2009 at 02:23 PM. Reason: my phone type wrong
    12-01-2009 12:49 PM
  8. SCFenceMan's Avatar
    ok i changed the values as described but when i go to settings, personal, phone, services and scroll to roaming and select change setting i still only have sprint only and automatic! any idea why? i verified that reg edits are correct and in key value location described and they are correct and even retain after a reboot... any help would be appreciated ty in advance..
    12-02-2009 08:17 AM
LINK TO POST COPIED TO CLIPBOARD