Black Screen Problem After Anniversary Update

Ariel Takom

New member
Aug 9, 2015
386
0
0
Visit site
Hi all!

So as the title reads, I'm facing a problem with black screen on my laptop AFTER the AU.

I bought my laptop about a month ago (Dell Inspiron 15 7559, i7, 8GB RAM, GTX960M, 1TB HD, in case specs info helps), and it came with the 10586 OS version (TH2 update). I updated every drivers then, and everything was running fine; gaming, working, browsing, etc.

Then after the AU, everything 'seems' to be fine, except for this problem. I noticed that everytime I put my laptop to sleep (closing the lid, sleep from start menu), whenever I try to wake it up, the laptop powers up (the power indicator on the power button lights up) but the screen remained black. I waited for 6-10 minutes and nothing happened.

But plugging in my earphone and unplugging it results in the notification sound playing, so I was sure my laptop is on, just that the screen stayed black/off. So to solve this problem for now, I have to force off my laptop via holding the power button until the indicator turns off, and turn it back on normally. Although, I must say that turning it on after this problem occurs makes the laptop's boot up time to be slower than usual.

Although I do have a workaround, this is kinda annoying to do. I'm a student, so I really need to be able to bring my laptop anywhere, pop it open during class to read my lecture slides, typing, and whatnot, and close the lid (put it to sleep) as I go for my next classes, rinse, wash, repeat. But with this problem, I've had to shut down my laptop and turn it on everytime (booting up from shut down is quicker).

So, yeah. Anyone have faced this problem before or currently? I tried deactivating the fast startup setting, but it only worked about three times. After that, this problem resurfaced again. :eck:
 

Ariel Takom

New member
Aug 9, 2015
386
0
0
Visit site
does it happen if you use hibernate?
Try this too: SFC Scan: https://support.microsoft.com/en-us/kb/929833

I'm not sure what hibernate is tho. I've only ever used Sleep mode (from start menu > power > sleep) or closing my laptop's lid.

Though I must say that I did try to deactivate hibernate function via cmd command from one of the possible fixes I read somewhere on the internet, but cmd replied with something like "this feature is not in your device"
 

Ariel Takom

New member
Aug 9, 2015
386
0
0
Visit site

Chintan Gohel

Active member
May 23, 2014
10,785
1
36
Visit site
There's no solution posted in those links, and from what the people said in the forum (and what I'm experiencing as well), this black screen occurs after either sleep or hibernate mode.

Suspiciously, it happened after the AU. Now I'm running the SFC scan again, hoping for a better result :/

Agreed, but maybe you could try enabling hibernate mode
 

Ariel Takom

New member
Aug 9, 2015
386
0
0
Visit site
In the case that someone out there is facing this problem of mine, good news: I've found a fix!

All you have to do is simply go to roll back your Intel HD driver (if any. Mine's a laptop so I do have this installed) to a previous version, preferably download the driver from your laptop manufacturer's website, and voila! No more blackscreens baby!

Anyway, I thought of this fix after reading a comment from some other site on the Internet, where someone said they TEMPORARILY fixed the problem by uninstalling the Intel HD Display driver via Device Manager. However, I say 'TEMPORARILY' because each time he restarted his laptop, Windows automatically re-installs the driver for him, and the problem persists. So he had to repeat the uninstall process over and over again.

So I checked the Intel HD Display driver version I had installed on my laptop, and turns out it had the latest version (I suspect it was installed together with the AU), version no.: 21.xxxx, while the driver available on the Dell website (my laptop is a Dell Inspiron 15 7559) is of version no. 20.xxxx. I downloaded the driver from the Dell website, installed it, restarted my laptop, and voila! Problem fixed! No more black screen baby!

Hope you all find this post useful! ^_^
 

RJ Priest

New member
Feb 13, 2013
364
0
0
Visit site
I experienced the black screen problem today when my desktop received the anniversary update. Only a problem with displayport connection, I could get monitors to work with DVI. After hours of failing to solve the problem, I had to rollback my OS - which immediately solved the problem.

Nvidia Quadro 5000 video card.
 

Members online

Forum statistics

Threads
324,649
Messages
2,245,816
Members
428,216
Latest member
michellethomas