Caller ID not displaying when I receive a call after Buid 10549

tabraoui

New member
May 17, 2012
69
0
0
Visit site
Hey all,
I have a Lumia 820.
I've already tried almost all the previous builds (mostly I went back to 8.1, but was very happy with build 10536).
I updated to 10549 a week ago... All working well (almost) however, for the first time, the caller ID does not display when I receive a call... Weird.
I already tried a hard, clean reset... twice... same thing.
I checked the forums... I didn't see anyone else with this issue (I hope I'm wrong though)
If anyone has an idea, please... help :smile:
 

Krystianpants

New member
Sep 2, 2014
1,828
0
0
Visit site
Privacy > background apps
make sure phone is enabled

System > phone

Make sure "show my caller ID is selected to something. Sometimes it's blank may cause problems

Then scroll down and select choose apps. And make sure "calling" isn't using some app you may have installed. Should be set to none. And call filtering should be set to none or whatever you use to filter apps.

The settings are really all over the place. They need to clean it up a bit.
 

tabraoui

New member
May 17, 2012
69
0
0
Visit site
Thanks. But it's not that.
I finally figured it out.
I have my region set to United States and I don't live in the US.
When I changed my region to my country... It worked.
But, I always had my region set on US (since my first Lumia 800 :smile:)... this was the first time it messed it up.
 

Members online

Forum statistics

Threads
323,181
Messages
2,243,392
Members
428,035
Latest member
powerupgo