Computer wont recognize phone via USB

Xaxinian

New member
Sep 29, 2014
3
0
0
Visit site
My issue is two-fold. One is I believe since the update, I cannot connect phone to PC. It will charge the phone, but no data. I tried this on my PC and Laptop running 7 and 8 respectively with the same result, Only charges, cant explore phone at all.

I have the dev preview installed prior to the new version being released for the T-Mobile 521. Can anyone confirm I am up to date? If not I may have to reset the phone because it is telling me my phone is up to date. Below are the Version numbers. Any help would be appreciated.

OS Version: 8.10.12382.878
Firmware Version 3056.40000.1404.0034 (Note when I look online it shows 4000 instead of 40000 on my phone.

Thanks in advance.
 

mathsisbest

New member
Nov 1, 2014
229
0
0
Visit site
Sometimes try blowing the dust off the usb port. Try all usb ports. For me it sometimes takes time for pc to recognise phone. Also make sure when you connect it to use your phone. If you use it, it fastens the process (in my experience)
 

Dneil46

New member
Dec 12, 2013
11
0
0
Visit site
Same issue here. Have a 521 and just got a brand new Dell with Windows 8.1. Downloaded the app for the PC to connect to my phone but it just sits there on the screen telling me to connect my phone. Phone is charging, both phone and computer chime to indicate their connected, but doesn't initiate any features to explore my phones files. Tried my wife's phone, which is not updated to Windows 8.1 and it sees it just fine. Very frustrated with this. Have you had any success with resolving this?
 

rhapdog

Retired Senior Ambassador
Aug 26, 2014
3,035
0
0
Visit site
After I did a phone update, my phone suddenly had a new "USB" section under Settings. In it, you can check to have it ask you if you want to use the USB as a data connection. If I don't answer the prompt quickly enough, I don't get to use it as a data connection. If I uncheck the box, then it will automatically use it as data connection.

Check the setting to see if you're needing to do something when plugging in the cable. Can't hurt to look. May not help, but if the phone is getting a charge, it is properly connected. This is the most likely culprit that I can think of at the moment.
 

Members online

Forum statistics

Threads
324,068
Messages
2,244,919
Members
428,161
Latest member
Toologix