Display Dock HD-500 not working

mvw

New member
Jan 27, 2013
2
0
0
Visit site
I recently got my free Display Dock from Microsoft (which I got because I ordered the Lumia 950XL). I was very excited to try it out, but when I tried to connect an external monitor it didn't work! The phone beeps to let me know it has connected something, the LED on the Display Dock turns from red to white, but then I get a message on my phone saying I'm using the wrong USB-C cable and I should use the one that came with it. Of course, that is the only one I have (USB-C to USB-C) so I am actually using that very cable and still it's not working!

Anyone else having issues with this? :unhappysweat:
 

Don Geronimo

New member
Aug 22, 2014
199
0
0
Visit site
I've gotten that message before, but I've ignored it each time. Continuum worked for me on my Lumia 950 (AT&T), and at a certain point it stopped complaining at me about the cable.

Any road, it sounds like you connected it, the light turns to white, but you get that message. Have you tried to launch the Continuum app on the phone, and made sure you select the Wired Dock radio? You may need to unplug the phone, open Continuum, select the Wired Dock radio option, then plug the phone back in.
 

mvw

New member
Jan 27, 2013
2
0
0
Visit site
I tried that already (in fact, I just tried it again). Sadly with the same result. I contacted Microsoft Support today, they've provided me with a return shipping label so I can return it and get a replacement Display Dock. Let's hope it doesn't take too long and the new one does work. (I just hope there's nothing wrong with my phone's USB-C port, it does connect properly to my PC using the USB-C to USB cable though...)
 

jdmd1979

New member
Aug 27, 2012
3
0
0
Visit site
I actually have received the same error message about using the wrong USB-C cable and to use the one that came with the Display Dock (which of course I was using). Sometimes I could just ignore the message and could continue to use Continuum, but other times it would just be a black screen. Guess I will try contacting Microsoft for an exchange unit, unless anyone knows any other solutions.
 

OsnaStonie

New member
Nov 19, 2012
14
0
0
Visit site
Hm ... I don't think it helps in this specific case, but maybe someone else locking for help with a Display Dock can benefit from my experience: I received the dock yesterday, tested it (worked great) and then made a firmware update via the Gadgets App. When it told me to disconnect and reconnect power, I did so but the dock did not start up properly. I dis- and reconnected several times, with phone connected as well as without phone but could not get the dock to work again. Most of the time it showed a constant red LED but when connected to the phone it was blinking. The manual said I should follow instructions on the screen in that case, unfortunately neither the phone nor the connected display showed any instructions. Finally after half a dozen tries the device blinked red followed by white. According to the manual I should visit the next store. Damn!

So I thought I messed up the Display Dock two hours after arrival via a firmware update. Luckily, I stumbled upon a Reddit post indicating that a connected display might negatively influence the update. I detached all cables, connected the phone and reconnected the power cable only and ... et voila ... update finished, works like a charm again.

Just wanted to share, maybe it helps.
 
Last edited:

tomaszsb

New member
Aug 23, 2014
1
0
0
Visit site
I have the same problem except Microsoft now says it is not warrantied because it was part of a bundle. ... I asked them where to repair it and they sent me on a wild goose chase. In addition they say they will call me back and never do... also they do not want to provide me with a complaint number... Who have you called to get the replacement?
 

Members online

Forum statistics

Threads
322,529
Messages
2,242,192
Members
427,942
Latest member
Mallandyrr