Facebook mobile in ie?

pavlovscow

New member
Nov 11, 2012
16
0
0
Visit site
Hey everyone,

i just upgraded to windows 8.1 for my surface rt, which I hadn't used in a while. When I go to Facebook.com in ie, it forces me to the mobile site. No one else is complaining about it. Is there a setting in ie to appear as a mobile device I can toggle? Am I missing something?
 

SlickShoesRUCrazy

New member
Oct 4, 2012
67
0
0
Visit site
Hey everyone,

i just upgraded to windows 8.1 for my surface rt, which I hadn't used in a while. When I go to Facebook.com in ie, it forces me to the mobile site. No one else is complaining about it. Is there a setting in ie to appear as a mobile device I can toggle? Am I missing something?

I've been running 8.1 on my RT since the preview was available and just a few hours ago my RT started doing the same thing. Facebook only loads mobile version for some reason in the browser. It was working just fine this morning and loading the desktop version.

I had a weird message saying I need to activiate java script or something, and the next time I returned to facebook, mobile version only loads. Even more annoying I can't find a way so that it loads the desktop version.
 

Tas33

New member
Oct 4, 2013
1
0
0
Visit site
This just started happening on my Surface RT as well yesterday (10-3-13). I've been using my Surface since it was released, and installed the 8.1 update months ago, and never had this problem before. Nothing changed, I didn't even reboot the Surface, and this started occurring. If anyone knows how to fix this, I'd be appreciative! I really dislike the mobile facebook site, particularly when I'm not on a 3-inch screen!
 

martinmc78

New member
Oct 30, 2012
2,745
0
0
Visit site
Same here - only an issue with facebook though, every other website still loads properly. Even happens if you use IE in desktop mode.

Its quite annoying especially as there is usually an option to change to full website somewhere but even that seems to be missing.
 

martinmc78

New member
Oct 30, 2012
2,745
0
0
Visit site
Found a possible solution

Using desktop IE, go to http://www.facebook.com/home.php which should display the full site with a warning then display IE menus (press alt) and Tools, and into compatibility mode - facebook.com should be highlighted. Add it to the list for compatibility mode. It should then mostly work for both Metro and Desktop IE when you visit Facebook.
 

Vallos

New member
Mar 15, 2011
478
0
0
Visit site
Hey everyone,

i just upgraded to windows 8.1 for my surface rt, which I hadn't used in a while. When I go to Facebook.com in ie, it forces me to the mobile site. No one else is complaining about it. Is there a setting in ie to appear as a mobile device I can toggle? Am I missing something?

Thank you for starting this thread. I thought it was just me.

Found a possible solution

Using desktop IE, go to http://www.facebook.com/home.php which should display the full site with a warning then display IE menus (press alt) and Tools, and into compatibility mode - facebook.com should be highlighted. Add it to the list for compatibility mode. It should then mostly work for both Metro and Desktop IE when you visit Facebook.
Thanks, but it did not work for me.
 

Sean Steele

New member
Oct 4, 2013
1
0
0
Visit site
your suggestion worked perfectly, but I had to log out first, then manually type the address in. Compatibility view did the trick! thank you
 

HeyCori

Mod Emeritus
Mar 1, 2011
6,863
68
48
Visit site
Was coming here to ask about the same thing. Did the trick above but now I have a banner asking me to upgrade my browser. Not having a problem like this with any other sites or devices. Must be a Facebook thing.
 

Undead_Steve

New member
Jul 27, 2013
5
0
0
Visit site
Still happening for me as well on my Surface RT with 8.1 Preview - I assume it's something changed on Facebook's end, since it worked just s few days ago.
I'm curios whether this is will happen once we get the 8.1 RTM on our Surfaces in 2 weeks.
 

dhyna143

New member
Nov 4, 2013
3
0
0
Visit site
Turn windows features on or off

I'm using RT 8.1 as well, but the compatibility view didn't work for me neither. I tried these steps and it worked for me.

1. Use CHARM to search for 'Turn windows features on or off' and SELECT it.
2. Windows Features window will open with a list of folders. Uncheck folder 'Internet Explorer11' then OK. It will ask you to restart.
3. RESTART your device.

Once you logged back in, repeat the process but this time you'll put the check back for folder 'Internet Explorer11'. After you RESTART your device for the second time, open your IE and type the URL in the address bar such as facebook.com. You should not see the message anymore asking to 'switch browser' or something. I hope this helps. :smile:
 

dhyna143

New member
Nov 4, 2013
3
0
0
Visit site
Thank you for starting this thread. I thought it was just me.


Thanks, but it did not work for me.


I'm using RT 8.1 as well, but the compatibility view didn't work for me neither. I tried these steps and it worked for me.

1. Use CHARM to search for 'Turn windows features on or off' and SELECT it.
2. Windows Features window will open with a list of folders. Uncheck folder 'Internet Explorer11' then OK. It will ask you to restart.
3. RESTART your device.

Once you logged back in, repeat the process but this time you'll put the check back for folder 'Internet Explorer11'. After you RESTART your device for the second time, open your IE and type the URL in the address bar such as facebook.com. You should not see the message anymore asking to 'switch browser' or something. I hope this helps. :smile:
 

dhyna143

New member
Nov 4, 2013
3
0
0
Visit site
Was coming here to ask about the same thing. Did the trick above but now I have a banner asking me to upgrade my browser. Not having a problem like this with any other sites or devices. Must be a Facebook thing.

I'm using RT 8.1 as well, but the compatibility view didn't work for me neither. I tried these steps and it worked for me.

1. Use CHARM to search for 'Turn windows features on or off' and SELECT it.
2. Windows Features window will open with a list of folders. Uncheck folder 'Internet Explorer11' then OK. It will ask you to restart.
3. RESTART your device.

Once you logged back in, repeat the process but this time you'll put the check back for folder 'Internet Explorer11'. After you RESTART your device for the second time, open your IE and type the URL in the address bar such as facebook.com. You should not see the message anymore asking to 'switch browser' or something. I hope this helps. :smile:
 

Members online

Forum statistics

Threads
323,160
Messages
2,243,361
Members
428,031
Latest member
MatthewHilbers