Forced to hard reset

markwill

New member
Apr 10, 2011
3
0
0
Visit site
I have twice found that my HTC Arrive gets into a frozen state when the battery is removed. When replaced and turned on the initial HTC banner is displayed - and then stays there. I've waited a long time (10+ mins at one time) and it just doesn't progress. The phone is completely frozen - even the power button doesn't work.

My only resolution is to remove the battery again and restore to factory defaults (Volume Up/Down + power) - not a good solution. After doing this the phone works fine (except I have lost all my data and customisations!).

Any thoughts?

Thanks.

Mark
 

eric12341

New member
Dec 1, 2009
2,637
3
0
Visit site
are u powering down the device before removing the battery? not doing so may have corrupted the memory units inside, even PCs can have this happen if nit plugged into a surge protector. the other thing I can think of is maybe it is already defective as there are at least 2 or 3 in every bunch.
 

markwill

New member
Apr 10, 2011
3
0
0
Visit site
are u powering down the device before removing the battery? not doing so may have corrupted the memory units inside, even PCs can have this happen if nit plugged into a surge protector. the other thing I can think of is maybe it is already defective as there are at least 2 or 3 in every bunch.

Yes, the only reason I have ever removed the battery is when I have had no choice. It does look like some storage corruption to me. Factor reset fixes the issue but this is the second time this has happened in two days so it's a real pain.

Thanks.

Mark
 

drezzzzy

New member
Apr 7, 2011
5
0
0
Visit site
Hi, I am a Sprint employee and I've been using the Arrive for about a week now. What you described definitely should not be happening and to my knowledge this is not a known issue. You may just have a defective device so if the problem persists then I would take it to your nearest Sprint store and get it replaced. Good Luck.
 

markwill

New member
Apr 10, 2011
3
0
0
Visit site
Hi, I am a Sprint employee and I've been using the Arrive for about a week now. What you described definitely should not be happening and to my knowledge this is not a known issue. You may just have a defective device so if the problem persists then I would take it to your nearest Sprint store and get it replaced. Good Luck.
I did return the phone and have to say I was pleased with Sprint's response (no questions asked, immediate swap for anothet phone and - incidentally - $160 in trade-in for our four HTC Hero's). Pretty pleased with the response to be honest.

My new Arrive has worked flawlessly since.

Thank.

Mark
 

drezzzzy

New member
Apr 7, 2011
5
0
0
Visit site
I did return the phone and have to say I was pleased with Sprint's response (no questions asked, immediate swap for anothet phone and - incidentally - $160 in trade-in for our four HTC Hero's). Pretty pleased with the response to be honest.

My new Arrive has worked flawlessly since.

Thank.

Mark
Wow sounds like some great customer service!! Hopefully that was just some bad luck with a faulty device. Thanks for your patience and thanks for the feedback!
 

zeroy

New member
May 29, 2011
1
0
0
Visit site
Same issue, more severe!!!

Have had phone since release and no issue until NOW!!! touchscreen is slow and unresponsive
after I reset the phone the problem persisted. I also have not damaged the phone in any way. Will seek replacement, but i didnt get insurance. I came to sprint for this phone, so they better stand by their product.
 

Members online

Forum statistics

Threads
323,208
Messages
2,243,460
Members
428,046
Latest member
shadow1412