• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

RAM not detected

  • Thread starter Windows Central Question
  • Start date

Windows Central Question

Sir, I am facing an issue, please resolve this.

Recently I bought a new 4GB DDR4 RAM stick for my pc with the hope of doubling it, previously I had one 4GB stick. I bought the same brand same model RAM (Crucial Basics 4GB DDR4 RAM, model number: CB4GU2666). When I installed it into the other memory slot of the motherboard (Gigabyte GA-A320M-S2H, rev 2.0, has two memory slots, dual-channel configuration) and tried to boot up, it disappointed me. It didn't boot up. But the fans (CPU fan, power supply fan, and the cabinet fan) were moving.

Firstly I thought that the RAM is faulty, but it isn't. When I replaced the old RAM and put it into that slot (slot 2), it finely boots up. So the new RAM is okay.

Case 1: Any RAM (one at a time) in slot 1, the system does not boot up, no display.

Case 2: Any RAM (one at a time) in slot 2, the system boots up and works fine.

Case 3: Putting the two RAMs in both slots i.e. the new into slot 1 and the old into slot 2 or the new into slot 2 and the old into slot 1, the system doesn't boot up. The same happens as case 1.

My PC configuration:

OS: Windows 11 (Recently upgraded)

Processor: AMD Athlon 3000G processor with integrated AMD Radeon Vega 3 Graphics (64-bit compatible processor)

Motherboard: Gigabyte GA-A320M-S2H rev 2.0

RAM: Crucial 4GB DDR4 2666 MHz RAM

Sir, whenever I put a RAM in slot 1, the system doesn't boot up, no display. Strange thing is, even slot 2 has a RAM, the system does not show display because of putting RAM in slot 1.

I am sure there is something wrong with that slot. please suggest to me what I should do.

Things I have tried:

1. Cleaned several times slot 1 with a dry fresh cloth.

2. Opened the processor and tried to find fault in the CPU socket in the motherboard, but could not find any.

3. Opened the CMOS battery, cleaning it reinstalled. Means the bios is now reset.

4. Disconnecting the mechanical Hard Drive (I have an SSD as well, where the OS is installed)


New member
Nov 15, 2017
Sounds to me like there is something miss with the mobo. Do you still have warranty on it? Or you could send back the new ram and get a 8 gb ram stick for the 2nd slot only.


New member
Jan 15, 2013
It sounds to me like the slot on the motherboard is the culprit. Since the system boots fine regardless of which chip is in slot 2 this indicates to me the chips are fine.

Members online

Forum statistics

Latest member