Help! I'm not getting notified about app updates!

markfive

Member
Oct 27, 2012
384
0
16
Visit site
Here’s a quick guide on problems you might experience with being notified about app updates.

If you think you have a problem with app update notifications, there are some steps to go through that hopefully will get your update notifications working again. The key to this is a little patience – don’t try all the fixes in one go, and be prepared to wait a few hours to see if things improve.

How things should work
The Store app on your phone has a live tile – if you pin it to your start screen then it is intended that the tile displays the number of app updates available to you. This process works just fine for a lot of people, but some do seem to have problems with the reliability of these updates. Exactly why is a subject clouded in mystery and speculation. There doesn’t seem to be a single magic cure. Fortunately there are some steps you can take to get things up and running again.

Firstly, a little expectation setting – app update notifications are not immediate. Just because you see an article about your favourite app getting updated, it may take hours before your Store tile shows that an update is available. In my experience, the Store live tile updates about once every 24 hours.

How do you know you might have a problem?
So, you've seen a news item on WPCentral that your favourite app got an update this morning. But your Store tile pinned to your start screen doesn't show any app updates pending. If you’ve not had a notification after A Reasonable Time™ (or, like me, you’re just impatient
wink.png
) then go to the app’s page in the store and see if it shows the “update” button. Just because it does (and it invariably will) it doesn't mean that you have a problem. In truth the only way you will know is if the app was updated more than 24 hours ago (check the date in the store). If the date of last update is not today then you should work through each of the following steps to see which (if any - there are no guarantees that any of these will sort your problem) get your notifications going again.

Check you have push notifications enabled in Find My Phone
Go to settings > find my phone and tick “Send apps to my phone using push notifications (not SMS)”. Restart your phone.
If you already have push notifications switched on, try switching it off (untick the box), restarting your phone and then switching it back on again.

Re-pin the Store live tile
Remove the Store live tile from your home screen. Restart your phone and then add the live tile back to your home screen

Re-pin the Store live tile and clear your IE history

This is a variation on the previous - as well as removing the Store live tile, clear your IE history by opening IE and selecting settings > delete history. Then soft-restart your phone (power off and then power on whilst holding the volume down key down) and add the live tile back.

Try using cellular data only
Some people have reported better reliability of push notifications over cellular data connections. If you spend a lot of time on wifi this can be worth checking out.

Disable your wifi connection (settings > WiFi > WiFi networking > slide to off) and restart your phone. An extra step that might help this to work is to ensure that you a) have a good cellular signal and b) a working data connection after turning off wifi and before restarting your phone. A quick browse of www.wpcentral.com will do the trick for the latter!

If this does work for you, it’s possible that something related to the wifi connection is blocking the notification channel – if this is the case then you may find that other notifications become more reliable as well.

Help us to help you
Did one of these methods get your notifications going again? Have you managed to sort out this problem using another method? If so, please post here so we can all help each other out!
 
Last edited:

jbjtkbw007

New member
Mar 10, 2012
322
1
0
Visit site
While I don't have any problems with updates, I am an IT Helpdesk Manager. I can appreciate the step-by-step process in offering up a solution to this problem, and it's very easy to follow. Bravo on your efforts here.
 

jojapath

New member
Mar 14, 2013
317
0
0
Visit site
Well for me, the first option worked. The only difference is that when I went into SETTING and checked, it was already ticked so I unticked it, waited a couple of seconds and ticked it again then restarted.

I've been receiving updates ever since !!!
 

Ishan Pandya

New member
Aug 1, 2013
12
0
0
Visit site
Hi. I have a Nokia Lumia 620 and I have the same issue for which you have posted the fix. I tried all the options which you have mentioned in the first post, but have no luck.

I have made a suggestion in the community for a manual check for update button for the installed apps. Do vote for the same.
 
Last edited:

njnbat

New member
Mar 6, 2013
118
0
0
Visit site
Hi , first of all i appreciate your efforts in listing down the step by step procedures. I have encountered a similar issue of live tile not getting updated . However when i visit settings->find my phone, i see only one option and that is find my phone . i dont see the below option .
Go to settings > find my phone and tick “Send apps to my phone using push notifications (not SMS)”. Restart your phone.

Can u pls help me out . Meanwhile i am trying my luck with the second option of restart.
 

RAUB

New member
Aug 11, 2013
9
0
0
Visit site
Hi. I have a Nokia Lumia 620 and I have the same issue for which you have posted the fix. I tried all the options which you have mentioned in the first post, but have no luck.

I have made a suggestion in the community for a manual check for update button for the installed apps. Do vote for the same.

The same here with my Lumia 925... and nothing helps. I've voted.
 

fantakk

New member
May 1, 2013
64
0
0
Visit site
From the Support chat they suggest me to hard-reset my phone and set my date+time to manual and eventually install my keyboard before configuring my Microsoft Account.
They told me that configuring the Main account is the last thing you shoul do. I let you know if I solve that way.
 

speedtouch

New member
Jan 23, 2012
1,043
0
0
Visit site
I've had no update notifications for about 3 weeks now. I fixed it today. I followed all the steps in the original post for weeks now, but sadly, they did not work for me. Here's what worked for me.

Unpin the Store tile
Go to Settings > Find my phone > Uncheck 'Send apps to my phone...'
Go to Settings > Phone update > Uncheck 'Tell me when..' and ' Automatically download...'
Delete history in Internet Explorer
Shut down phone and remove battery for 2 minutes

Boot up phone
Pin the Store tile
Go to Settings > Find my phone > Add a check mark to 'Send apps to my phone...'
Go to Settings > Phone update > Add a check mark to 'Tell me when..' and ' Automatically download...'
Delete history in Internet Explorer
Shut down phone and remove battery for 2 minutes

Boot up phone
Got 8 update notifications about 30 minutes later

I left WiFi and cellular data enabled during the entire process.
 

RAUB

New member
Aug 11, 2013
9
0
0
Visit site
I've had no update notifications for about 3 weeks now. I fixed it today. I followed all the steps in the original post for weeks now, but sadly, they did not work for me. Here's what worked for me.
...

Thanks for sharing with us your experience. But the problem is some our devices, like my lumia 925 for example, simply have no removable battery...

I followed your solution (excepting battery removing ofc) but no luck, still no update notifications in Store. Also, instead of phone shutdown with battery removing, I tried to reset my device. Unfortunately with the same result.
 

speedtouch

New member
Jan 23, 2012
1,043
0
0
Visit site
Thanks for sharing with us your experience. But the problem is some our devices, like my lumia 925 for example, simply have no removable battery...

I followed your solution (excepting battery removing ofc) but no luck, still no update notifications in Store. Also, instead of phone shutdown with battery removing, I tried to reset my device. Unfortunately with the same result.

Well, crap. Sorry it didn't work out for you. I really wish there were no non-removable battery phones out there. It's such a pain when you need to really do some hard troubleshooting and clearing of memory, etc. I'm surprised it didn't work for you even after a soft reset. Supposedly a soft reset is equivalent to a battery pull. I guess not!
 

RAUB

New member
Aug 11, 2013
9
0
0
Visit site
Well, crap. Sorry it didn't work out for you. I really wish there were no non-removable battery phones out there. It's such a pain when you need to really do some hard troubleshooting and clearing of memory, etc. I'm surprised it didn't work for you even after a soft reset. Supposedly a soft reset is equivalent to a battery pull. I guess not!

To be honest it's already driving me mad... I don't understand why the Store is not checking for update at start. It could be partial, of course, but solution though.

Related our problem, I specially kept a several (not really important for me) apps outdated and I'm still not notified about new versions. Weird but it is.
 

Ishan Pandya

New member
Aug 1, 2013
12
0
0
Visit site
I've had no update notifications for about 3 weeks now. I fixed it today. I followed all the steps in the original post for weeks now, but sadly, they did not work for me. Here's what worked for me.
...
It doesn't work for devices with removable batteries as well. I tried your solution with lumia 620, waited 3 days and have not found the solution. Also manually checked app for update(found 1), did not update the app and waited for 1 more day, but it doesn't work. Hopefully MS finds a solution for this.
 

fantakk

New member
May 1, 2013
64
0
0
Visit site
It doesn't work for devices with removable batteries as well. I tried your solution with lumia 620, waited 3 days and have not found the solution. Also manually checked app for update(found 1), did not update the app and waited for 1 more day, but it doesn't work. Hopefully MS finds a solution for this.

Same phone and same problem here. Do you already have installed "Amber"? And how's set your date+time Manual or Automatic? Thanks
 

Ishan Pandya

New member
Aug 1, 2013
12
0
0
Visit site
Hi guys.
I tried a solution shared by a member
Steps are as below:
1.Closed all tabs lying in internet explorer.
2.Clicked on delete history button in settings of internet explorer.
3.Removed the live tile .
4.Did a soft reset by pressing volume down and lock button together.
5.Pinned the live tile back

I tried it on my Lumia 620, and got 4 updates (I was updating apps by manually checking previously). Also before I started checking for updates I check for one app which had an updated closed the store app (DID NOT Update the app).
Hope This helps. Good Luck.
 

Muessig

Moderator Team Leader
Sep 30, 2012
5,647
1
36
Visit site
Hi guys.
I tried a solution shared by a member
Steps are as below:
1.Closed all tabs lying in internet explorer.
2.Clicked on delete history button in settings of internet explorer.
3.Removed the live tile .
4.Did a soft reset by pressing volume down and lock button together.
5.Pinned the live tile back

I tried it on my Lumia 620, and got 4 updates (I was updating apps by manually checking previously). Also before I started checking for updates I check for one app which had an updated closed the store app (DID NOT Update the app).
Hope This helps. Good Luck.

This tip is already listed in the OP. Glad it worked, though!
 

fantakk

New member
May 1, 2013
64
0
0
Visit site
Hi guys.
I tried a solution shared by a member
Steps are as below:
1.Closed all tabs lying in internet explorer.
2.Clicked on delete history button in settings of internet explorer.
3.Removed the live tile .
4.Did a soft reset by pressing volume down and lock button together.
5.Pinned the live tile back

I tried it on my Lumia 620, and got 4 updates (I was updating apps by manually checking previously). Also before I started checking for updates I check for one app which had an updated closed the store app (DID NOT Update the app).
Hope This helps. Good Luck.

How long did you wait?You have Skype? Thank you :)
 

Members online

No members online now.

Forum statistics

Threads
323,197
Messages
2,243,435
Members
428,035
Latest member
jacobss