how can i install .xap without SD card?

  • Thread starter WPCentral Question
  • Start date

WPCentral Question

i have a nokia illumia 925.2 and it doesn't have an SD card, and the wifi is not competible with my very old router (i use cables at home)
so i want to install some apps, and i downloaded the .xap files to my computer, and then copied into the 925.2's internal storage, but it doesn't allow me to start the .xap... any help?


New member
Jul 14, 2011
Visit site
It's not enough to copy the XAP, it must be deployed using Windows Phone Application Deployment tool (or from Store of course), which is a part of Windows Phone SDK. You must register your phone as a Developer one to do that. See details here: How to deploy and run an app for Windows Phone 8

That's true if he downloaded some ripped XAP file from any source other than the Windows Phone Web Store. In this case I wouldn't even tell him how to correctly deploy, install and run it, tbh. But if he got the XAP from the web store, he just needs to copy or move it over to the root folder of his device. When he now opens the store on his device and pulls up the bottom app bar, it should show an option called "install local files" or so. Tapping on that should display a list of all found XAPs. Tapping on one of these will install the game or app. If the device meets the requirements and - in case of a paid app - he purchased the app beforehand.


New member
Jan 23, 2013
Visit site
I still don't know the option to deploy .xap file to the windows phone.

Few facts:

- The phone is HTC 8X without SD card
- The phone is running Windows Phone 8.0 and not 8.1
- The option install local from the windows store ( on your phone) is only available when you running 8.1

I do have VS 2013 installed and the phone is unlocked. When I try to deploy any app downloaded from the Windows Store (Web) via Application deployment tool (part of VS 2013) it says XAP file invalid.

Looks like I'm at square one......

Did anyone tried to download any app from the windows store (web) manually and tried to deploy it not via SD card or copying it to the phone but via the VS 2013 tool Application Deployment? Is anybody also getting 'XAP file invalid'?


Forum statistics

Latest member