How to Prevent Cortana From Searching OneDrive (cloud) on PC?

Rvacha

New member
Nov 27, 2015
47
0
0
Visit site
Somewhere during the RS1 development MSFT introduced a Cortana search behavior that drives me crazy. All of my PCs are now running AU. All of my docs on the PCs are in the OneDrive folder. If I type in a word or phrase Cortana will provide results from my *local PC* that includes file names or folder names that match. If, however, I want to search the contents of documents for the word or term (by clicking on Cortana's documents icon or typing "document: blah blah blah" EVERY result is a OneDrive (cloud) result instead of a OneDrive (local PC) result even though the PC has the exact same exact doc. In fact it NEVER provides a OneDrive (local PC) result. This results in Cortana fetching the doc from the cloud and opening it in Edge instead of opening with an app on my PC.

In other words, what I want is for Cortana to always provide ONLY search results from files in my PC's OneDrive - why should I have to have every document downloaded from the cloud when it is sitting right on my PC in the OneDrive folder?. In older version of Cortana there used to be an option to search "My Stuff" which would only return local PC results, but that is gone now.

There were some things that could be done with group policy ("Do not allow web search" & "Don't search the web or display web results in search") but these policies have no effect anymore. Any ideas?
 

ven07

New member
Jan 27, 2014
6,892
2
0
Visit site
just above the search box (after entering search terms) there are a few icons, which can help to filter the results. Did you try those?
 

Rvacha

New member
Nov 27, 2015
47
0
0
Visit site
The icons are no longer just above the box, they are now along the very upper edge (for AU/RS2). Yes, the document icon up there is what I have tried. When you click the documents icon the search box automatically fills in with "document: (whatever you typed)" and that always fetches the cloud file instead of the local file
 

ven07

New member
Jan 27, 2014
6,892
2
0
Visit site
The icons are no longer just above the box, they are now along the very upper edge (for AU/RS2). Yes, the document icon up there is what I have tried. When you click the documents icon the search box automatically fills in with "document: (whatever you typed)" and that always fetches the cloud file instead of the local file

Ah yes I was still in the process of upgrading ro the first RS2 build..

How about signing out of onedrive and checking if search will just allow you to look for local documents? it's a bit of work tho
 

Rvacha

New member
Nov 27, 2015
47
0
0
Visit site
After searching the interwebs high and low I finally gave up and disabled Cortana using Group Policy. Search works great - unless you try to search within Settings - it turns out nothing is found without Cortana working. I'd LOVE to get Cortana back, but I cannot allow my productivity to be impacted. If anyone has any other ideas I'd sincerely love to hear them
 

Members online

Forum statistics

Threads
323,694
Messages
2,244,233
Members
428,102
Latest member
Korshun