Its getting quite frustrating

anon(7935575)

New member
Aug 15, 2013
316
0
0
Visit site
Hello, I have a Lumia 520. Over some time I've been having problems with apps force closing. Like they just stop responding and crash. Some even crash without any lag. :/ I guess its because of less RAM?

I've done these things:
- Soft reset.
- Hard reset.
- Restarted ofcourse.
- Disabled all background apps except what's app.

Apart from this when browsing net, tabs tend to automatically reload themselves when I switch to them. Can anyone help me out with that?

Some apps i had these problems with are UC Browser, Get them all, Surprisingly tapatalk app too, what's app. :/

Any fix or any suggestion is welcome... Thanks a lot. :D



Sent from my RM-914_im_india_269 using Tapatalk
 

mase123987

New member
Mar 1, 2012
3,118
0
0
Visit site
Have you tried a factory restart? Three people in my family have the 520/521, and none of them have this issue. You shouldn't be seeing the crashes.
 

anon(7935575)

New member
Aug 15, 2013
316
0
0
Visit site
I did... That's what I meant by reset. I also did the soft reset which is done by power button and volume down... Unfortunately nothing...

Can it have anything to do with memory free? I have 2 GB of memory left... RAM I don't know because we cant access it. :(

Its quite weird. Anyways thanks for reply... Maybe they'll disappear after GDR2 update. Who knows.

Sent from my Nokia Lumia 520 using Tapatalk.
 

mase123987

New member
Mar 1, 2012
3,118
0
0
Visit site
My bad...I would look through the comments in the store of apps that are giving you issues. Maybe you will find a trend and know what apps not to use. If there isn't any trends, I would do a factory reset again. Believe it or not, sometimes fixing a problem happens after doing it twice (speaking in general terms with experience with all the different smartphone OSes).
 

anon(7935575)

New member
Aug 15, 2013
316
0
0
Visit site
Thanks a lot :) Yeah ill do that. Im waiting for update.. I'll do a fresh reset. I'll manage my phone till then. :)

Sent from my Nokia Lumia 520 using Tapatalk.
 

mase123987

New member
Mar 1, 2012
3,118
0
0
Visit site
Good Luck! i wish I could be more help, but I am just not experiencing any of the same issues on my phone or family members' phones.
 

Members online

Forum statistics

Threads
322,407
Messages
2,241,962
Members
427,920
Latest member
ohlawd