Left BlackBerry for 520.....Worried I will need to go back!

Wesley Killman

New member
Sep 9, 2013
1
0
0
Visit site
I have had this phone for 2 weeks now.

Several Apps crash randomly from day 1, (Jewel Hunter - always dies after a period of time), (Google App - now wont even stay open for 2 seconds)

Connectivity - Even with wifi and 4G or 3G most apps wont update regularly, twitter swears there is no internet 75% of the time, gmail times out 50% of the time, and even internet explorer fails to find internet frequently!

Phone - it doesn't seem to search "people" effectively to find contacts to call, I often have to find peoples numbers in "people" rather than just search on the phone function.

Is this phone really this buggy or have I done something wrong? I get that Apps my get corrupted but what is with the connectivity?
 

Jazmac

New member
Jun 20, 2011
4,995
4
0
Visit site
You have a bad handset or need your carrier to intervene in your service. Sounds like your carrier to me. The 520 is a very good handset. I got one for my daughter and she never complains about it.
 

faceless_el

New member
Jul 26, 2013
30
0
0
Visit site
never had issues with my 520. I myself came from a blackberry and from time to time miss the physical keyboard but with the Lumia 520 I don't miss the constant battery pull and lag on blackberries.
 

xumit

Member
Sep 6, 2013
106
0
16
Visit site
Network problem is more of carrier problem. Reset the OS for app crash problem, it may solve most of the problems. if thats not working, Try replacing the handset.
 

crash1989

New member
Oct 30, 2012
1,491
0
0
Visit site
I have had this phone for 2 weeks now.

Several Apps crash randomly from day 1, (Jewel Hunter - always dies after a period of time), (Google App - now wont even stay open for 2 seconds)

Connectivity - Even with wifi and 4G or 3G most apps wont update regularly, twitter swears there is no internet 75% of the time, gmail times out 50% of the time, and even internet explorer fails to find internet frequently!

Phone - it doesn't seem to search "people" effectively to find contacts to call, I often have to find peoples numbers in "people" rather than just search on the phone function.

Is this phone really this buggy or have I done something wrong? I get that Apps my get corrupted but what is with the connectivity?

Maybe .. just maybe ..

Are you using Battery Saver the whole time? If you are tiles won't be live most of the time and might cause WIFI to disconnect. It won't crash the apps like yours.

The search button at the bottom is for Bing search and other scanning related functions, it is not a universal search.
 

Members online

Forum statistics

Threads
322,538
Messages
2,242,230
Members
427,958
Latest member
gorly3