Lost ICS on Upgrade to 6.1

AEngineer

New member
Aug 20, 2008
3
0
0
Visit site
I just updated my Q9h to 6.1 and am generally happy.

I'm having trouble, however, with Internet Connection sharing, which worked with 6.0. Now when I select "connect" it checks the cable and then goes to an endless "waiting for network".

The settings are
PC Connection - USB
Network Connection - ATT ICS
I'd note that there is also a "MEdia Net" showing under GPRS connections, but it's not an option under ICS.

For what it's worth the PC I'm connecting to is a Lenovo V100 running XP-SP3 with ActiveSync 4.5

Any suggestions?
 

brianp48093

New member
Aug 25, 2008
1
0
0
Visit site
You have to edit the registry. 6.1 locked the ICS unless you have a tethering plan plus unlimited data plan. Someone correct me if I'm wrong Here are the steps to enable your phone to tether. This works...I'm tethering as I write this. :D

Enable Tethering via Internet Sharing using the MEdiaNet connection
HKLM\Comm\InternetSharing\Settings
In here will be a value named "ForceCellConnection"
Change "ATT ICS" to "" and reboot.
ICS will now allow you to choose either ATT ICS or MEdia. ATT ICS will not work without a tethering plan on your wireless account, but MEdia Net will work as long as you have the signal and the basic pay-as-you-go feature (not recommended).
ATT ICS uses "isp.cingular" (tethering) whereas MEdia Net uses "wap.cingular" (general internet).

Unlocking ICS and Media Net
The ATT ICS and MEdia Net entries in the connection settings dialog are read only and won't let you edit them, But if you navigate to:
HKLM\Comm\ConnMgr\Providers\{7C4B7A38-5FF7-4...}\Connections
There will be 2 keys in there. one for ATT ICS and MEdia Net. In those keys there will be a value of ReadOnly. Change the value for these from 1 to 0 and reboot your phone. These connections should now be editable.
This post was made via tether w/o plan and via USB connection
 

gundojack

New member
Sep 7, 2008
2
0
0
Visit site
I have a BlackJackII which I upgraded to 6.1 using the instructions and ROM from Samsung site with no problems. The phone works really well.

I'd like to be able to tether the phone via USB to my Lenovo T60 in the rare case that there isn't any internet access somewhere.

I also have a MediaNet 1500 Bundle which includes unlimited Data. With my BJ1 I never had any problems tethering the phone to my PC and surfing my heart out.


I've successfully run the SDA_ApplicationUnlock.exe tool from my laptop.

Using Pocket Controller Pro I've edited the registry setting described in Enable Tethering section above. One issue I had is that i've replaced the AT&T ISP text with a space. Then rebooted the device.

When opening ICS the connect button is greyed out and I can't connect.

Should I use something other than a space?

Did I miss a step?

To continue - I followed the instructions under the Unlocking ICS and found some inconsistencies. There are actually three providers: AT&T IMS, AT&T ISP and MEdia Net. I've changed all 3 read only sections to Zeros and restarted soft and hard. Still Nothing.

I'm certain I'm missing a step somewhere.

--Just a note - I have a MediaMax 1500 unlimited data plan and used to use ICS with my BJ1 flawlessly.
 
Last edited:

jeromio

New member
Sep 16, 2008
2
0
0
Visit site
I've changed the registry to edit the readonly and the ForceCellConnection values. Now I can connect via ICS and MEdia Net. However, I don't get a proper IP address. I always get a bogus 169.254 address, therefore, no internet connectivity.

Any ideas? I also cannot use the phone as a modem. I always get error 719, timeout. This is a blackjack 2 w/ WM6.1 on a Windows Vista Business laptop.
 

jeromio

New member
Sep 16, 2008
2
0
0
Visit site
Well, this is even weirder and more frustrating. Now my phone will not connect un-tethered. I can't go online or get email from the phone itself. I tried undoing my reg changes, but that didn't fix it.
 

techboydino

New member
Sep 1, 2008
2
0
0
Visit site
i can successfully connect using ICS but I still cannot get through to the internet. I did the reg fixes and can connect using ICS through usb cable. my laptop connects and gets an 0.2 ip address at 10Mbps. is there something else i need to do in order to connect to the web? do i need to change any settings under the proxy or wap? thanks.
 

berdinkerdickle

Retired *********
Dec 3, 2005
128
0
0
Visit site
i can successfully connect using ICS but I still cannot get through to the internet. I did the reg fixes and can connect using ICS through usb cable. my laptop connects and gets an 0.2 ip address at 10Mbps. is there something else i need to do in order to connect to the web? do i need to change any settings under the proxy or wap? thanks.

Where you get the choice to choose USB or Bluetooth there's also an option to choose ICS or Medianet.
You need to choose Medianet.
 

berdinkerdickle

Retired *********
Dec 3, 2005
128
0
0
Visit site
I have a BlackJackII which I upgraded to 6.1 using the instructions and ROM from Samsung site with no problems. The phone works really well.

I'd like to be able to tether the phone via USB to my Lenovo T60 in the rare case that there isn't any internet access somewhere.

I also have a MediaNet 1500 Bundle which includes unlimited Data. With my BJ1 I never had any problems tethering the phone to my PC and surfing my heart out.


I've successfully run the SDA_ApplicationUnlock.exe tool from my laptop.

Using Pocket Controller Pro I've edited the registry setting described in Enable Tethering section above. One issue I had is that i've replaced the AT&T ISP text with a space. Then rebooted the device.

When opening ICS the connect button is greyed out and I can't connect.

Should I use something other than a space?

Did I miss a step?

To continue - I followed the instructions under the Unlocking ICS and found some inconsistencies. There are actually three providers: AT&T IMS, AT&T ISP and MEdia Net. I've changed all 3 read only sections to Zeros and restarted soft and hard. Still Nothing.

I'm certain I'm missing a step somewhere.

--Just a note - I have a MediaMax 1500 unlimited data plan and used to use ICS with my BJ1 flawlessly.

Not sure:

I changed "ATT ICS" to "" and reboot. I think a if brian was suggesting a space he would of said: " "
I didn't add a space, I just deleted ATT ICS.
I'm not sure if that's your problem.
 

berdinkerdickle

Retired *********
Dec 3, 2005
128
0
0
Visit site
Well, this is even weirder and more frustrating. Now my phone will not connect un-tethered. I can't go online or get email from the phone itself. I tried undoing my reg changes, but that didn't fix it.

If you lost internet altogether, I'm not sure if you will need to do a Hard-Reset.
 

berdinkerdickle

Retired *********
Dec 3, 2005
128
0
0
Visit site
I've changed the registry to edit the readonly and the ForceCellConnection values. Now I can connect via ICS and MEdia Net. However, I don't get a proper IP address. I always get a bogus 169.254 address, therefore, no internet connectivity.

Any ideas? I also cannot use the phone as a modem. I always get error 719, timeout. This is a blackjack 2 w/ WM6.1 on a Windows Vista Business laptop.

I didn't do those changes.
All I did was changed "ATT ICS" to "" and reboot.
 

Members online

No members online now.

Forum statistics

Threads
323,770
Messages
2,244,349
Members
428,122
Latest member
postman