Lumia 920 - Wireless charging issues

Mr. Brown

New member
Oct 22, 2012
291
0
0
Visit site
I have a red Lumia 920 and a wireless charger that came with my AT&T order. When I set my phone on the wireless charger, I see a LED light show up on the charger and the phone also shows an icon that it is charging and it makes the sound when power is plugged into it. The odd thing is, the phone is not charging while on the wireless charger. It's actually losing battery life when sitting there. I just had it on there for 10 min and it lost 1% of battery life. Is anyone else experiencing this?


Edit: I should have mentioned previously that I tried restarting my phone and also tried unplugging the wireless charger. Still didn't change anything. This is my second 920, my first 920 worked on the wireless charger, I just bricked it when I tried doing a reset in the about option.
 
Last edited:

theprawn

New member
Jul 1, 2011
74
0
0
Visit site
That's... not how it's supposed to work. Worst case scenario, my phone is hot on the charger but it IS charging. Reboot and cross your fingers?
 

Mr. Brown

New member
Oct 22, 2012
291
0
0
Visit site
That's... not how it's supposed to work. Worst case scenario, my phone is hot on the charger but it IS charging. Reboot and cross your fingers?

I should have mentioned in my post that I have already tried restarting my 920 and I also tried unplugging and plugging the wireless charger back in. :(
 

doublesman3486

New member
Oct 23, 2012
193
0
0
Visit site
If you have a fat boy pillow, it doesn't matter what position you place your phone on the charging pillow, it will charge. However with the wireless charging pad the phone has to be placed on the charger anywhere from just below the camera strip on the body of the phone to just before the camera lens on the charging pad.
 

lifesizepotato

New member
Nov 14, 2012
11
0
0
Visit site
^^^^^^^
Posted while typing my response below. Good to know! I bet there's something about it in the manual, too, which I of course haven't read.

I got my charging plate today, and the issue I'm having with it is that the phone needs to be very particularly positioned for it to keep charging. In promo shots, people are casually laying their 920s at random angles on the plate, but when I try to do that, it does the charging sound, and then 5 seconds later, does it again, and then again 5 seconds later, on and on, as if it keeps losing connection and then reconnecting. It seems like it only stays quiet (and stays charging) if the phone is pretty much in one position, lined up with the pad. The phone does end up pretty toasty by the time I take it off, too.
 

Mr. Brown

New member
Oct 22, 2012
291
0
0
Visit site
If you have a fat boy pillow, it doesn't matter what position you place your phone on the charging pillow, it will charge. However with the wireless charging pad the phone has to be placed on the charger anywhere from just below the camera strip on the body of the phone to just before the camera lens on the charging pad.

I've tried lining up the bottom of the phone with the bottom of the charging pad (where the led light is). The led light is a solid light when in this position. If I move the phone up higher on the pad, the light starts to blink slowly.
 

Hoan Cho

New member
Nov 24, 2012
1
0
0
Visit site
Same thing here, I have a black Lumia 920 and it does work on both our wireless chargers, my wife have a red glossy one and it doesn't charge, the light in the charger turns on but the phone don't start charging (no update on the battery icon, no sound notification, battery still drop)
 

joeaux

New member
Mar 6, 2012
126
0
0
Visit site
It's broken. I can lay my Lumia on it just about any orientation as long as it's on it's back and the thing chimes, LED comes on and the phone will charge. When it's done the LED goes off. Exchange yours.
-joe-
 

Mr. Brown

New member
Oct 22, 2012
291
0
0
Visit site
It's broken. I can lay my Lumia on it just about any orientation as long as it's on it's back and the thing chimes, LED comes on and the phone will charge. When it's done the LED goes off. Exchange yours.
-joe-


Looks like I'll have to do that . I was hoping I wouldn't have too because I already replaced it once and I don't want to go through the trouble of a reset again.
 

Matt Sharpe

New member
Nov 13, 2012
15
0
0
Visit site
My Lumia 820 previously worked fine on its wireless charger, but today it is refusing to charge. The LED comes on, and the charger can even cause the phone to boot, but it doesn't actually charge.

Have tried rebooting, and power cycling the charger.

Edit: Discovered why - one of the 4 pins that connects the phone to the backplate is stuck in and doesn't spring out, therefore isn't contacting the backplate properly.
 

Steve Ridges

New member
Nov 9, 2012
157
0
0
Visit site
It's broken. I can lay my Lumia on it just about any orientation as long as it's on it's back and the thing chimes, LED comes on and the phone will charge. When it's done the LED goes off. Exchange yours.
-joe-

Your LED goes off? My charger seems to work fine and when I take my phone off it's always at 100% but my LED never goes off.
 

en0x#AC

New member
Jan 9, 2012
89
0
0
Visit site
Your LED goes off? My charger seems to work fine and when I take my phone off it's always at 100% but my LED never goes off.

I have the same issue. the led never goes off but the phone is charged...
before i replaced my phone the led was working fine and it turned off after the phone was charged... i guess it has to do with a phone?
 

ryanj04

New member
Oct 31, 2012
36
0
0
Visit site
I was having the same issue! Except with mine it would buzz when I put it on the charger and the charging icon showed up on the top of the phone. So I would leave it on the charger but it would never increase the battery life and it would actually decrease while on the pad. So I went to an AT&T store and tried it on a charging pad there and it did the same thing, so it was determined it was the phone and not the charging pad that was defective. Other than that the phone is amazing! I get great battery life and no other issues.
 

Mr. Brown

New member
Oct 22, 2012
291
0
0
Visit site
I was having the same issue! Except with mine it would buzz when I put it on the charger and the charging icon showed up on the top of the phone. So I would leave it on the charger but it would never increase the battery life and it would actually decrease while on the pad. So I went to an AT&T store and tried it on a charging pad there and it did the same thing, so it was determined it was the phone and not the charging pad that was defective. Other than that the phone is amazing! I get great battery life and no other issues.

I received my replacement red 920 yesterday and it's nice to have the wireless charging working. I know when I first got my previous one that I was transferring music to it via USB and also set it on the wireless charging pad, I wonder if that caused the issue or if the wireless charging never worked in the first place?
 

zigzagr63

New member
Oct 20, 2011
28
0
0
Visit site
Absolutely love the wireless charger. Works like a charm. One thing I have heard some people doing wrong with their charger is having it upside down. The rubber ring goes down. I know it's stupid to mention on here.... But just saying.
 

masterfisherman

New member
Nov 29, 2012
19
0
0
Visit site
Absolutely love the wireless charger. Works like a charm. One thing I have heard some people doing wrong with their charger is having it upside down. The rubber ring goes down. I know it's stupid to mention on here.... But just saying.

I was gonna make a joke about that. If i turn the charger upside down my phone doesn't act like its charging. Mine works.
 

hb2p

New member
Sep 27, 2011
25
0
0
Visit site
Absolutely love the wireless charger. Works like a charm. One thing I have heard some people doing wrong with their charger is having it upside down. The rubber ring goes down. I know it's stupid to mention on here.... But just saying.

I don't think you are the stupid one... That would be me! I'm one of those that had it upside down. For some reason I thought the side w/ the larger ring was the side to set the phone on. When the small ring is up, the phone magically started charging :amaze:
 

Members online

Forum statistics

Threads
318,854
Messages
2,237,053
Members
427,580
Latest member
JamesGecko