MMS issues with Lumia 950 on T-Mobile - Help?

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
I'm having issues with MMS on my dual sim Lumia 950 rm-1118 on T-Mobile, purchased from B&H. I have searched Windows Central forums and other sites (Reddit, T-Mobile support, Microsoft's Answers site, and others) for MMS settings.

Nothing is working. I have even done a hard reset and no luck with sending and receiving MMS. Any help would be appreciated. I was super excited for this phone, but having this issue has dampened it.

Edit: I do have the latest update installed.
 

mark233

New member
Dec 26, 2013
1,118
0
0
Visit site
Will this work? ... Reason I'm asking is I'm expecting a 950 this Friday. It's for Nokia -- maybe settings will work for 950. Menu navigation will be different on the 950 I'm sure.
mms settings.PNG

...from the T-Mobile site:
mms2.PNG
 

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
Will this work? ... Reason I'm asking is I'm expecting a 950 this Friday. It's for Nokia -- maybe settings will work for 950. Menu navigation will be different on the 950 I'm sure.
View attachment 129225

...from the T-Mobile site:
View attachment 129226

Thank you. Sadly, that also didn't work for me. It can't be my sim because I got an MMS on my iPhone and my last Android without any issues. Yay for you getting a 950, I hope you'll have better luck.

Edit: I tried this:
http://answers.microsoft.com/en-us/...a/6b1b9386-67bd-4c69-bc70-eae8ea598d03?auth=1
https://www.reddit.com/r/windowsphone/comments/3ut0m3/tmobile_mms_internet_pictures_settings_with/
 

Player Piano

New member
Jan 18, 2016
341
0
0
Visit site
I'll try to attach a screenshot of my settings shortly. I have a single sim 950 on T-Mobile.

Edit: the "preferred settings" listed above are what I have and everything works perfect. The only other change I made was IPv4v6 but I'm not sure that even matters. Are you then saving the settings and then immediately sending yourself a picture? I remember reading somewhere by doing so makes the settings stick.
 
Last edited:

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
I'll try to attach a screenshot of my settings shortly. I have a single sim 950 on T-Mobile.

Edit: the "preferred settings" listed above are what I have and everything works perfect. The only other change I made was IPv4v6 but I'm not sure that even matters. Are you then saving the settings and then immediately sending yourself a picture? I remember reading somewhere by doing so makes the settings stick.

Yeah that is what I am doing. Are you saying that you changed it to IPv4v6 or that you left it there? I am going to try that and hopefully that will work. There's a setting that has PAP selected. Did you change that or no?

I hope that I wouldn't need to do an exchange.
 

Player Piano

New member
Jan 18, 2016
341
0
0
Visit site
Yeah that is what I am doing. Are you saying that you changed it to IPv4v6 or that you left it there? I am going to try that and hopefully that will work. There's a setting that has PAP selected. Did you change that or no?

I hope that I wouldn't need to do an exchange.
I did nothing with PAP, just left it at none. All other settings I took from my L920. Sorry to hear you can't get mms working.
 

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
I did nothing with PAP, just left it at none. All other settings I took from my L920. Sorry to hear you can't get mms working.

No luck. Thank you though, I'm going to have to return this. I will try another one from them or even the Microsoft store at this point.
 

mark233

New member
Dec 26, 2013
1,118
0
0
Visit site
No luck. Thank you though, I'm going to have to return this. I will try another one from them or even the Microsoft store at this point.
Dang. I'm sorry to read you didn't get mms working. The unlocked 950 I'm getting is coming from Microsoft so I'll soon know if it'll have the same issue.
 

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
Dang. I'm sorry to read you didn't get mms working. The unlocked 950 I'm getting is coming from Microsoft so I'll soon know if it'll have the same issue.

Thank you. Hopefully my next one would be normal. Ooh okay, in that case, it should work just fine then. I was avoiding Microsoft because of taxes but it looks like it would be slightly cheaper from them with taxes included over B&H. Please let me know (or post somewhere) if it will work okay for you. I have considered buying the AT&T one and unlocking it but eh.

It seems like the phones I always want to try the most are weird on the first try. Happened with the Robin too. lol.
 

Werentuckl

New member
Mar 15, 2016
466
0
0
Visit site
Libra, can you screenshot your settings to us? Might just be able to make something work out for all we know. Also, how comfy comfy are you dabbling in registries? We could read the mms values off the registries just to make sure whether they're sticking or not, just in case. :)

-- W
 

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
Libra, can you screenshot your settings to us? Might just be able to make something work out for all we know. Also, how comfy comfy are you dabbling in registries? We could read the mms values off the registries just to make sure whether they're sticking or not, just in case. :)

-- W

I can't, I already reset the phone and submitted the RMA to send it back. I did the Reddit link and the preferred settings on the T-Mobile support site. I'll rather not mess with the registry, but I do appreciate that you offered this, thank you.
 

Werentuckl

New member
Mar 15, 2016
466
0
0
Visit site
Hmm... will you be ordering the device again Libra? Because I'm pretty sure we can get it to work , with a concerted effort, even if your new one wants to be difficult too. Order from MS or AT&T this time if you do?

And no, no registry messes, just making sure the settings stay was all. :)

-- W
 

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
I probably will, I did like it. I have to see how B&H will handle this, since I noted it as defective. I also had a weird thing with this phone not turning on sometimes even when holding down the power button to turn it on, so I'm not sure if something is up with this particular phone.

I haven't received the RMA yet from B&H so I can try what you might have in mind. I'll re-set up the phone. I don't know how to see the registry on this phone. Would I need a usb to do that or can I do that on the phone itself? I'm at work, but can't do my work atm so I'll give this a shot. I don't have access to a usb cable at work.
 

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
Well, give me a few minutes. I just closed all the tabs I had opened up for you. I'm stupid. I know. :/

-- W
Nah, you're not stupid. I really do appreciate you for using your time to help me.

This is how my MMS settings are right now. Whoa this keyboard files btw. After taking the screenshots, I changed IPv4v6 to IPv4, no difference by the way. My work wifi is better in certain spots over others, and my connection is generally lame here so don't mind the bar(s).
4Mcmx41.jpg

4WFG6zm.jpg


Sent from mTalk
 

Werentuckl

New member
Mar 15, 2016
466
0
0
Visit site
Okay, so first things first, you get your phone into Dev mode, and install the interop tools by Gustave, once you have those in - we can start looking into the settings. Btw I would recommend returning this eventually after those power on issues you mentioned, do not seem natural. AT&T this thing and unlock your way to happiness. I'm attaching the links for the guides for the Interop, and will add another post in here with the values to look into - I'm assuming this is going to be running support and you'll be here watching. :p

Here's Dan's guide on the interop.
Interop Tools for Windows 10 Mobile lets you edit your registry for some hacking fun | Windows Central

And here is the link for the latest toolset. You want to install the file that says 1.8 Beta for ARM after going over Dan's instructions. Around 3.8 MBs or so. And yes you can just bypass needing a USB cable for this altogether. ^_^
https://mega.nz/#F!iZMhSSzI!sGQy4V12ubfvT8Abm2Uo1g

Happy hunting. I'll get back to you again in a few with the other things. :)

-- W
 

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
Thanks, I downloaded the one that you said and followed Daniel's instructions but unfortunately, it's not showing up on my phone under Extras. Would it not work the way it should if I download the one that he linked in the guide?
 

Werentuckl

New member
Mar 15, 2016
466
0
0
Visit site
Hmm... The values you're using seem to be correct to me, so I'm going to ask you to double check and do them over the registry too. Hopefully, we're just missing out on some odd values which is messing things up. The strings I'm copying over are for both tethering and MMS, so lets just go with both anyways. :)

HKLM\SOFTWARE\Microsoft\Messaging\PerSimSettings\Legacy
ADDR = http://mms.msg.eng.t-mobile.com/mms/wapenc
WapPushTechnology = 0
UAProf = <Blank>
IMsiAuthenticationToken = <Blank>
DefaultContentLocationUrl = http://mms.msg.eng.t-mobile.com/mms/wapenc

HKLM\System\ControlSet001\Services\ICSSVC\Settings
EntitlementRequired = 0

HKLM\Software\Microsoft\Cellular\MVSettings\IMSISpecific\Default\CellUX
HideMMSAPN = 0
HideAPN = 0

Just browse to these pathways and check or set these values in where they dont match up with what I've sent you. :)
 

Werentuckl

New member
Mar 15, 2016
466
0
0
Visit site
Darn, this would be so much easier over a more realtime mode of communication. Okay so lets seee....hmm... Ive had people report it moving out of the extras and showing up on the general applist. Has it installed properly? And if it has, does it show up on your applist? :)

-- W
 

libra89

Active member
Feb 6, 2015
11,076
6
38
Visit site
Ah yeah, it probably would be. Nope, not on the general app list either. I get the same box that asks me if I want to install it and after hitting install, nothing else happens.

Edit: I just got it, finally! It took uploading it to OneDrive and then tapping on it in there! Going to do the steps you said in your previous post.
 
Last edited:

Members online

Forum statistics

Threads
323,770
Messages
2,244,346
Members
428,120
Latest member
ColeMartinHater69