No T-Mobile service -- Cellular Settings Show "No Network Found"

Ethan Alvaree

New member
Dec 18, 2014
50
0
0
Visit site
Just got two unlocked Lumia 950 XLs from the Microsoft Store. Took them to T-Mobile, purchased a plan for 2, and got new SIM cards. While we were in the store, our 950 XLs had service and were able to place/answer calls and send/receive MMS messages. Everything seemed OK.

Unfortunately, as soon as we got home, both 950 XLs lost celluar service. We see a circle with a slash through it over the network bars. Going into Settings > Network & Wireless > Cellular & SIM we see "no network found". To further investigate, we went into "SIM 1 settings" to see what options are selected:
-Under "Highest connection speed", we tried changing from LTE (highlighted) to both 4G and 2G, however that didn't fix the problem
-Under "Search for networks" we have the options "automatic", "AT&T (LTE,3G,2G)", and "Verizon (Forbidden)". This option is currently set to "automatic".
-Under "Cellular connection profile", we have set "T_Mobile". (That is the only option.)
-Under "get the latest cellular settings from your mobile operator", tapping "update settings" has no effect.
-Under "Internet APN" we have "Default APN" added, and under "MMS APN" there seems to be no setting added yet.

Anyone else having issues with voice and text on their Lumia 950 XLs with T-Mobile?
 

rdubmu

Active member
May 25, 2011
3,314
0
36
Visit site
No T-Mobile service -- Cellular Settings Show "No Network Found"

What are the settings you have under Internet APN? Have you tried to reboot your phone? Do you have service in your home?
 

Rezzee

New member
Aug 10, 2014
18
0
0
Visit site
Just got two unlocked Lumia 950 XLs from the Microsoft Store. Took them to T-Mobile, purchased a plan for 2, and got new SIM cards. While we were in the store, our 950 XLs had service and were able to place/answer calls and send/receive MMS messages. Everything seemed OK.

Unfortunately, as soon as we got home, both 950 XLs lost celluar service. We see a circle with a slash through it over the network bars. Going into Settings > Network & Wireless > Cellular & SIM we see "no network found". To further investigate, we went into "SIM 1 settings" to see what options are selected:
-Under "Highest connection speed", we tried changing from LTE (highlighted) to both 4G and 2G, however that didn't fix the problem
-Under "Search for networks" we have the options "automatic", "AT&T (LTE,3G,2G)", and "Verizon (Forbidden)". This option is currently set to "automatic".
-Under "Cellular connection profile", we have set "T_Mobile". (That is the only option.)
-Under "get the latest cellular settings from your mobile operator", tapping "update settings" has no effect.
-Under "Internet APN" we have "Default APN" added, and under "MMS APN" there seems to be no setting added yet.

Anyone else having issues with voice and text on their Lumia 950 XLs with T-Mobile?

I have T-Mobile and also purchased a 950 XL unlocked from the Microsoft Store. No abnormal issues to report here. Have you had T-Mobile prior to getting these phones? My service generally takes a serious hit when I go into my apartment, but I still usually get 1-2 bars (enough for phone calls and texting).
 

gerrymad

New member
Apr 6, 2011
216
4
0
Visit site
Just got two unlocked Lumia 950 XLs from the Microsoft Store. Took them to T-Mobile, purchased a plan for 2, and got new SIM cards. While we were in the store, our 950 XLs had service and were able to place/answer calls and send/receive MMS messages. Everything seemed OK.

Unfortunately, as soon as we got home, both 950 XLs lost celluar service. We see a circle with a slash through it over the network bars. Going into Settings > Network & Wireless > Cellular & SIM we see "no network found". To further investigate, we went into "SIM 1 settings" to see what options are selected:
-Under "Highest connection speed", we tried changing from LTE (highlighted) to both 4G and 2G, however that didn't fix the problem
-Under "Search for networks" we have the options "automatic", "AT&T (LTE,3G,2G)", and "Verizon (Forbidden)". This option is currently set to "automatic".
-Under "Cellular connection profile", we have set "T_Mobile". (That is the only option.)
-Under "get the latest cellular settings from your mobile operator", tapping "update settings" has no effect.
-Under "Internet APN" we have "Default APN" added, and under "MMS APN" there seems to be no setting added yet.

Anyone else having issues with voice and text on their Lumia 950 XLs with T-Mobile?

I had a similar issue and it was easily resolved or me. Go back into your SIM 1 settings and look for the "Cellular connection profile" drop down. I had originally selected T-Mobile and my service was horrible. Switch the drop down to t_mobile. This should reprovision the phone with new settings. You may also need to follow that up with tapping the update settings button. After I switched profile my phone restarted and my connection has been great.
 

copjake

New member
Oct 1, 2011
13
0
0
Visit site
I think there is no T-Mobile service in your house the fact that you scan for networks and it doesn't show T-Mobile as one of them tells me your area is dead for T-Mobile my XL actually have the best signal of any T-Mobile branded phone I have ever used, only the Lumia 640 had this good of a signal but, the XL actually work in one area where the 640 would not, It sucks that the specs say it supports WI-FI calling when it clearly doesn't.
 

Ethan Alvaree

New member
Dec 18, 2014
50
0
0
Visit site
Hey all. Thanks for your replies. I wanted to post an update.

It seems like the problem is our condo is a coverage dead zone. When we left the condo today, our service gradually returned as we reached the street.

If that's the case, we don't have many options - we may have to switch to AT&T. Practically speaking, what would be the differences (aside from AT&T being more expensive)? Would I have all the same features (e.g. WIFI calling, Visual Voicemail, etc.) between T-Mobile and AT&T?

Speaking of WIFI-calling, is this something I could enable with T-Mobile? Theoretically speaking, that would solve the problem of the coverage dead zone in my condo, since we do have WIFI in our condo. But how would we go about setting that up?
 

mattdistro

New member
Jul 30, 2013
33
0
0
Visit site
You're not going to have WiFi calling or Visual Voicemail with the 950 XL on any carrier.

You have 2 options.

1. Switch to AT&T
2. Get a 4G LTE Cellspot from T-Mobile (https://support.t-mobile.com/community/coverage/personal-cellspot/4g-lte-cellspot)

The latter will give you coverage in your condo, but it is open, so if you have neighbors close by that have T-Mobile they could potentially bog down your internet connection. Probably not likely anyone would if your condo is a dead spot.
 

spdsk8race

New member
Oct 6, 2015
4
0
0
Visit site
on your phone would you mind checking and seeing if you have your band 2, 4, 12 and 1700 turned on? they might have somehow got disabled.. and add a new apn fast.t-mobile.com
 

TexasLabRat

New member
Oct 17, 2012
385
0
0
Visit site
Hey all. Thanks for your replies. I wanted to post an update.

It seems like the problem is our condo is a coverage dead zone. When we left the condo today, our service gradually returned as we reached the street.

If that's the case, we don't have many options - we may have to switch to AT&T. Practically speaking, what would be the differences (aside from AT&T being more expensive)? Would I have all the same features (e.g. WIFI calling, Visual Voicemail, etc.) between T-Mobile and AT&T?

Speaking of WIFI-calling, is this something I could enable with T-Mobile? Theoretically speaking, that would solve the problem of the coverage dead zone in my condo, since we do have WIFI in our condo. But how would we go about setting that up?

call them (from the street, I suppose) and request a new LTE cell spot. It plugs into your internet connection and is effectively a miniature t-mobile cell tower. I have one..it works great.

https://support.t-mobile.com/community/coverage/personal-cellspot/4g-lte-cellspot
 

Members online

Forum statistics

Threads
324,218
Messages
2,245,170
Members
428,177
Latest member
Not_Applykable