Old new stock prototype keyboard power cover - battery not charging

ClairelyClaire

New member
Apr 20, 2018
2
0
0
Visit site
I picked up this thing:
https://rover.ebay.com/rover/1/711-.../www.ebay.com/itm/282897693650?orig_cvip=true

The battery doesn't seem to quite want to start charging. I don't think it's completely dead, though, because depending on exactly how I connect the tablet to the keyboard, it occasionally picks up that there's a battery attached, and the battery starts charging for a few seconds. It always reverts to "not charging" though.

I ALSO am able to get a valid cycle count, design capacity, and real capacity from running powercfg /batteryreport from a command prompt, but only if the computer is charging the battery when I run the report...and sometimes it still doesn't give me any values.

I've seen it claim 3% and 6% charge on two separate occasions, but as soon as the battery stops charging, it goes back to 0%.

I'm not really expecting to be able to easily fix this given that I bought an as-is cover with no guarantee on battery capacity, but I'm 99% sure this battery's never been used, which means it's just a matter of getting it to start charging properly.

Any ideas are appreciated!

Addendum 4/23/18: I ended up removing the plastic cover that sits between the two battery cells, and one of the two Li-polymer packs had leaked and corroded all over the place. It was a mess. I've bought an OEM replacement battery on eBay, so we'll see if I have better luck with that.
 
Last edited:

Members online

Forum statistics

Threads
324,219
Messages
2,245,173
Members
428,178
Latest member
oscahill