• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

One second delay in showing sharp pictures - just me?

Joe920

Trusted Member
Nov 13, 2012
1,677
0
0
When I'm showing off the awesome pictures that my 950XL takes, it's annoying that the pictures look slightly blurry for about a second, before showing fully sharp. Does everyone see this? Is this an option that can be turned off?

This is on the latest Threshold build, on the built in photos app, with my photos saved to the main phone storage, and saving as 16MP jpeg.
 

Chintan Gohel

Ambassador
May 23, 2014
10,784
0
0
When I'm showing off the awesome pictures that my 950XL takes, it's annoying that the pictures look slightly blurry for about a second, before showing fully sharp. Does everyone see this? Is this an option that can be turned off?

This is on the latest Threshold build, on the built in photos app, with my photos saved to the main phone storage, and saving as 16MP jpeg.

that's present on most phones - it just takes a while for the phone to process the high res pics - perhaps show the 5MP image?
 

anthonyng

Trusted Member
Nov 29, 2012
1,866
0
0
When I'm showing off the awesome pictures that my 950XL takes, it's annoying that the pictures look slightly blurry for about a second, before showing fully sharp. Does everyone see this? Is this an option that can be turned off?

Unfortunately I noticed this at one point on the recent redstone builds on my 950XL... It's not all the time though funny enough. It's like it's figuring out stuff (living images or something) my photos goto SD... sucks to hear you get that on main memory.

Now someone go tell me Microsoft pix on ios takes 5 seconds before showing clear pictures so I can hopefully feel a little bit better lol.
 

Joe920

Trusted Member
Nov 13, 2012
1,677
0
0
that's present on most phones - it just takes a while for the phone to process the high res pics - perhaps show the 5MP image?
Thanks, that's too bad. I've seen this behavior forever, but I hoped it was some kind of setting I could turn off. I have the camera set to only save the 16MP picture so there's no 5MP version to show. I hope MS figures out a way to get rid of this delay, because I love showing people the picture quality.
 

Chintan Gohel

Ambassador
May 23, 2014
10,784
0
0
Thanks, that's too bad. I've seen this behavior forever, but I hoped it was some kind of setting I could turn off. I have the camera set to only save the 16MP picture so there's no 5MP version to show. I hope MS figures out a way to get rid of this delay, because I love showing people the picture quality.

the 5 (or is it 8)Mp version is still good -try taking a few shots in that combination of low + high res and see if the loading still takes a second or two
 

white_Shadoww

New member
Jan 11, 2015
374
0
0
No, even downloaded pics do this. It's a bug I think, or messy coding.
 
Last edited:

Summer_Moon

New member
Sep 16, 2014
298
0
0
When I'm showing off the awesome pictures that my 950XL takes, it's annoying that the pictures look slightly blurry for about a second, before showing fully sharp. Does everyone see this? Is this an option that can be turned off?

This is on the latest Threshold build, on the built in photos app, with my photos saved to the main phone storage, and saving as 16MP jpeg.

Same for me, but then again I see this happen on the LG G4 so I'm pretty sure it's just loading the rest of the image. I see you mentioned they are saved in main storage so not really a read speed issue, but I have seen the problem be even worse when it is being saved to SD and they have a class 4 or 6 card.
 

Noob1ee

New member
Oct 30, 2012
157
0
0
I experience this, also zooming seems broken as well, it gets stuck quite frequently...very annoying so far.
 

anon(8648115)

New member
Mar 5, 2014
181
0
0
This has been a problem since the beginning of W10M. I've noticed that shots taken with HDR having fired don't suffer from this problem. So I'm stuck with letting the phone use HDR (which on auto, is all the time literally) and waiting 10 seconds for the photo to process... or use without HDR and having to wait for the damn image to 'load' in a sense each time I scroll through it.
 

Joe920

Trusted Member
Nov 13, 2012
1,677
0
0
Mine seems to be a little slow too but could very well be dependent on the memory card.
I'm sure that can play a role, but I see this on the 950XL which is almost the fastest WP phone with the pictures saved directly to the phone memory.
 

CraigCole

New member
Nov 5, 2015
193
0
0
I experience this, also zooming seems broken as well, it gets stuck quite frequently...very annoying so far.

This happens CONSTANTLY on my 950. Most of the time it won't pinch-to-zoom unless I patiently wait at least two seconds for it to figure out what the heck it's doing. Even then it oftentimes gets stuck when I zoom in, not allowing me to move the image around (only swiping to the upcoming or previous pictures), which is INCREDIBLY frustrating. How is it possible that they effed-up the photos app?! Isn't that one of the most basic functions of a smartphone? I'm just sooooo disappointed in this device...
 

white_Shadoww

New member
Jan 11, 2015
374
0
0
This happens CONSTANTLY on my 950. Most of the time it won't pinch-to-zoom unless I patiently wait at least two seconds for it to figure out what the heck it's doing. Even then it oftentimes gets stuck when I zoom in, not allowing me to move the image around (only swiping to the upcoming or previous pictures), which is INCREDIBLY frustrating. How is it possible that they effed-up the photos app?! Isn't that one of the most basic functions of a smartphone? I'm just sooooo disappointed in this device...

Same behavior here on Lumia 730!
 

Ask The Community

Members online

Forum statistics

Threads
315,752
Messages
2,238,386
Members
427,207
Latest member
donaldtrumpjr5