OneDrive not working after Cyan Update


WPCentral Question


I recently updated my Lumia 520 to WP8.1 (Cyan). Mostly everything is fine and I'm very happy with the update, EXCEPT for the fact that OneDrive no longer opens and only displays as a shadow tile on the start screen.

I have tried a soft reset and I have gone to to attempt to re-install the app, but there is no option to install, view or re-install the app as it thinks I already have it successfully installed.

The Windows Phone Store support webpage offered the following suggestion:

"You've requested re-installation of OneDrive from the Windows Phone Store. Here's how to download and reinstall this app:
Tap the link below on your phone to go to app details inside the Store.
OneDrive | Windows Phone Apps+Games Store (United States)
When prompted, tap the Install button.
Your app will begin downloading.
Once the download is complete, you can find your app in the app list.
Enjoy your app! Thanks again for visiting the Windows Phone Store."

Well, I did that, but the same thing happened.... no install option.

I have noticed that many people seem to have this problem. Hopefully it may be addressed in an upcoming update....? Has anyone got any suggestions in the meantime?


Malcome Larcens

New member
Jan 11, 2014
Visit site
Hi all. I'm experiencing the same problem with OneDrive.
The app only doesn't work and I can't uninstall it. When I go to the applications I see the app but my only option it to pin it to start.
I did a soft reset a few times (start button and volume up) but nothing changed.
What I mean the app only not working is that all my pictures are still being uploaded to OneDrive as before. So my pics are safe.
I can also access them through the browser on my phone or anywhere else.
I just went to the site now and touched the install button but nothing happened.
A solution would be greatly appreciated.

Thank you


New member
Sep 18, 2014
Visit site
Hi guys,
Must admit that have the same problem with onedrive as you do. Also tried soft reset few times (start button and volume up) but nothing has changed. I have nokia lumia 920. I live in Ukraine and use my native language. But the telephone itself was manufactured for Italy (mobil operator - It Country Variant). Is it possible that such problems are because of difference between my location and manufacture?

Members online

Forum statistics

Latest member