PSA: Regarding (restoring) setting up your new 950XL

VegaNovus

New member
Nov 5, 2012
240
0
0
Visit site
I've gathered some data from the bugs and defects list from here and a few other sites and found that 79% of people who are having extended issues (more than 4 problems simultaneously) are restoring a backup from a previous device.

Of those 79%, 56% restored from a 1520.

Those people that set up their shiny new 950XL as a new phone don't experience as many issues as those restoring.

If you have multiple issues, try reset your phone and set it up as a new phone - see if it helps.
 

nokia4life

New member
Mar 31, 2012
430
0
0
Visit site
my question is I never even selected to restore the last time I used WM was in 2012 with a Lumia 900 however as soon as i powered it on after putting my sim in and SD card it automatically restored from previous did not ask if i wanted to like most phones do. Where did I go wrong and can we confirm that If I take the time to reset the device to new again and start all over (hours of work) that this will fix the lanky issues going on? Has anyone done this with success >>>>>
 

mdbuilder

New member
Apr 15, 2014
73
0
0
Visit site
Well, I had the issue of no pics in emails, everything else seemed fine. I just did the reset and no restore, sure enough, the issue is gone. If you do it, when you get to the screen with the backups to choose you need to scroll to the bottom and select don't restore.
 

Captpt

New member
Sep 16, 2015
373
0
0
Visit site
Funny I've been reading up on the issues people are having here, (still waiting for my XL :unhappy:) and came to your conclusion too.. Guess when it arrives I'll be starting fresh lol... I may use a app to backup my contacts just to be safe.
 

Lundon44

New member
Sep 6, 2012
586
0
0
Visit site
I am one of these people. Did my first hard reset yesterday after restoring from my 1520. Phone was buggy as hell to the point where I couldn't even open my text messages app. Or it would open, not show any messages and then freeze for 15 sec before showing a few messages. Battery also began to drain super fast.

Took me literally most of the day to set it all back up. Thank god for backing up my sms and whatsapp convos. Apps were tedious to re-install but if you access the app store you can see your history of apps and download what you want again. Problem is once you get over 15-20 pending downloads the OS starts to lag.

Since my fresh start it's running a ton better. My only complains now are custom text sounds for individual contacts do not work at all for anyone. Only plays the same sound for everyone. Outlook calendar doesn't always show the date on the live tile and sometimes just shows the outlook icon. And lastly, when using the phone with my Nokia wireless charging pad (DT-903) the phone heats up A LOT. It seems to charge it slowly but not sure why it gets so hot.
 

GoodThings2Life

New member
Dec 1, 2011
1,037
0
0
Visit site
While I'm not normally a fan of restoring backups across device models, I had a fairly bare bones 640 setup with latest W10M Insider Build and opted to take a chance. I had zero issues with the process, and my device is running GREAT with only a handful of build-specific known issues (like the battery life and shape writing issues with Edge/Tweetium/etc.). Nothing major.

That said, YMMV, and I certainly would advise to hard reset with a "Clean Setup" option if you're having trouble. And once you do clean setup, make sure the FIRST STOP is to the Store and get the native app updates installed BEFORE you start customizing things.
 

VegaNovus

New member
Nov 5, 2012
240
0
0
Visit site
"make sure the FIRST STOP is to the Store and get the native app updates installed BEFORE you start customizing things."

Can I quote you on the OP?
 

ajj3085

New member
Aug 29, 2013
276
0
0
Visit site
I'm a bit skeptical; the data is from self reported sources, which are pretty unreliable to begin with (to use as a source, not saying the posters are not having issues). I've personally never had a problem restoring across devices, or even between Win8.1 & 10. My backup restored fine when I moved my 920 back from the Insider version of 10 back to 8.1, it worked fine again recently when my 920 broke so that it no longer gets a cell signal and I restored to a 520. It worked again when I backed up the 520 and restored to a 640, and it's also worked fine backing up the 640 and then restoring that to my 950 XL.

I've only gotten the 950 yesterday, so I guess we'll see if issues pop up, but my experience doesn't really have me worried. Ironically the only issue so far is my text messages not restoring (some really old ones have from 2013, but most have not), and that's not part of the normal backup process.
 

midnightfrolic

New member
Aug 2, 2015
687
0
0
Visit site
I can vouch for this. I had a 640 XL. Restoring from backup always had issues and randomly glitches. Usually from upgrading to latest Insider builds. I no longer restore from backups. Always fresh reset for me.

I just got a 950 XL early today. No issues so far from useability standpoint for basic functions. Making and taking calls, browse web. Connecting to cellular and wifi. Updates and upgrades...etc. Only issue was no Display Dock promo in Lumia Offers app. Calling MS Store hotline and they manually issued me a promo code.
 

Members online

No members online now.

Forum statistics

Threads
322,454
Messages
2,242,034
Members
427,928
Latest member
Donaldb1129