Rev 1.4, still no NoDo on 5/10/11

enahs555

New member
Feb 21, 2011
653
4
0
Visit site
Well, its like 3 weeks (21 days) later, and still no NoDo for me and us other poor rev 1.4 Focus owners. This is just getting fing ridiculous!!!!!!!!!!!!! exclamation point!!!!!!
 

Duvi

New member
Jan 1, 2011
3,094
5
0
Visit site
would you want to try get a warranty replacement through at&t? if you have a warranty center near you, go there and ensure they give you a rev 1.3 device.
 

enahs555

New member
Feb 21, 2011
653
4
0
Visit site
My phone was free from Microsoft for being a developer, so no luck for any replacement or such. Just was given to me, as is. It was a 100% new ATT branded Focus, just not from ATT....
 

Duvi

New member
Jan 1, 2011
3,094
5
0
Visit site
You're still covered under warranty man! Head over to a warranty center man! Lol.

The most they can say is "no". Don't mention how you got the phone either.
 

cdook

New member
Dec 6, 2010
675
7
0
Visit site
I'd wait and see if there's news in this week's where's my update? post. That really stinks there are people out there who can't update. How much could the hardware have changed?
 

furygoalbrtis39

New member
Apr 23, 2011
113
0
0
Visit site
I just got my phone today, and after I left the store I check the memory version and apparently I have rev 1.4 too...

Sent from my SGH-i917. using Board Express
 

jdunn

New member
Dec 9, 2010
142
2
0
Visit site
The problem you have run into is that fixing this problem has been left up to Samsung, and they have a horrible history of fixing their phones problems. This probably effects a small enough percentage of devices to not warrent a speedy answer by Samsung. That is my thought on this anyways.
 

Members online

Forum statistics

Threads
322,447
Messages
2,242,022
Members
427,924
Latest member
Christina Bellot