Samsung omnia 7 says it's charging even when it's unplugged!!

cheesydevil

New member
Oct 18, 2011
3
0
0
Visit site
Hi good people of the WPcentral forum

I have encountered a most severe and annoying problem, My Phone thinks it is charging even when it is not plugged in. somtimes it even alternates like crazy causing the sound fx for charge to reapeat over and over again. this is an issue I can not live with because it causes my phone to go flat very quick as my screen will only stay off on the odd chance the phone remains on the charge icon and whats more I can't turn on battery saver because the phone thinks it's charging.

I have removed the battery dozens of times and have trawled the internet and the closest thing I find is people having problems with dodgy battery icon behaviour on this handset (omnia 7). I am on mango and my phone has decided it can not charge from the wall plug anymore. sorry for the wordiness I just thought I'd get it all out in one post.
 

TheWeeBear

New member
Jan 9, 2011
5,285
17
0
Visit site
welcome.gif

Yes, that's not good, sound like something's not right with your USB socket cheesydevil. (shorting?)

As palandri suggested try a reset and if nothing changes get a replacement. :)
 

cheesydevil

New member
Oct 18, 2011
3
0
0
Visit site
I have been dreading that answer, what do you think about the chance the micro usb is screwed? I have no warranty as I bought the phone outright overseas and it does not have international warranty. I had to flash the ROM with an offical optus one when it got here but I doubt thats the problem or everyone in the country would be reporting it.
 

TheWeeBear

New member
Jan 9, 2011
5,285
17
0
Visit site
Oh dear, it does sound as if the USB socket is more likely to be faulty than a software problem. :(

Other than reseting or flashing not a lot else to suggest. :(
 

richu75

New member
Jul 30, 2011
32
0
0
Visit site
I've seen the same behaviour on my Omnia while charging it with an older USB charger.
I my case it was an older BB charger with a micro-USB cable. Seems the Samsung charger provides more power.

Do you charge it with an non original adapter?
 

TheWeeBear

New member
Jan 9, 2011
5,285
17
0
Visit site
I've seen the same behaviour on my Omnia while charging it with an older USB charger.
I my case it was an older BB charger with a micro-USB cable. Seems the Samsung charger provides more power.

Do you charge it with an non original adapter?
That would be good, if that's all it was richu75. :)
 

richu75

New member
Jul 30, 2011
32
0
0
Visit site
I've checked the chargers.

The omnia's original charger delivers 5 volts at 0,7 Amps.
In my case the old blackberry charger delivered 5 Volts at 0,5 Amps.

Quite a difference.
 

PrittStickFace

New member
Nov 6, 2012
7
0
0
Visit site
This has started happening to me since last night.

Since fully charging it overnight and disconnecting it for 1 hour this morning, my battery has already drained to 55%! The screen keeps turning itself on every 5 seconds. I've currently got my phone on vibrate to stop the beeping!

Did anyone find a fix?
 
Last edited:

Reflexx

New member
Dec 30, 2010
4,484
4
0
Visit site
This is risky, but worked for me.

If you look in your USB port, you'll notice that the part that's supposed to be in the middle might be making contact with the side wall. I used a very small tool to move that middle island away from the side wall so it would stop touching.

That was on my Samsung Focus over a year ago. It still works fine now.
 

PrittStickFace

New member
Nov 6, 2012
7
0
0
Visit site
This is risky, but worked for me.

If you look in your USB port, you'll notice that the part that's supposed to be in the middle might be making contact with the side wall. I used a very small tool to move that middle island away from the side wall so it would stop touching.

That was on my Samsung Focus over a year ago. It still works fine now.
Thanks for the rapid response. :)

I just tried it with a small jewellers screwdriver. I will see how it goes and report back.

Battery now at 6% needs another charge!
 

PrittStickFace

New member
Nov 6, 2012
7
0
0
Visit site
It worked OK for about 2 hours and then the battery completely died. When i fully charged it and disconnected it happened again.

Tried with the screwdriver again and its been fine for the rest of the day.

Thanks Winning Guy!
 

Paul Bamforth

New member
Sep 12, 2013
1
0
0
Visit site
My phone has been going crazy recently with the same fault. I did as suggested regarding moving the central bit inside the USB and it seems to be working fine now.
 

Members online

Forum statistics

Threads
323,747
Messages
2,244,315
Members
428,114
Latest member
WillyA