Slow connection via WiFi

Adam Linka

New member
Aug 7, 2013
3
0
0
Visit site
Hello!

I have a strange problem with my HTC 8X. I have this device for 3 months, everything was working perfect since last update. Pages in IE and everything that uses internet connection is just very slow, when i use wifi. BUT if i do speedtest, it says 21Mbps (exactly what i have on my PC wire connected to the same router). I tryed factory reset - didnt help, reseting router - didnt help, changing from WPA2 to WPA - didnt help. If i connect to mobile network, everything just works perfectly fine and i am pretty sure, that mobile network is slower than my home internet. Any ideas, guys? btw i have another problem with my FB chat in the intergrated messenger - everytime i set up online status, it says "connected (logged in)" but also says "Nobody is online", when i see many friends online on my PC. So if someone knows solution, please, let me know :) Thanks
 

Laura Knotek

Retired Moderator
Mar 31, 2012
29,412
27
48
Visit site
It is possible that you are getting interference from other wireless devices or networks. Have you tried changing the channel on your router?
 

Adam Linka

New member
Aug 7, 2013
3
0
0
Visit site
I've just tried it, but without success. Also tried change from WPA to WEP - didnt help :( But this happens even if i change the router, so i think, theres something from with my phone.
 

BroMarduk

New member
Apr 17, 2012
5
0
0
Visit site
Adam,

I'm having a similar issue with slow WiFi on my 928. One thing I did find that restores WiFi speed back is to turn the celluar radio off. For me, Cell On, WiFi On = Slow WiFi and Cell Off, WiFi On = Blazing Fast WiFi. Not proposing that as a solution, but curious if that helps you out as well. I noticed its not so much the speed, but the ping times that are really slow with both on. I also noticed that it is not that way with all access points, so it could possibly be the router. I'm using a Asus RT-N66U as my router and use WPA2.
 

Adam Linka

New member
Aug 7, 2013
3
0
0
Visit site
Thanks for help, but it isnt working for me :( It really pisses me off, cuz it happened from nothing, my connection via WiFi was great, but now from day to day its just fkn slow. Maybe its coused by GDR2 update, but im not sure.. Ill try my phone in another wifi to check if problem is in phone or in router.
 

garyrday

New member
May 15, 2013
3
0
0
Visit site
I have exactly the same problem on my HTC 8X. it was work great until GDR2. I've tried it with several different wifi hotspots and routers at different physical locations, no joy. There is definately a bug with wifi in GDR2. Just wish i could revert to GDR1 as having a working wifi is way more important to me than the very few enhancements in GDR2. Please Microsoft, reliability is more important than features!!!
 

JulianRaymondDC

New member
Nov 9, 2012
3
0
0
Visit site
I have two Lumia 920's in my house (read no GDR2), and I'm having the exact same problem. I event deleted the network and restarted everything in case it was a DNS problem. This is pissing me off!
 

absonj

New member
Jan 3, 2013
99
0
0
Visit site
I've got the G2 update, and ever since, my WiFi connectivity has been a bit slow. I have to wait a minute after waking phone up before I can connect to WiFi, and sometimes it just drops the connection to my router. Its a pain, but it beats the.constant reboots and random freezes / battery pulls back when I had android. Still love the phone and especially the OS! Seeing more and more of the 8X out there. And hearing nothing but good from the new users.
Sent from my wicked sexy HTC 8X windows phone using Board Express
 

ebk14

New member
Jul 25, 2013
20
0
0
Visit site
I have a Verizon 8x and have been having the exact same problem ever since the GDR2 update. When im at home, or any other WiFi connection that normally has been very fast, hardly works at all anymore. If I switch the WiFi off and use the lte network, the problem goes away...really annoying that things can never be perfectly right with this phone.
 

ShocWave

New member
May 13, 2012
59
0
0
Visit site
I have a similar problem here on my Samsung Ativ S.
I wouldn't say the connection is slow, but the speed drops to nothing for a short time every few minutes.

If I were watching a YouTube video, it would give me an error message about the connection.
If I were browsing webpages using IE, I would have to hit refresh several times for the page to display.
If I were using apps, I would see the loading "..." fly across the screen until I back out.
 

ebk14

New member
Jul 25, 2013
20
0
0
Visit site
I just wanna bump this message up. Im curious why not all htc8x phones wouldn't be having this WiFi issue post gdr2? Its a huge problem, WiFi is basically completely unusable now...i have to either use data only or constantly switch my WiFi off then on to get it to work for a minute...
 

gohaaron

New member
May 29, 2013
11
0
0
Visit site
Same here with my ATIV S after updating to GDR2!! my case is even worse where my stream disconnects after 5-10 secs!! WiFi is connecting but after doing some tests i found that the connection keeps breaking/disconnecting. very frustrating indeed! tried everything but still nothing has changed!
 

iampwd

New member
Jun 22, 2013
99
0
0
Visit site
I changed beacon interval to 1000 from 100 on my router and I think that help. Also disabled 3g when on WiFi. Haven't tried long enough to be certain if this helps or not. Probably not...
 

Members online

Forum statistics

Threads
323,815
Messages
2,244,458
Members
428,133
Latest member
Lorena783lopez