Upgrade experience for Lumia 540 from 8.1 denim to 14393.103

Chintan Gohel

Active member
May 23, 2014
10,785
1
36
Visit site
I have a new lumia 540 which I decided to upgrade to windows 10 mobile 14393.103

I downloaded and installed windows upgrade advisor app, ran it, configured the device and started downloading the update.

The update took about 20 minutes to download, another hour to install. it had installed 10586.107. Then I checked for updates again, took another 20 minutes to download update 2 and 40 minutes to install. Now my phone was on 14393.67. At this point, I did a factory reset from settings

The reset took about 25 minutes, then I started the phone afresh. I did not restore anything from old backups, just a fresh start. Took some time setting up, added 2 emails, updated 21 apps, removed other apps like news and finance etc. I then downloaded about 15 apps I needed

I wanted the release preview so I went into settings, signed in and selected release preview - took another hour downloading and installing that

Checked for app updates again, had 10 more. Weather app is now stuck, it won't uninstall.

So far no bugs noticed or encountered. I guess the total process took about 5 hours. I wasn't checking on time, just letting it do it's stuff

I have noticed a couple of peculiarities which I'll post in a separate post
 

abhishek singh21

Active member
Apr 27, 2014
2,454
2
38
Visit site
So far no bugs noticed or encountered.

for me build 103 was a battery drainer , there were minor bugs in outlook mail and calendar app where the system date will change to 6 September but the tile will show the date of the previous day 5 sept ( live tile broken). so rolled back to 67, build feed servers already show a new build 14393.185 under testing. also the Tuesday patch is coming week so will wait for the official CU :D
 

Chintan Gohel

Active member
May 23, 2014
10,785
1
36
Visit site
I don't have calendar tile pinned so I wouldn't notice that- I don't use the calendar at all except to check which date is what day
 

Rinsun

New member
Apr 4, 2016
871
0
0
Visit site
for me build 103 was a battery drainer , there were minor bugs in outlook mail and calendar app where the system date will change to 6 September but the tile will show the date of the previous day 5 sept ( live tile broken). so rolled back to 67, build feed servers already show a new build 14393.185 under testing. also the Tuesday patch is coming week so will wait for the official CU :D

Is your Outlook Calendar and Mail tile updating okay on .67 ?
The Calendar tile on my phone changes to Outlook icon after an event is over and at midnight .Mail tile does not show new mail or change back after I finish reading a mail.I am on .67.Both need resizing every time.

Sorry ,I know this is not related to this thread.Just wanted to know as I rely on the Calendar tile a lot.
 

Chintan Gohel

Active member
May 23, 2014
10,785
1
36
Visit site
for me build 103 was a battery drainer , there were minor bugs in outlook mail and calendar app where the system date will change to 6 September but the tile will show the date of the previous day 5 sept ( live tile broken). so rolled back to 67, build feed servers already show a new build 14393.185 under testing. also the Tuesday patch is coming week so will wait for the official CU :D

you might have a point on battery, seems faster than it should be though I'm still trying to find my rhythm

Tried the new .105 build? Any idea on download size?
 

EspHack

New member
Jun 11, 2013
1,279
0
0
Visit site
you might have a point on battery, seems faster than it should be though I'm still trying to find my rhythm

Tried the new .105 build? Any idea on download size?

how could we know that now, you just find your phone with spinning gears randomly, I think .67 had the best battery life, lets see how .105 turns out
 

Chintan Gohel

Active member
May 23, 2014
10,785
1
36
Visit site
how could we know that now, you just find your phone with spinning gears randomly, I think .67 had the best battery life, lets see how .105 turns out

I'm installing .105 now, download size was 31.5MB as stated by the update service, I'll have to confirm with my own data usage service
 

Chintan Gohel

Active member
May 23, 2014
10,785
1
36
Visit site
Installed .105 build, seems the same. Did a soft reset to clear a funny error where I couldn't see the signal or time or anything -just a white strip
 

EspHack

New member
Jun 11, 2013
1,279
0
0
Visit site
data usage seems to be broken, again, stuck with 300mb used, setting a new limit or removing it doesnt reset it, reboots and soft resets, nothing, its just stuck there
 

Chintan Gohel

Active member
May 23, 2014
10,785
1
36
Visit site
GPS has an issue locating on maps -workaround is to open whatsapp and then use that to search for location - then the maps app works okay
Maps also uses a lot of data when using GPS
 

Members online

Forum statistics

Threads
323,628
Messages
2,244,107
Members
428,092
Latest member
raymowen