• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

USB not detecting my Lumia 620 in PC after installed WP 8.1

prasanth1947

New member
Apr 23, 2014
85
0
0
I am not able to find my phone in my PC after installed WP 8.1.

has one face this issue? or am I the only one here? can anybody help me to sort out this issue.

I have tried in windows XP and WIndows 7

Thanks
Prasanth
 

kylezangel

New member
Apr 5, 2014
72
0
0
I also had this problem, to fix it I deleted my windows phone drivers, unplugged, plugged in again and let the new drivers install from scratch.

If that doesn't work, you can try going to devices from the remove hardware tab and change general settings of your phone
 

prasanth1947

New member
Apr 23, 2014
85
0
0
Thank you so much for the quick response, I am completely new to this to be done. would you mind please update more details what need to be done exactly ..
I just want to make sure before I start of this activity. dont want to mess in the middle of my job.

Thanks for uderstanding
 

kylezangel

New member
Apr 5, 2014
72
0
0
Okay, you know on the right of the taskbar there's a button you click when you want to remove hardware(eg flashstick)? Click that, you'll see a menu item along the lines of "devices center". Open that. In the new window you should see your device listed, double-click on it. Somewhere you should see "change general settings". Where it says what to do when the device is connected, choose open folder to view files.

From then on it should show up under computer. I don't have my laptop right now, but if you're stuck please say so
 

yaro da yaar

Banned
Jul 8, 2013
221
0
0
Thank you so much for the updates, I will try at home and let you know the status. thanks again
Dear prasanth, kylezangel deserves a thanks.I know, you thanked him but there is a thumbs up button by which you can thank him. Kylezangel puts his effort to give you a nice answer
 

prasanth1947

New member
Apr 23, 2014
85
0
0
Thanks Yaro, I am new to this forum so I am not really sure of all the funstionalities/utilities here yet.but thanks to you me to knowing it
 

prasanth1947

New member
Apr 23, 2014
85
0
0
Hi,its me again. I am not able to find out the options mentioned in my laptop as well as PC( one is with Windows XP and other one is Windows 7). But if I do other phone with Andro and Window 6.5 is still showing.

Any lights on this please ?

Thanks in advance
 

prasanth1947

New member
Apr 23, 2014
85
0
0
Hi Guys,

Any one can help me in this please ??? Still I am not able to access my mobile details on my PC. USB cable is usable for charging purpose at the moment.

Thanks in advance
 

prasanth1947

New member
Apr 23, 2014
85
0
0
Any one can help me here ?? I am facing this issue from the day 1 when I installed WP 8.1 in my 620 . I tried in 5 laptops with windows 7 and one desktop with XP but no luck. No signs of drivers showing in tray as well as device manager.

My battery is draining very quickly so I wanted to go back to WP 8 now, I tried NSU and NSRT etc etc but USB is not detecting so no luck. I am facing lot of issues due to battery draining. I keep my battery full around 11 PM in the night and I see in the morning with dead state .Thats the huge problem for me.

Any help is much appreciated since it is my oncall mobile.


Thanks in advance.
 

sinime

Retired Moderator
Sep 13, 2011
4,461
0
0
I've had my wife's 1520 not be recognized in USB a couple of times, but a quick reboot always remedied the issue.

As far as a solution to fix battery drain, idk, but does the battery saver app give any indication as to which app might be causing the drain?
 

prasanth1947

New member
Apr 23, 2014
85
0
0
thanks for the quick response but no luck with reboots in my case. I tried hard reset 3,4 times also but still no luck :( . I am not sure any settings need to be tweaked in the case of 8.1 . It was perfectly working with WP 8.0
 

prasanth1947

New member
Apr 23, 2014
85
0
0
No One to help me here?? Am I the only person facing this issue? then it should be some settings I should make( I am ready to reset once more too). Please help me .
 

ajayden

New member
Feb 26, 2012
795
0
0
No One to help me here?? Am I the only person facing this issue? then it should be some settings I should make( I am ready to reset once more too). Please help me .



Have you tried changing the USB cable?





Posted from Lumia 1020 using Tapatalk
 

prasanth1947

New member
Apr 23, 2014
85
0
0
Have you tried changing the USB cable?

Yes Ajay, I tried couple of USB cables and these are working for some other mobiles ( Samsung Omnia 2 and other Andro mobiles as well ) but the problem started after I installed WP 8.1





Posted from Lumia 1020 using Tapatalk
 

TechFreak1

Moderator
May 15, 2013
4,601
0
0
Try the following:
1) a different usb port

2) re-install the drivers, you will need to first uninstall it via the device manager, look for portable devices. Once done press f5 or scan for new hardware. Windows should reinstall the drivers automatically.

3) if the above don't work search for usb settings in bing on your phone, go to the phone view and check what options are ticked. (they should be both not ticked by default if not then untick the first one "ask me before using a usb connection". Safely remove the phone and plug it back in.

Let us know if any of the above works.
 

prasanth1947

New member
Apr 23, 2014
85
0
0
Thanks for all the options, I have tried all of them before and now as well. but still i am running with out of luck :( so sad for me. not sure what is making worse for me. I have did hard reset and soft reset multiple times to fix this issues , still no shine.

I am afraid that I don't see any option for the drivers in device manager and even I tried in new laptop .

Any other suggestions ??
 

ajayden

New member
Feb 26, 2012
795
0
0
Thanks for all the options, I have tried all of them before and now as well. but still i am running with out of luck :( so sad for me. not sure what is making worse for me. I have did hard reset and soft reset multiple times to fix this issues , still no shine.

I am afraid that I don't see any option for the drivers in device manager and even I tried in new laptop .

Any other suggestions ??

Have you also downloaded the windows phone app?
 

prasanth1947

New member
Apr 23, 2014
85
0
0
nope, I have not downloaded it yet. I did hard reset in this morning again and installed only Whats App and file manager .

Do we need to install windows phone app? what is the main purpose of that one? can you please help me in this ?

and please provide the exact link for this app if it is needed to install.

Thank you all for your kind suggestions so far.
 

Members online

Forum statistics

Threads
316,164
Messages
2,233,413
Members
427,363
Latest member
mldavis99