WiFi + DHCP weirdness

kaffeenhed

New member
Dec 6, 2010
2
0
0
Visit site
I've got a Focus, and a couple of times over the past week, I've tried to connect to a couple of different WiFi access points on my corporate network. I have a few AP's that are secured with WPA2, and a couple that are unsecured for guest access. The AP's are different manufacturers/models, from a couple of cheap DLink and Netgear ones to some high end Cisco AP's.

Weirdly, it wouldn't connect to any of these. It would detect them, but would always come back and say it couldn't reach the network when I tried to make a connection. It connects fine at home and to a few other public/private networks I use.

On my corporate AP's, DHCP is disabled; I have a DHCP server elsewhere on the network, so none of my AP's are allowed to hand out IP addresses. My phone won't connect to these AP's, and it won't connect at another site where with a similar configuration, but a different DHCP server platform.

Just for grins, I went and created a single address DHCP pool on one of the AP's, and my phone connected immediately.

Based on what I've seen with my phone, it won't connect to a WiFi network in which the AP is configured to not act as a DHCP server.

Anyone else have a similar/different experience with that sort of network configuration?
 

Members online

No members online now.

Forum statistics

Threads
323,628
Messages
2,244,107
Members
428,092
Latest member
raymowen