Windows 10 Mobile build 15205 Discussion (Redstone 3; Fast Ring)

Ariel Takom

New member
Aug 9, 2015
386
0
0
Visit site
Just installed today on my Lumia 950DS, and everything seemed good. It's only been about 10 hours, but so far performance has been as brilliant as 15204 or whatever the previous FR version is. Hopefully it'll maintain the same performance level, or better.

EDIT: Outlook e-mail notifications in the Action Centre is still broken. The only way for me to know if I have an e-mail is either through the Outlook notification on my lock-screen, or from the live tile. Could anyone please tell me if you know of any workarounds to fix this? It's been there since the CU FR builds, and after all those OS build and the Outlook app updates, this is still happening.

P/S: I've tried enabling notifications, banners, and all that from the settings page as well as the Outlook Mail app itself, yet the same thing happens. I've yet to reset the app or perform a Hard Reset as I'm in a busy period of my university semester and I really need my phone to be in a usable condition in all times to communicate with my project group.
 

Rupert Holmes

New member
Apr 18, 2014
113
0
0
Visit site
No known problems. I have being running this build since the 15th. Only thing I have noticed is greater battery life, a good thing. The rest of the listed fixes are of little importance to me, except maybe Edge improvements. I would still like to see a repeating messaging notifications option. Continuum is a cute exercise, but really I will just carry my laptop. 950LX Dual Sim, if only it had my 1020's camera it would perfect.
 

Keith White Jr

New member
Feb 21, 2014
529
0
0
Visit site
As weird as it sounds, I am LOVING this update on my 1320! Phone runs faster and I have yet to experience any random freezes or screen tearing (both of which happened OFTEN before this build).
 

andyqkw

New member
Sep 12, 2012
152
0
0
Visit site
Could it be that your telcos are in the process or had already decommissioned the 2G network?

Ar, now that you mention it...

Yes, the telco here have indeed decommissioned the 2G network just recently and I've clear forgotten about it.

No wonder the SIM 1/SIM 2 is not working now when the other one is active.

Thanks
 

PerfectReign

New member
Aug 25, 2016
859
0
0
Visit site
Haven't updated my X3 to 207 yet. Am on 205 still. Anyone else notice that you can't turn off monitoring in the feedback hub?

t2VaGyU.jpg



Sent from mTalk
 

Members online

No members online now.

Forum statistics

Threads
323,182
Messages
2,243,401
Members
428,035
Latest member
powerupgo