• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

WSL not working after update from Microsoft store

srpurani

New member
Apr 9, 2022
1
0
0
Hello I had successfully installed WSL few days ago and everything was working fine. But after the I got an update regarding WSL from Microsoft Store I updated WSL and since then it is throwing this error. I also restarted the computer and checked to make sure my Virtual Machine Platform and Windows Subsystem for Linux are ON and I found out that both of these services were already ON. still I get the same error. May I please get any guidance on this one? as I have to use WSL for my educational purpose that would be really helpful thanks

Installing, this may take a few minutes...
WslRegisterDistribution failed with error: 0x80070050
Error: 0x80070050 The file exists.

Press any key to continue...
 
Jun 9, 2021
428
4
18
Try in uninstall and after restarting you system install it again hoping your problem will be solved.
I also suggest you to report this problem on "Feedback Hub"

You definitely find lots of stuff and videos regarding the solution of this problem but most of them didn't work as per the comments and feedback...