The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. TheMiseryOfMe's Avatar
    So tomorrow I think I'm going to take the plunge and install the TP on my main laptop then move it to the 10122 build because my friend has told me it's stable enough now. Are there any huge problems he may have neglected to tell me that would stop me installing the TP.
    I am aware of the risks and have made a few back ups.
    05-21-2015 04:20 PM
  2. Zulfigar's Avatar
    No, even Microsoft said this latest preview is good on main computers, so enjoy Windows 10. :D
    TheMiseryOfMe likes this.
    05-21-2015 04:22 PM
  3. xandros9's Avatar
    Be careful though. It isn't radioactive, but it still runs the risk of causing issues.

    There isn't too many overall issues, but there is still risk because luck.

    You seem well prepared though. The current slow ring build is enough for me, so you shouldn't run into issues unless it decides to crash and burn.
    TheMiseryOfMe likes this.
    05-21-2015 06:56 PM
  4. tofnow's Avatar
    I let it Fast Ring install over the previous build which was pretty good. The best I can say for 10122 is that, at least in my installation, Spartan/Edge works very well. People, Mail and Calendar start and stop almost immediately I do not have an icon for Feedback. Had to send feedback on this using another build.
    TheMiseryOfMe likes this.
    05-21-2015 07:10 PM
  5. michail71's Avatar
    Feedback is linked from the insider's app. You can pin it once you launch it. It's as if they had enough feedback, lol.

    Hmm, perhaps I'll provide feedback that it is too hidden.

    Spartan is working very well. Though I did upgrade to an NVIDIA card today. They made Win10 drivers and Spartan had the radeon bug so NVIDIA got my money.
    TheMiseryOfMe likes this.
    05-21-2015 11:16 PM
  6. Rasetech's Avatar
    I have the following issues:

    • Login with pin not working anymore altough in settings it says that a pin is configured
    • Insider-Hub app crashing immediately
    • Some apps dont get updated through the store (Health & Fitness and the Cooking App, Music and Video)
    TheMiseryOfMe likes this.
    05-22-2015 12:49 AM
  7. michail71's Avatar
    Only issues I've had are with Task View and multiple desktops. Messing with it can lock my computer up to where I need to cut power.
    TheMiseryOfMe likes this.
    05-22-2015 07:28 AM
  8. TheMiseryOfMe's Avatar
    Only issues I've had are with Task View and multiple desktops. Messing with it can lock my computer up to where I need to cut power.
    Do you mean multiple desktops as in dual screens because, I often use two screens for my work.
    05-22-2015 08:11 AM
  9. tofnow's Avatar
    This morning, People still not working but Calendar and the rest, including Mail. I did nothing else but close it down overnight and reboot.
    TheMiseryOfMe likes this.
    05-22-2015 08:57 AM
  10. michail71's Avatar
    Do you mean multiple desktops as in dual screens because, I often use two screens for my work.
    No, just virtual desktops in task view.
    TheMiseryOfMe likes this.
    05-22-2015 10:34 AM
  11. TheMiseryOfMe's Avatar
    Oh ok well in that case I should be fine, thank you.
    05-22-2015 10:38 AM
  12. net voyager's Avatar
    i have installed it as a main os no turning back now games run great and im using the latest lintel grafic's card driver 8.1 and it works fine on my laptop i can actually run two or three games and alt tab between them its turned my lappy into a decent low end gaming platform its working well no real problems so far all i have noticed is that when i send a short-cut to start it displays it all pix-elated and distorted maybe i have a setting wrong ill have to investigate or it could just be a bug
    TheMiseryOfMe likes this.
    05-23-2015 06:02 PM
  13. TheMiseryOfMe's Avatar
    i have installed it as a main os no turning back now games run great and im using the latest lintel grafic's card driver 8.1 and it works fine on my laptop i can actually run two or three games and alt tab between them its turned my lappy into a decent low end gaming platform its working well no real problems so far all i have noticed is that when i send a short-cut to start it displays it all pix-elated and distorted maybe i have a setting wrong ill have to investigate or it could just be a bug
    Thanks I'm am looking forward to installing it but I'm currently stuck on build 10074 (which seems somewhat stable for now) because of an update error. I will watch out for the distortedness when I finally upgrade.
    05-24-2015 04:46 AM
  14. michail71's Avatar
    i have installed it as a main os no turning back now games run great and im using the latest lintel grafic's card driver 8.1 and it works fine on my laptop i can actually run two or three games and alt tab between them its turned my lappy into a decent low end gaming platform its working well no real problems so far all i have noticed is that when i send a short-cut to start it displays it all pix-elated and distorted maybe i have a setting wrong ill have to investigate or it could just be a bug
    That's probably an older program without a higher resolution icon needed for the modern start. IMHO, MS needs to make sure everything that ships with the OS can support that resolution. Notepad is like that now. Pin notepad to start and it looks terrible.
    05-24-2015 11:20 PM
  15. garak0410's Avatar
    I heard enough good things about 10122 that I decided to clean install it (on new SSD) on my work PC...but I was immediately disappointed that PIN TO START is broken... :(
    05-27-2015 08:07 AM
  16. Steven Taylor 5's Avatar
    I'm upgrading my secondary (work) computer with 10125 from Win 7 Pro 64 as I'm writing this. I've had many problems with 10074 (Hyper-V VM) and some with 10122 (dual-boot), but I'm hoping 10125 is going to be fairly good enough for daily use. All of the programs installed run fine in Windows 8.1, and the Win 10 installer didn't complain.
    05-28-2015 11:38 AM
  17. Steven Taylor 5's Avatar
    OK, I'm back. The first sign of success was a local login prompt after install. W 10 did not ask me for a Microsoft Account. Surprised. Three minutes of waiting after hitting Enter at login page (1.6 GHz C2D U9600, but with 128 GB SSD) for the two subsequent pages.

    The "Hi" stage now is pulsing blue shades, not a rainbow like 8.x. Just received a full page "Unfortunately, it's taking longer than usual" message. Never have seen that before, but not surprised that it's happening on this machine. That stage took about 5-6 minutes.

    Screen went black, cursor still works. This lasted until I figured out that explorer.exe (shell) hadn't initiated. Ctrl+Alt+Delete - Task Manager - Run New Task fixed that. All of my pinned icons are there.

    Now for a shut down - restart to see if it stuck. It did. Asked for Ctrl + Alt + Delete to allow for login, just like before. Everything is there on boot. Yay!
    Last edited by Steven Taylor 5; 05-28-2015 at 01:05 PM.
    05-28-2015 12:36 PM

Similar Threads

  1. Tapping the Music note on Volume Control toggles mute!
    By someone2639 in forum Windows 10 Mobile Insider Preview
    Replies: 1
    Last Post: 05-22-2015, 09:19 AM
  2. Need help screen is black and the os is runnning
    By rapide8 in forum Nokia Lumia 920
    Replies: 5
    Last Post: 05-22-2015, 08:17 AM
  3. First look at the new universal MSN apps for Windows 10 Mobile
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-21-2015, 01:00 PM
  4. DMD Panorama for Windows Phone takes and shares panoramic images
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 05-21-2015, 12:50 PM
  5. Why do my Windows 10 TP updates take forever to download?
    By Skulls138 in forum Ask a Question
    Replies: 0
    Last Post: 05-21-2015, 12:15 PM
LINK TO POST COPIED TO CLIPBOARD