1. p1800nut's Avatar
    I know that Waze hasn't been updated on Windows phones since 2014 or so, but I've found that even with the limited functionality it meets my needs on my Lumia 640. But as of last night, it has stopped working entirely. The splash screen comes up but it never seems to connect, and eventually closes on its own. Has the End finally come?
    01-17-2018 12:07 PM
  2. Kerry2112's Avatar
    Not yet (at least, not for me). I used it today as every other day, with no problems, on my 950XL DS.

    If it (or CloudMuzik) ever die on W10M, that'll be it for me. Both absolutely indispensable for me.
    01-17-2018 12:30 PM
  3. camaroz1985's Avatar
    Hasn't worked on W10M for me in some time. It never connects, and that has been on several different devices, so I can't blame it on one. It was one of the final straws for me.
    libra89 likes this.
    01-17-2018 12:48 PM
  4. p1800nut's Avatar
    Interesting split opinions, which is also what I found with more general Googling. I'm not sure if that reflects different definitions of "working" (mine was already hobbled, but I considered it workable), different devices, or some sort of rolling shutdown.

    Whatever it is, it looks like my L640 is headed to retirement. Oddly, I can't get GMaps to work either--also freezes on the opening page--though since the native Maps works, it's not a problem with my GPS radio. I wonder if an API changed, rendering other sat nav programs useless....
    01-18-2018 02:55 PM
  5. fatclue_98's Avatar
    It may just be a regional thing. Has anyone uninstalled it and then re-installed?
    01-18-2018 07:18 PM
  6. p1800nut's Avatar
    I tried installing and reinstalling with no luck,

    HOWEVER, I did have success when I did a hard reset and reloaded the backup. Obviously I had to reset some of my settings, but it was a pretty painless way to get Waze back. (Interestingly, GMaps is working too, though I don't think I'll be using it with Waze working.)

    Granted, it's still a bit funky. For example, it seems to get stuck in a recalculating loop, but all I need to do is use the back arrow (like I was exiting the app), and then choose Cancel and it turns out that it has actually completed the recalculation. Somewhat annoyng, but I can live with it.
    01-18-2018 11:07 PM
  7. camaroz1985's Avatar
    Didn't work for me after uninstall/reinstall or hard reset/restore. For me it is truly dead.
    01-19-2018 01:49 PM
  8. sneaky7642's Avatar
    p1800nut,

    I contacted WAZE Support November 2017, and I've attached their response below. I'm using the WAZE app on my 950XL phone with occasional GPS issues. But, I hadn't had any problems this past week. I guess from there response, all the Windows Phone users will need to uninstall and re-install the WAZE app monthly for them to provide us with updates and support. I love my Windows 10 Phone, but it's getting frustrating not having the app support. I'm giving Microsoft to the end of this year to get this resolved or I will move to another device.

    --

    From: waze.cases@google.com
    Sent: Wednesday, November 29, 2017 9:23 AM
    To: sneaky7642
    Subject: RE: [2-6367000020057] My location isn't shown on the map

    Hi Christopher,
    Thank you for contacting Waze Support.
    New versions of the Waze app are not currently optimized for the Windows Phone platform, since the vast majority of Waze users are on iOS or Android devices. We are monitoring the Windows Phone install rate and will certainly reconsider if there is significant uptake.
    Thanks,
    The Waze Support Team
    --
    fatclue_98 likes this.
    01-20-2018 12:24 PM
  9. fatclue_98's Avatar
    We are monitoring the Windows Phone install rate and will certainly reconsider if there is significant uptake.
    A very polite way of saying "you outta gas, dog".
    libra89 and Chippy757 like this.
    01-20-2018 07:41 PM
  10. anthonyng's Avatar
    Installed it!
    01-21-2018 05:27 AM
  11. dacarter77's Avatar
    it's working for me.
    01-24-2018 04:02 PM
  12. gmfeld's Avatar
    Today I replaced my L950 with a new L950. When I set it up I did a clean install of all apps. I downloaded Waze, but now it just says "No Network Connection" every time I launch it. It was working fine yesterday on my previous 950. Did I lose the ability to use Waze in the change to the new phone?
    02-08-2018 04:37 PM

Similar Threads

  1. Over priced iPhones. Is Apple fooling people?
    By Satish Singh in forum The "Off Topic" Lounge
    Replies: 36
    Last Post: 01-25-2018, 12:07 AM
  2. My OS is 15254.16
    By okizen in forum Windows 10 Mobile Insider Preview
    Replies: 2
    Last Post: 01-17-2018, 03:53 PM
  3. Microsoft is launching the Xbox One X in India on Jan 23
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-17-2018, 08:10 AM
  4. Microsoft made Android Windows-friendly — but the work is far from done
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-16-2018, 12:30 PM
  5. 'They Are Billions' for PC is a deep strategy game that finally makes you fear zombies
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-15-2018, 04:10 PM
LINK TO POST COPIED TO CLIPBOARD