The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Laquox's Avatar
    I've tried twice now to update to build 10158 and each time it throws a blue screen with an error of: Recovery
    Your PC needs to be repaired
    There isn't enough memory available to create a ramdisk device
    Error Code: 0xc0000017

    Since the build is brand new obviously there are no threads or solutions to this problem. Anyone know why this particular build would give me this error? I have never had this problem with any previous builds.
    06-29-2015 10:07 PM
  2. shorski's Avatar
    I did not have any problem updating to this build. You probably need to do some repairs on your pc. Refresh your pc and redo the update. You will lose your apps and settings though.

    z30sta100-2os10.3.blackberry
    06-30-2015 03:34 AM
  3. Laquox's Avatar
    I don't think I am ready to wipe and re-install just yet because of a hiccup.
    06-30-2015 10:51 AM
  4. MrMakeEmAkkRight's Avatar
    Having same problem. Reset failed now have to start all over again from scratch
    06-30-2015 10:55 AM
  5. Laquox's Avatar
    Reset failed now have to start all over again from scratch
    That's what I was worried about. I don't want to reset only for it to also fail and I lose everything and have to start over. I know it's a bug because SFC scan returned nothing and this problem didn't happen with other builds on the same PC so I know it's not a ram issue either.
    06-30-2015 11:29 AM
  6. MrMakeEmAkkRight's Avatar
    Never had an issue before this build. Not sure what to say about it but I hope MS gets it together I kno its not my PC. I'll wait to see how this 'Rebuild' goes before I judge
    06-30-2015 11:36 AM
  7. Laquox's Avatar
    Make that 2 PCs, completely different specs that cannot update to build 10158 due to this error. About to test 3rd PC and see if the problem happens as well. This bug is very reminiscent of the 8.1 bug that behaved the same way.
    06-30-2015 01:15 PM
  8. Adam Gorecki's Avatar
    I have the same problem today: in the time of upgrade to 10158 my computer hang on with the blue screen. I try do do some more or less stupid things :) i.e. turn all options in BIOS to default but without effect.

    Finally I found in BIOS in Boot Menu an option "Launch EFI Shell from filesystem device - Attempts to Launch EFI Shell application (Shell64.efi) from one of the available filesystem devices". I'm not sure what that mean exactly but when I choose it, that WORKS! My computer restart two or three times and then upgrade operation was resumed (from about 75%) and successfully finished.

    My motherboard is Asrock H77 Pro 4 MVP. System disc is SSD Crucial 512.
    06-30-2015 01:28 PM
  9. MrMakeEmAkkRight's Avatar
    Well, got all the way back up to build 10130 worked my way around the failing updates and now it doesn't see the new build in the fast ring. Lost all my data for nothing 😩
    06-30-2015 02:00 PM
  10. Laquox's Avatar
    UEFI/EFI is not on either system so this isn't my problem but it does point to what may be causing the problem with the memory allocation.
    06-30-2015 02:08 PM
  11. Laquox's Avatar
    Well, got all the way back up to build 10130 worked my way around the failing updates and now it doesn't see the new build in the fast ring. Lost all my data for nothing
    Sorry to hear that. In general a reset is a LAST resort measure that you should only do if all else has failed. Personally, I can wait until the next build or RTM and let them fix this. I already sent a tweet over to Gabe and am hoping I get a response sometime. It's obviously a problem with the build.
    06-30-2015 02:10 PM
  12. MrMakeEmAkkRight's Avatar
    Sorry to hear that. In general a reset is a LAST resort measure that you should only do if all else has failed. Personally, I can wait until the next build or RTM and let them fix this. I already sent a tweet over to Gabe and am hoping I get a response sometime. It's obviously a problem with the build.
    Yeah, got a little too excited about the new build. It was too late to turn back once I said screw it so looks like I'll be waiting until rtm as well.
    06-30-2015 04:48 PM
  13. DalekSnare's Avatar
    I was able to update yesterday, but 10158 corrupted my system so badly not even a reset fixed it. I had to install from an iso to get a working version again. So now I'm back to 10130 and there's no update this time.
    06-30-2015 09:22 PM
  14. shorski's Avatar
    10159 is showing now. Probably that will fix your issues

    z30sta100-2os10.3.blackberry
    06-30-2015 10:52 PM
  15. MrMakeEmAkkRight's Avatar
    I was able to update yesterday, but 10158 corrupted my system so badly not even a reset fixed it. I had to install from an iso to get a working version again. So now I'm back to 10130 and there's no update this time.
    Same as me. I went through that long and tedious road but now the new build just showed up and installing now. Seems to be installing fine for now
    06-30-2015 11:30 PM
  16. 4lpha's Avatar
    Unfortunately I have the same issue - but apparently the 10159 build hasn't resolved it. Anyone have any other ideas?
    07-01-2015 06:34 PM
  17. PBlessing's Avatar
    Was not even able to get to 10159. I did the install from 8.1 yesterday and it updated me to 10130. After that it just said that my pc was up to date.
    07-02-2015 11:59 AM
  18. 4lpha's Avatar
    Wow - just saw 10162 is now available. Downloading now and crossing my fingers....
    07-02-2015 07:24 PM
  19. 4lpha's Avatar
    No difference. Still getting the blue screen. I burned an ISO and tried boot repair (even though it boots to the old install fine every time except when upgrading), but that did not help. SFC reports no issues. Ran repair on the HD to scan for anything but no problems detected. I am getting very frustrated now. My other systems upgraded fine with no issue - but my main PC won't.

    Looking over my logs, it started reporting a December update could not be installed (weird since it's been updated regularly and never had an issue until now). I can't find that update anywhere though. Also, it's having an issue with a Samsung USB driver. Might make sense if it was a hard drive driver (I have a Samsung EVO SSD)....
    07-02-2015 07:49 PM
  20. shorski's Avatar
    I just updated to 10162 with no single issue

    z30sta100-2os10.3.blackberry
    07-03-2015 05:33 AM
  21. David Feifer's Avatar
    Was not even able to get to 10159. I did the install from 8.1 yesterday and it updated me to 10130. After that it just said that my pc was up to date.
    Seems like there is a lock in place allowing you to upgrade builds only once in a 24hr time frame. Did a reset yesterday morning on 10130 and would not show any further builds until this morning. Unfortunately I am still having the same issue of it being on the pre restart page before installation "configuring update for windows 10 85% complete do not turn off your computer" and never get past this. Have tried to get past10130 4 times and given it as much time as 12 hrs. Looking like I will be doing an in place upgrade with the current build.
    07-03-2015 09:06 AM
  22. infosage's Avatar
    Same here, how frustrating.
    07-03-2015 11:15 AM
  23. PBlessing's Avatar
    They finally put out the 10162 ISO. I reinstalled windows 8.1 and then installed from the ISO and it worked fine.
    Last edited by PBlessing; 07-08-2015 at 09:14 PM. Reason: changed to 10162
    07-08-2015 08:57 AM

Similar Threads

  1. Is the current build of Windows 10 for phones stable enough for everyday use?
    By thepolicecall911fordetails in forum Windows 10
    Replies: 18
    Last Post: 08-26-2015, 03:15 PM
  2. Why won't it save my "Windows Update Preferences"?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-20-2015, 03:51 PM
  3. Updating Issues ? Read this and fix it !
    By Hasan Chocor in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 07-06-2015, 09:02 AM
  4. Why won't my Windows phone update?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-29-2015, 07:10 PM
  5. Microsoft Wi-Fi makes an appearance in Windows 10 build 10158
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-29-2015, 06:20 PM
LINK TO POST COPIED TO CLIPBOARD