1. mkdll's Avatar
    Hello people!
    Since I updated to Windows 10 websites are not loading properly, but not all the time, sometimes they load as fast and normal than ever and some others they don't load at all and I need to hit refresh like 10 times for them to show up. It doesn't matter what website it is, the problem is with every one of them and also its persistent with every web browser (Edge, FF, Chrome). I have a laptop in my home too and it loads websites as it should be so it's not an internet or modem problem.

    Any help?
    08-02-2015 02:15 PM
  2. Blkacesvf41's Avatar
    I had the same problem. Do a restart, that fixed it for me.
    08-02-2015 02:19 PM
  3. mkdll's Avatar
    I had the same problem. Do a restart, that fixed it for me.
    Do you mean restarting the PC? I have done it many times and I still have the same problem.
    08-02-2015 02:31 PM
  4. Blkacesvf41's Avatar
    Do you mean restarting the PC? I have done it many times and I still have the same problem.
    Yup, just the PC, it was that simple for me. Is this an older PC? I noticed Windows10 runs much better on newer hardware. Even the install was faster.
    08-02-2015 02:55 PM
  5. Unkn0wnU53r's Avatar
    been in the same situation, restart the pc havent helped, cleared web history, registry, temp files if can find a solution will share here :/
    08-02-2015 08:41 PM
  6. mkdll's Avatar
    I'ts not an older PC, not that old. I made my PC as a gaming rig about 3 years ago. I have an AMD 8150 8 core at 3.60GHz and 16GB RAM, just to say some of the specs, so I don't think that's the problem here.

    Unkn0wnU53r I hope you could find a solution, I'm really close to get back to Win 7, it's really annoying and nearly impossible to use my PC in this way.
    08-02-2015 11:11 PM
  7. Blkacesvf41's Avatar
    I'ts not an older PC, not that old. I made my PC as a gaming rig about 3 years ago. I have an AMD 8150 8 core at 3.60GHz and 16GB RAM, just to say some of the specs, so I don't think that's the problem here.

    Unkn0wnU53r I hope you could find a solution, I'm really close to get back to Win 7, it's really annoying and nearly impossible to use my PC in this way.
    Mine really settled down after a couple of days and it's been great since. Give it a few more restarts and see what happens. There's obviously quite a few bugs to be worked out. Yesterday, my Start screen button on the left side of taskbar completely became invisible. I could click on it and it worked, but you couldn't see it. Weird stuff!
    08-03-2015 07:17 AM
  8. mkdll's Avatar
    Mine really settled down after a couple of days and it's been great since. Give it a few more restarts and see what happens. There's obviously quite a few bugs to be worked out. Yesterday, my Start screen button on the left side of taskbar completely became invisible. I could click on it and it worked, but you couldn't see it. Weird stuff!
    There are some issues indeed, then I'll better wait a few days.
    I was looking for information about this in the anwers.microsoft website and it looks like there are more people with this problem and nobody knows how to fix it yet so I think It will get patched in an update.

    Today I found a temporary (and weird) fix. I unplugged the ethernet cable and I enabled Wifi connections in my PC, now I can open every website using wifi only, it's somewhat slow for some reason but it works better than with the ethernet cable.
    08-03-2015 11:52 AM

Similar Threads

  1. Software update
    By anon9476898 in forum Windows 10 Mobile Insider Preview
    Replies: 10
    Last Post: 08-11-2015, 07:39 AM
  2. Windows Update KB3035583 not appearing at all?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 08-02-2015, 12:55 PM
  3. Videos not loading correctly
    By Mr_Costa in forum Windows 10
    Replies: 0
    Last Post: 08-02-2015, 12:51 PM
  4. Replies: 0
    Last Post: 08-02-2015, 12:08 PM
  5. Please let me know that if I can update my Nokia Lumia730 to Windows 10?
    By Purna Chandra Patnaik in forum Ask a Question
    Replies: 1
    Last Post: 08-02-2015, 12:01 PM
LINK TO POST COPIED TO CLIPBOARD