1. TITANWULF's Avatar
    I've looked everywhere in the forums for an issue with the Nokia Software Recovery Tool, but a lot of people have been getting problems with their phones for downgrading from DP for 8.1 to 8.0 and trying to do the Cyan update. My problem is strange... My computer (self built rig running 8.1 and fully up to date) can detect my Nokia Lumia 1520 and I can even use Windows Media Player or the Windows Phone App from Microsoft to transfer to and from the phone all of my files, but the Software Recovery Tool cannot recognize that my phone is connected at all. I have used the Hard Reset method of shutting it down and plugging the phone back into the computer when the Tool prompts that option and still nothing. It will take forever (~5 minutes) to boot back on and the Tool doesn't recognize it still. I've uninstalled, re-downloaded the up-to-date Tool, re-installed the Tool, and same thing happens... No go. Can anyone help me with this situation, and has anyone else experienced this as well?
    07-25-2014 09:18 PM
  2. Keith Brooks's Avatar
    I'm in the same boat as you. The Nokia Software Recovery Tool program doesn't recognize my Nokia Lumia 521 running Windows Phone 8.1 Developer Preview in Windows 8.1 Pro w/Media Center x64 Update. The Windows Phone app's on desktop and the start screen, as does Windows 8.1 Pro, all recognize my Lumia 521. Just Nokia's software doesn't.
    07-26-2014 12:15 AM
  3. stanrogo's Avatar
    Yes the same problem here. I really don't know what could be wrong.
    07-26-2014 06:00 AM
  4. multiloop's Avatar
    Same problem here. Lumia 925 not being detected even after numerous hard resetting attempts.
    Was trying to get CYAN by downgrading from DP 8.1.
    07-26-2014 06:33 AM
  5. Goldy Mazumdar's Avatar
    Lumia 925........not detected by software :(
    07-26-2014 11:18 AM
  6. GabrielStorm's Avatar
    you'll need to d/l the latest version of NSRT.
    current version is 1.4.3
    07-26-2014 11:22 AM
  7. Goldy Mazumdar's Avatar
    I have the latest.......still not detecting
    07-27-2014 09:51 AM
  8. emperor_skull's Avatar
    I have the latest.......still not detecting
    Just wait for MS to find a fix
    07-27-2014 10:03 AM
  9. dumgeek's Avatar
    Change usd cable for a short one 3". Try an other usb port. Turn phone off before plug in the phone
    07-27-2014 10:05 AM
  10. HTC13's Avatar
    Changing to another USB port did it for me.
    07-27-2014 10:24 AM
  11. GabrielStorm's Avatar
    use the cord that came with your device, NOT a third party cord.
    form what has been posted in other threads, this seems to be one
    of the more common issues.
    07-27-2014 11:11 AM
  12. Silviu Bogusevschi's Avatar
    Delete the phone drivers in Device Manager and reconnect the phone.
    07-27-2014 04:37 PM
  13. Jowarman's Avatar
    Try running the Nokia Recovery tool in compatibility mode for Windows 7. (Disconnect the phone first, then run the program in compatibility mode, connect the phone) I had to downgrade/upgrade 5 Nokia phones in my family (all 925,925, 929, 1020, 1520). All went smoothly! Although I left my Surface Pro at home, so I had to resort to an old laptop with Windows 7.
    07-27-2014 05:25 PM
  14. multiloop's Avatar
    Uninstalling the Universal Serial Bus controllers and then re-installing them with the phone connected worked for me.

    But, the Recovery tool says I can install software version 3051.40000.1345.1001 to my phone.
    I am on the DP and my About Phone says my Firmware revision number is the same as above - 3051.40000.1345.1001 which is Lumia Black.

    I suspect that the recovery tool will give me Lumia Black and WP 8.0 together.
    07-29-2014 06:31 AM
  15. J0n5ey's Avatar
    I'm not having any luck either. The recovery tool doesn't detect my phone, while the laptop itself does.

    I've tried different cables, both USB 2 & 3 ports, uninstalling and reinstalling the tool, multiple restarts and still nothing :(

    Update: Tried all of the above again today and I'm guessing that magic faeries must have came and blew on it while I was making coffee, because everything is underway now.
    Last edited by J0n5ey; 08-08-2014 at 08:50 AM.
    08-07-2014 07:52 PM
  16. kansal's Avatar
    It worked for me after I updated the winusb driver..
    08-14-2014 02:05 AM
  17. Orcapilot's Avatar
    Hi all,

    Was having the same issue as the OP, in that the I could transfer data between the phone and PC, but NSRT wasn't recognizing the phone. Here's what I did to fix my issue:

    • Uninstalled NSRT
    • Went to Device Manager, and uninstalled the "Universal Serial Bus Devices" for my phone (see image)
    • Reinstalled NSRT
    • NSRT now recognizes my phone


    *For the Device Manager step, you may need to go to "View" and select "Show hidden devices." I right clicked and uninstalled each of those "Nokia Lumia 909 (RM-707)" files. As I uninstalled each one, it sometimes asked if I wanted to remove the associated software--I checked the box for yes. I didn't uninstall the "NOKIA BOOTMGR" or "NOKIA FLASH" files because I didn't know what they correlated with. The Nokia Lumia 909 files (there were three) reinstalled when I connected my phone.

    Hope this helps.
    tomipanu and ivokpop like this.
    08-15-2014 04:18 PM
  18. Hero Calibo's Avatar
    this one helps...thanks so much! followed your steps and it works. mwah
    08-23-2014 12:01 PM
  19. Firesilverblade's Avatar
    I installed it but it wont open the tool. Click on the icon on my desk top and nothing happens ( self built rig) running 8.1 updated.
    08-24-2014 01:01 AM
  20. Marko Marjanovic's Avatar
    Hey, found out this topic when i was searching for a solution.. if that doesen't work just unplug all USB devices from your PC, then restart it. REMOVE SD card from Windows Lumia phone, and try windows phone recovery tool. Works like a charm !
    02-23-2015 08:41 AM
  21. Nihad Asadov's Avatar
    And then how i am supposed to control my PC? Without any keyboard or mouse?
    im.thatoneguy likes this.
    04-15-2015 01:19 PM
  22. Jesse Dufva's Avatar
    The most working solution to this issue is running the application in Windows 7 -compatibility mode & as Administrator, set it up from folder the software is installed, Right click on the application icon, select Properties and check these boxes + Apply it
    06-23-2015 05:38 AM
  23. Albert Einstein1's Avatar
    MOTHER****ER THERE IS 2 recovery tools. Lumia and windows recovery. DOWNLOAD THE RIGHT ONE.
    07-29-2015 05:48 AM
  24. Mohieddine Shebaro's Avatar
    thanks worked for me after i turned off phone before plug in..
    08-06-2015 11:48 PM
  25. omerfbingol's Avatar
    Mine moves a little when I plug in my Lumia 925, but doesn't completely detect it. When I look at the logs, I can see the Lumia 925 name and other stuff very well detected. Can you say what is wrong by looking at this?
    Edit: I just flashed my phone using Microsoft developer tool that I found on the xda developers' forum. It comes in a folder along with a driver installer, WPID and NaviFirm+
    Now my phone gets recognized on the Windows Device Recovery Tool, though I can't install WDRT while connected to the Turkish ISP 'TTNet'. I can install it while connected to my phones hotspot.
    Attached Files
    Last edited by omerfbingol; 10-05-2015 at 10:52 AM.
    09-20-2015 08:01 PM

Similar Threads

  1. Microsoft's Windows Phone 8.1 Lockscreen app
    By Ma Rio in forum Windows Phone 8.1
    Replies: 16
    Last Post: 07-28-2014, 09:11 PM
  2. Hands-on with the new Live Lock Screen app for Windows Phone 8.1
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-25-2014, 08:42 PM
  3. Replies: 2
    Last Post: 07-25-2014, 08:34 PM
  4. Follow the Glasgow 2014 Commonwealth Games with the official app for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-25-2014, 08:11 PM
  5. BBM beta for Windows Phone gets transparent Live Tile and more before going public
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-25-2014, 07:42 PM