1. SuStel's Avatar
    My battery was draining fast yesterday. When I tried to go into Battery Saver from the app list to see what was using the power, the app started to load, then dropped back to the app list. I've restarted, done a soft reset, and just plain waited a day before trying again, but I still can't run Battery Saver. I've also tried deleting temporary files using Storage Check.

    I can go into Battery Saver from Settings, but when I swipe to Usage it crashes out again. BS from Settings loads the Settings pivot; BS from the app list tries to load the Usage pivot. Clearly, it's the Usage pivot that's causing the problem.

    What should I do?

    Lumia 920, AT&T, Cyan. Not running the developer preview.
    10-06-2014 02:49 PM
  2. primortal's Avatar
    10-06-2014 02:55 PM
  3. SuStel's Avatar
    Thanks for the link. Since you can't uninstall Battery Saver, and since it doesn't appear in the Store on the phone, I didn't realize I'd find it on the web.

    However, despite the website's claim that Battery Saver has been reinstalled on my phone, nothing has happened. I've watched the app closely and I've checked my download history. The app has not been reinstalled.
    10-06-2014 03:13 PM
  4. SuStel's Avatar
    Thanks for the link. Because you can't uninstall Battery Saver and because it does not appear in the store when searching on the phone, I didn't think to look for it on the Web.

    However, when I tell the store to reinstall Battery Saver, it says okay, sure, it'll install in a moment. But it never does. It's not in my current downloads or my history. I watch it in the app list and never see it being updated.

    If I go to the store in the phone's browser, it switches to the app in the Store app, but it doesn't give me an option to reinstall.
    10-06-2014 03:21 PM
  5. aikidaves's Avatar
    In my experience, system apps don't show in history, so you can't tell from there whether it reinstalled or not. However, if you're watching it closely and it's not doing anything within a few minutes of you ordering the reinstall, I'd be inclined to say that's not working - especially if the app is still broken.

    You could try the trick of turning off data and time updates, then changing the date to one in the far future, and see if it will let you uninstall the app then. It may not work, though, which probably leaves you stuck with a hard reset or a full reinstall using NSRT or whatever. Someone smarter than me may yet post a better answer, though. Good luck!
    10-06-2014 05:29 PM
  6. SuStel's Avatar
    I've found this topic in which several people experienced the same problem. The Date+Time trick did the same thing for me that it did for them: it lets you keep the app open, but the usage data is not there.

    It looks like everyone that's had the problem just had to wait a couple of days, and it started working again automatically—probably as bad usage data left the app and new usage data entered. I'm crossing my fingers.
    10-06-2014 05:49 PM
  7. badcat's Avatar
    10-06-2014 06:33 PM
  8. SuStel's Avatar
    I tried it, but it never prompts me to uninstall the app.
    10-06-2014 06:41 PM
  9. badcat's Avatar
    Sorry, this worked for me when I wanted to uninstall the Verizon contact backup app. I don't what else to try.

    Edit: Here's a link to a similar thread here on WPC.

    http://forums.windowscentral.com/win...date-cyan.html
    10-07-2014 03:28 AM
  10. SuStel's Avatar
    After several days, Battery Saver has started to work again on its own. This seems to have been the case with everyone else who's had the problem. I was just about to give up and hard reset the phone when I found it working this morning.
    10-09-2014 10:44 AM
  11. badcat's Avatar
    That seems to agree with what some of the people in the thread I linked to experienced. I'm glad it's working for you again.
    10-09-2014 08:34 PM
  12. azgoth444's Avatar
    Mine is doing the same thing. Been 2 days now. Frustrating.
    10-13-2014 06:53 PM
  13. SuStel's Avatar
    Hang in there. I imagine it could take up to a week to fix itself, depending on your usage and whatever vaguaries the bug has.
    10-14-2014 08:47 AM

Similar Threads

  1. WhatsApp always running in the background when battery saver is on.
    By Kaushik Dash in forum Update 1 for Windows Phone 8.1 (GDR1)
    Replies: 3
    Last Post: 10-06-2014, 04:52 PM
  2. Replies: 0
    Last Post: 10-06-2014, 02:21 PM
  3. How can I block some sites on my kids' Windows Phones?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 10-06-2014, 12:50 PM
  4. How do I save contacts from my Lumia 800?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 10-06-2014, 12:33 PM
  5. How do I add a second Skype account on my Windows phone?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 10-06-2014, 11:41 AM
LINK TO POST COPIED TO CLIPBOARD