1. BasketCase13's Avatar
    Today is the first time I've taken my Lumia 620 overseas.

    i landed and turned off data roaming, but the triangle is still there. At home, it always says "3G" when I'm connected to it, and it doesn't have that icon here. So...i think data roaming is off, but the triangle is rather disconcerting.

    i tried turning it off and on etc.

    Anyone else had this problem? My old iPhone never did that.

    thanks.
    06-27-2013 08:44 PM
  2. klcow's Avatar
    The triangle appears even with data off, it shows you that you are currently roaming overseas (as in mobile network, not data).
    06-28-2013 12:40 AM
  3. BasketCase13's Avatar
    Ah ok thank you. I couldn't figure it out. :)
    06-28-2013 09:19 PM
  4. bgpt45's Avatar
    Must I have to roam in my own profider country? If we were abroad I'm agree, but not in your own country. I have Lumia 630 Dual SIM, the first SIM is using the profider where i live and the second from a profider abroad, but I saw 2 triangles. For the second I'm agree, but not for the first SIM. Try to disable "roam" option, but no data connectivity is possible. At this time option "roam" is always on! I think it's a bug from Microsoft!
    07-05-2014 04:08 AM

Similar Threads

  1. Miracast - Where is it (8.1 preview)
    By Shawn Keating in forum Microsoft Surface for Windows RT
    Replies: 11
    Last Post: 08-12-2013, 03:20 PM
  2. today is troll day on the forums?
    By Bartdog in forum The "Off Topic" Lounge
    Replies: 2
    Last Post: 06-28-2013, 08:13 PM
  3. Kindle on the 928
    By MikeLip in forum Nokia Lumia 928
    Replies: 1
    Last Post: 06-28-2013, 09:13 AM
  4. Does Speed alert on here drive + work well?
    By chocolateyum in forum Applications
    Replies: 5
    Last Post: 06-27-2013, 09:02 PM
LINK TO POST COPIED TO CLIPBOARD