1. arifdanials's Avatar
    I was not using and somehow my younger brother accidentally switched off the main switch which also turned off the wifi modem at my home. Obviously my phone would lost connection to the wifi. And when I tried to reconnect to the wifi, the name of the wifi doesn't pop up anymore. I tried rebooting and full resetting my phone, nothing changed. My phone still can't detect my home's wifi but it can detect the neighbour's wifi. (I am using the GDR3 Preview for Developers)
    01-06-2014 08:53 AM
  2. gwinegarden's Avatar
    Can anyone else connect to your router? Perhaps you lost some settings.
    01-06-2014 08:58 AM
  3. arifdanials's Avatar
    My family members' devices reconnected to the modem as soon as it was working. I can't do anything with my phone after trying to full reset my phone.
    01-06-2014 09:05 AM
  4. cgranjaobando's Avatar
    Have you tried to reset your router?... its works but I think this is an issue from windows because my 520 it can detects neighbours wifi networks but not my home's
    05-10-2014 12:56 PM
  5. wkrwk's Avatar
    I'm facing this exact problem with my Dad's phone, Lumia 525. The 525 can detect other wifi except the house's wifi. And other devices can connect to the house wifi except the 525. I've reset and reboot everything. Still can't solve it. Have you found a solution?
    08-04-2014 08:43 PM
  6. arifdanials's Avatar
    I'm facing this exact problem with my Dad's phone, Lumia 525. The 525 can detect other wifi except the house's wifi. And other devices can connect to the house wifi except the 525. I've reset and reboot everything. Still can't solve it. Have you found a solution?
    I have but I called for assistance from the internet provider, I suggest you do the same.
    08-06-2014 05:05 AM
  7. T-System's Avatar
    I know this is old but seeing as it is a top result on Google:

    Try changing the Wireless Channel on the router. I had recently changed mine to 13 to avoid interference. It was working for a while and then one day the the wireless network simply disappeared. I couldn't understand why.

    Changed it to Channel 1 and all was well again. The Lumia 920 may only support standard Channels 1 - 12. If suffering from poor Wireless bandwidth, try setting your wireless router to Auto. It should sort it all out for you.

    Hope this helps
    BritDad likes this.
    06-23-2015 01:49 PM
  8. 13071973's Avatar
    Thanks so much, your solution has just worked for me. I changed the channels from Auto to 1. Then all of a sudden the WiFi was detected.
    02-22-2017 12:51 AM

Similar Threads

  1. How to get GDR3 on my Lumia 625
    By SoullessOnyx in forum Windows Phone 8
    Replies: 4
    Last Post: 01-07-2014, 09:54 AM
  2. My first App - Arsenal Motif
    By Saighduiri in forum Developers Corner
    Replies: 3
    Last Post: 01-06-2014, 03:03 PM
  3. Is my SD card Good?
    By Devmer11 in forum Windows Phone 8
    Replies: 7
    Last Post: 01-06-2014, 01:12 PM
  4. Heating up my Lumia 520
    By Rakesh Racky in forum Nokia Lumia 520
    Replies: 7
    Last Post: 01-06-2014, 09:22 AM
  5. Events for Me, an Eventbrite client app for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-06-2014, 08:00 AM
LINK TO POST COPIED TO CLIPBOARD