1. flair77's Avatar
    I had Draw Something installed on my phone and it worked just fine for about 2-3 days, but then developed this strange problem.

    One, it started taking agesssssss to load.
    Two, once it loads, when I select a partner, all of a sudden a message pops up, something to the likes of "This game needs an active internet connection to work" and when I press OK (which is the only choice), it exits and is back on the main menu. Needless to say, there is an active internet wifi connection when I'm trying this and it works perfectly fine with browsing, whatsapp, skype etc.

    Any pointers guys?
    04-03-2013 06:33 AM
  2. hamzie11's Avatar
    restart phone?
    toggle wifi on/off?
    04-03-2013 07:06 AM
  3. Aggemam's Avatar
    Draw Something sucks on WP. Bad port I guess.
    04-03-2013 07:17 AM
  4. doadrian's Avatar
    I have the same Internet connection problem on Lumia 920.
    04-03-2013 09:55 AM
  5. flair77's Avatar
    restart phone?
    toggle wifi on/off?
    First thing that's done my friend.
    04-04-2013 05:10 AM
  6. despertador's Avatar
    Look in the reviews. The app sucks, and I bought it.

    EDIT: Seems like it's fixed now!
    Last edited by interopbyt; 05-27-2013 at 10:18 PM.
    05-15-2013 01:09 AM

Similar Threads

  1. Replies: 4
    Last Post: 08-10-2013, 06:05 PM
  2. AT&T and my Lumia 920 (Long story)
    By kennethsd in forum Windows Phones
    Replies: 2
    Last Post: 02-20-2013, 09:21 PM
  3. Replies: 27
    Last Post: 01-21-2013, 02:12 PM
  4. And my Lumia 920 screen shattered
    By Harish Rao in forum Windows Phones
    Replies: 44
    Last Post: 01-17-2013, 12:48 PM
  5. 2 Weeks with my Lumia 920 and....
    By koldmiser in forum Windows Phones
    Replies: 0
    Last Post: 11-29-2012, 12:08 AM
LINK TO POST COPIED TO CLIPBOARD