09-01-2016 02:45 AM
73 123
tools
  1. Windows Central Question's Avatar
    Hi,

    I have updated my Lumia 830 to Win 10 and it was successful. However when my device was receiving the latest app update for the Windows Camera, the update installed successfully. It showed on my device but later when I opened the app, it crashed and gave me 0xA00F424A(0xC00D3704) error and the main camera is not working ever since. I have tried using other applications such as Instagram Beta, 6Tag and Lumia Selfie but can not access the main camera. However the front camera is working. I have also tried to roll back to win 8.1 by using the recovery tool but the main camera issue remains.

    Here are the informations of my Lumia 830,

    Manufacturer Name: RM-984_1000
    OS version: 8.10.15148.160
    Firmware Revision Number: 02177.00000.15184.36002
    Hardware Revision Number: 1.0.0.0

    Please if any of the nice people could help me I would really appreciate it.

    Thanks in advance.
    04-11-2016 03:47 AM
  2. Chintan Gohel's Avatar
    Hi,

    I have updated my Lumia 830 to Win 10 and it was successful. However when my device was receiving the latest app update for the Windows Camera, the update installed successfully. It showed on my device but later when I opened the app, it crashed and gave me 0xA00F424A(0xC00D3704) error and the main camera is not working ever since. I have tried using other applications such as Instagram Beta, 6Tag and Lumia Selfie but can not access the main camera. However the front camera is working. I have also tried to roll back to win 8.1 by using the recovery tool but the main camera issue remains.

    Here are the informations of my Lumia 830,

    Manufacturer Name: RM-984_1000
    OS version: 8.10.15148.160
    Firmware Revision Number: 02177.00000.15184.36002
    Hardware Revision Number: 1.0.0.0

    Please if any of the nice people could help me I would really appreciate it.

    Thanks in advance.
    If no app can open the main camera, it could be a hardware issue. Is your phone under warranty? Can you take it to a service center?
    04-11-2016 06:10 AM
  3. Y C Neo's Avatar
    Originally posted by Windows Central Question
    Hi,

    I have updated my Lumia 830 to Win 10 and it was successful. However when my device was receiving the latest app update for the Windows Camera, the update installed successfully. It showed on my device but later when I opened the app, it crashed and gave me 0xA00F424A(0xC00D3704) error and the main camera is not working ever since. I have tried using other applications such as Instagram Beta, 6Tag and Lumia Selfie but can not access the main camera. However the front camera is working. I have also tried to roll back to win 8.1 by using the recovery tool but the main camera issue remains.
    ...
    I had exactly the same issue when updated to one of the insider preview 1-2 build before the official WM10M roll out. Tried rolled back to WP 8.1 GDR2 but the camera remain as dead, updated to official 10586.107 then to 10586.164 didn't change anything...
    I've thought this as a hardware issue that I'll need to send in to service, but surprisingly the newest 10586.218 brought the camera back alive!! I'm not too sure if it is the OS updates or the latest camera software updates (version with HDR option) that corrected this issue, apparently it was not a hardware issue.
    Chintan Gohel and jpharwood like this.
    04-13-2016 10:38 PM
  4. lucaspedersoli's Avatar
    Hi, I'm on release preview (also L830) with camera not working. I'm on 10586.107 and it doesn't find any updates, not 164 and certainly not 218. I just re-rolled into the release preview ring, maybe that'll do the trick. Wish me luck!

    Edit: okay, that did the trick, hope camera works again, I'll report when it updates!
    04-19-2016 08:47 PM
  5. lucaspedersoli's Avatar
    Hi, I'm on release preview (also L830) with camera not working. I'm on 10586.107 and it doesn't find any updates, not 164 and certainly not 218. I just re-rolled into the release preview ring, maybe that'll do the trick. Wish me luck!

    Edit: okay, that did the trick, hope camera works again, I'll report when it updates!
    Well, it didn't work... idk... here are my phone details:

    Manufacturer Name: RM-985_1005
    OS version: 10.0.10586.218
    Firmware Revision Number: 02040.00021.15235.53003
    Hardware Revision Number: 1.0.0.0
    SOC: 8926

    Also after the updates the phone promt me with a "welcome to Cyan" notif, which is weird, at least. I'll stop insider updates to see if theres any firmware update to download L830 specific.
    04-19-2016 10:48 PM
  6. meet liya's Avatar
    Well, it didn't work... idk... here are my phone details:

    Manufacturer Name: RM-985_1005
    OS version: 10.0.10586.218
    Firmware Revision Number: 02040.00021.15235.53003
    Hardware Revision Number: 1.0.0.0
    SOC: 8926

    Also after the updates the phone promt me with a "welcome to Cyan" notif, which is weird, at least. I'll stop insider updates to see if theres any firmware update to download L830 specific.
    Same with me, i update did update with
    OS version :10.0.10586.218, but issue remain same.
    04-24-2016 04:16 AM
  7. bh5213's Avatar
    I have the same issue. Camera was working fine on 8.1. Last night I updated to OS 10.0.10586.218 and the camera is not working getting that same error message. Camera and update works fine on my 640. Any advice?
    04-24-2016 11:25 AM
  8. bh5213's Avatar
    Has anyone found a solution yet? Soft and hard reset did not work for me.
    04-25-2016 07:07 PM
  9. lucaspedersoli's Avatar
    Seems w10m somehow manage to break the 830s that remained alive and away from this ****ed up camera issue... nice!
    04-25-2016 08:59 PM
  10. Y C Neo's Avatar
    Has anyone found a solution yet? Soft and hard reset did not work for me.
    I got the camera error when in one of the preview build before the official build 10586.107. I search internet and saw many reported the same issue, out of these some said replaced the camera module it works, some said the issue remain; some still searching for solution; there is one that said flashing to a firmware of a different country variant solved the issue. I didn't search for the way to flash firmware of different country variant, and I reckon it would be quite cumbersome, hence I choose to roll back to WP8.1 GDR2, thinking that it might fix the issue, but it did not.

    I updated my L830 when W10 mobile officially release, it first update to 10586.107 then to 10586.164, between the update, I check and found the camera remain dead, and it remain as dead after updated to 10586.164. I've gave up hope of it coming back alive.

    When 10586.218 was released, I update my L830 also, and to my surprise the camera is back alive!! It is still alive after updating to the latest 10586.242. The L830 is a spare phone, it do not have a SIM card, but there is a micro SD card. I've took out the micro SD card after I updated to 10586.164, and have not put in a micro SD since then.

    I'm not too sure if micro SD is the cause of the camera issue, above is my experience to share. You may want to try using WDRT to roll back to WP8.1 GDR2 first, then update to Windows 10, remove the SIM card and storage card when using the WDRT and updating to Windows 10.
    jpharwood likes this.
    04-29-2016 05:56 AM
  11. lucaspedersoli's Avatar
    Well, kind of reflashed the phone over a thousand times allready, still, since you're giving me some sort of hope, I'll do it again.
    I'm updating through the update advisor now, thought to try it out. I'm on 218 and there's no update promt, just checked for updates and 242 doesn't pop up. Are you going Insider way release preview ring? Thanks for the hope, lets see what happens now... :P

    Edit: btw, if you can point out the firmware version and variant you have on your device I could try that one. I think I can install a rm-984 rom on a rm-985 right? I'm not sure...
    Last edited by lucaspedersoli; 04-29-2016 at 10:38 AM.
    04-29-2016 06:37 AM
  12. Y C Neo's Avatar
    Well, kind of reflashed the phone over a thousand times allready, still, since you're giving me some sort of hope, I'll do it again.
    I'm updating through the update advisor now, thought to try it out. I'm on 218 and there's no update promt, just checked for updates and 242 doesn't pop up. Are you going Insider way release preview ring? Thanks for the hope, lets see what happens now... :P

    Edit: btw, if you can point out the firmware version and variant you have on your device I could try that one. I think I can install a rm-984 rom on a rm-985 right? I'm not sure...
    Sorry, I left my Lumia 830 in office today, I'll only be back in office on Tuesday morning (Singapore time), I can't retrieve the firmware version now ...
    Mine is a Singapore set, I believe is RM-984. Yes, I've joined the release preview ring to update to the latest 10586.242.
    04-29-2016 11:42 AM
  13. lucaspedersoli's Avatar
    Thanks man, no rush. I'm doing some flashing now :P
    04-29-2016 11:47 AM
  14. Robert Novak1's Avatar
    I have a 830 on WP 10 and the main and secondary camera work as advertised and I am on the latest update. My phone is unlocked ATT model
    04-30-2016 04:07 AM
  15. Y C Neo's Avatar
    Thanks man, no rush. I'm doing some flashing now :P
    Hi bro, as promised, here is the device info in the Settings > System > About screen.

    Model: NOKIA Lumia 830
    Software: Windows 10 Mobile
    Installed RAM: 1GB

    Version: 1511
    OS build: 10.0.10586.242
    Firmware revision number: 02177.00000.15184.36005
    Hardware revision number: 1.0.0.0
    Radio software version: 401c3.00009.0001
    Chip SOC version: 8926


    EXTRA & INFO

    Manufacturer Name: RM-984_1062
    Mobile Operator: SIN-SG
    Configuration ID: 1062.028D1A
    Core Build ID: 6230.54 (02177.00000.15184.36000)
    ...
    ...
    Build Creation Date: 14/7/2015
    05-02-2016 08:38 PM
  16. lucaspedersoli's Avatar
    Thanks bro, I'll try it asap. Still have to google if flashing rm-984 is viable on rm-985 device and whatever consequences could have. I think that Q has been answered regarding L920. I'll let you know what happens as soon as I can :D Thanks again and good luck!
    05-03-2016 10:39 AM
  17. lucaspedersoli's Avatar
    Well, no luck... Idk I'm thinking now of that refurbish option on NSC(Nokia Suit Care) maybe it can be useful. And also all the other files provided when you search for the firmware, like, you flash that one file which extension I don't remember, and there are a lot of other files which use are still unknown :P time to find info on refurbishing
    05-04-2016 08:06 AM
  18. Y C Neo's Avatar
    Well, no luck... Idk I'm thinking now of that refurbish option on NSC(Nokia Suit Care) maybe it can be useful. And also all the other files provided when you search for the firmware, like, you flash that one file which extension I don't remember, and there are a lot of other files which use are still unknown :P time to find info on refurbishing
    hi bro, this may be useful >> https://stebet.net/how-to-install-a-...ecovery-tools/ , http://www.lumiafirmware.com

    I've no idea whether it is possible/safe to flash RM-984 firmware to RM-985, though they are all Lumia 830, you'll be doing at your own risk..
    If you're not using the camera much I would think just leave it, who knows a future O/S upgrade (did you try Redstone?) may fix it..
    05-04-2016 12:30 PM
  19. lucaspedersoli's Avatar
    Originally posted by Y C Neo
    Originally Posted by lucaspedersoli
    Well, no luck... Idk I'm thinking now of that refurbish option on NSC(Nokia Suit Care) maybe it can be useful. And also all the other files provided when you search for the firmware, like, you flash that one file which extension I don't remember, and there are a lot of other files which use are still unknown :P time to find info on refurbishing
    hi bro, this may be useful >> https://stebet.net/how-to-install-a-...ecovery-tools/ , http://www.lumiafirmware.com

    I've no idea whether it is possible/safe to flash RM-984 firmware to RM-985, though they are all Lumia 830, you'll be doing at your own risk..
    If you're not using the camera much I would think just leave it, who knows a future O/S upgrade (did you try Redstone?) may fix it..
    Hi, I used lumiafirmware.com to download the firm, it has the latest firmware for each cv and carrier, the thing is I read somewhere installing old firmware may solve the issue. But you can only download the latest ones on that website and navifirm is down (and in navi you needed a payed account to download older firmware) so I'll have to find older fw somewhere else... Contacting MS for help is pretty useless... I double checked that sadly xD
    Thanks for your caring!
    Btw yes the camera is indeed important to me. I bought it because it has a better camera than 640 and of course a micro sd slot (otherwise I'dpuck a 1020). I can't afford a L950 which hasn't even arrived to Argentina, still it's even out of my league if it arrives, at least for now, I'll probably buy it when its price goes down 1/2 years. It get's even worse... The 830 was never sold here so the official service points MS has here do not have the spare parts needed to change the camera module (if its actually a hardware issue) I bought it from a guy that originally bought it in Mexico. I'll add a spider pic I took with this phone later.
    05-04-2016 01:04 PM
  20. lucaspedersoli's Avatar
    And yes, I've tried Redstone. I tried the 3 update rings and also update advisor which is a slower update ring than release preview on the windows insider app, it's like the official update. The only thing left to try is older firmware and look if any of those files on the lumiafirmware web is useful for any kind of fix. Idk, the error code is, as it seems, related to drivers. If the reflash doesn't get the drivers right idk what could do. I've installed rm-984 I looked on some forums and the one you cannot install is the att version rm-983 cause I think that's a no return flash.
    05-04-2016 01:18 PM
  21. lucaspedersoli's Avatar
    For 2300 views there're not many ppl actually participating on the discussion :P
    05-05-2016 08:50 PM
  22. bh5213's Avatar
    Maybe we are all hoping someone figures it out....I keep coming back hoping you found a resolution...nothing I have tried has worked...so I am back on my 640. I so rather be using my 830.
    05-05-2016 10:09 PM
  23. karthikraman's Avatar
    Seriously frustrating. Sometimes it just works... even after the 218 update. I am wondering if some combination of Lumia apps gets this to work? I have a feeling the camera worked transitorily while I was updating store apps, and deleting unnecessary apps.

    Does anyone with a Lumia 830 and Win 10 218 have a working camera? I am asking this because I also had issues with my camera with 8.1 -- didn't work for a few months and randomly started working at some point of time.
    05-07-2016 09:59 AM
  24. raycpl's Avatar
    My 830 refuse to work on a couple of previous builds (both updated without restore from backup)

    Once, the screen keep going green, the other instance the error message was "there is another app using the camera" (can't recall the exact words) and refuse to launch...
    I had to do hard reset.
    The other, was uninstall camera related apps, followed by several soft resets.. Then it was ok
    ... bugs!! How we love the challenges!!
    05-07-2016 10:29 AM
  25. lucaspedersoli's Avatar
    .318 still no luck... Anyone has any ideas? Maybe I should start a new thread so we can make polls to gather some information, since a guest made thin one... Also a changeorg thingy, to get some attention from MS maybe...?
    05-14-2016 08:47 PM
73 123

Similar Threads

  1. Who of us still with 1020 as the only and main phone?
    By diego866 in forum Windows Phones
    Replies: 209
    Last Post: 04-08-2020, 11:25 PM
  2. Lumia 640, Ways to get windows 10?
    By Windows Central Question in forum Windows Phones
    Replies: 6
    Last Post: 04-19-2016, 02:11 PM
  3. Why does my Microsoft Lumia 640 XL keep killing my headphones?
    By Windows Central Question in forum Windows Phones
    Replies: 1
    Last Post: 04-11-2016, 03:29 AM
  4. Foxsports.com.au videos only load on wireless connection, not cable. Any help?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 04-11-2016, 12:57 AM
  5. About updates in w10m
    By haykol in forum Ask a Question
    Replies: 2
    Last Post: 04-11-2016, 12:45 AM
LINK TO POST COPIED TO CLIPBOARD