The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. podsnap's Avatar
    I've updated my Omnia 7 to Mango.

    Yet I get a warning on several apps about incompatability.

    A lot of compass apps tell me my phone doesn't have a compass.

    Mango Compass tells me I don't have access to the motion API and that I need the final build of Mango (which is what I have).

    Samsung Now app still doesn't install.

    That said, Mango only apps such as What's App run fine.

    Aaarrrggghhh!

    Any ideas people?
    10-06-2011 07:32 AM
  2. TheWeeBear's Avatar
    I hadn't heard of this app podsnap, so downloaded it and installed and it runs fine on my Omnia 7.

    I have the Samsung setting app 'High Fidelity Positioin' installed would that have any bearing on the Mango compass app working maybe podsnap ?

    If it's not in the Samsung Zone, just do a search for Samsung.

    Bear in mind it can't be uninstalled, only turned off, once it's installed.

    (It appears right at the bottom of settings once installed)

    PS Samsung Now app is still kaput.
    Last edited by TheWeeBear; 10-06-2011 at 08:20 AM.
    10-06-2011 07:47 AM
  3. podsnap's Avatar
    Thanks for the heads up about High Fidelity. I don't know why these apps aren't 'adverstised' to users more. How am I supposed to know that exists?

    Anyway, back to the point. While it clearly makes a difference in Maps, it doesn't have any bearing on the compass.

    I also tried to install the WinPhone Info' app which tells me, not only do I not have a compass but I don't have a gyroscope either.

    What is going on. Is there something physically wrong with my Omnia 7?

    Where can I go for official support?

    OS version: 7.10.7720.68
    Firmware revision number: 2424.11.2.3
    Hardware revision number: 3.15.0.4
    Radio software version: 2424.11.7.2
    Radio hardware version: 0.0.0.800
    Bootloader version: 5.8.1.9
    Chip SOC version: 0.36.2.0
    10-06-2011 08:49 AM
  4. podsnap's Avatar
    Hmmm, interesting. It would seem that some Omnia 7 users have firmware: 2424.11.8.5 after the update.

    For some reason I don't have that.

    Does anyone know how I get the updated firmware on my phone?

    Thanks.
    10-06-2011 09:01 AM
  5. TheWeeBear's Avatar
    I have firmware revision number 2424.11.8.5 podsnap, it must be that causing your problem.
    (All other revisions are the same as yours)

    Mine updated to these versions with my forced Mango update.

    No idea why you didn't get it. :(
    10-06-2011 09:08 AM
  6. podsnap's Avatar
    Just did a test of the speed reading HTML5 page. It is reading at only 6 FPS so there must be something wrong.

    It must be the firmware.

    Why did I not get this and how do I get it?

    Thanks.
    10-06-2011 09:09 AM
  7. TheWeeBear's Avatar
    Clutching at straws here podsnap, but have you tried the Omnia update tool ?

    No idea if it will help or not.

    http://org.downloadcenter.samsung.co...KC3_Ver1.2.exe
    10-06-2011 09:39 AM
  8. podsnap's Avatar
    Yeah, I'd tried that TheWeeBear.

    It does say something like 'The attached Omnia 7 needs a binary update' but while it seems to run quickly through the process, the end result is the same, no change.

    Oh well, I may try yet another restore and update.

    Otherwise I'm going to have to resort to calling Samsung.

    I'll probably get the same response I got from Virgin Mobile when I called them, "Is that an Android phone?"!
    10-06-2011 10:05 AM
  9. TheWeeBear's Avatar
    Aw good luck podsnap, sorry couldn't think of anything else, it's a bit of a strange one.
    10-06-2011 10:18 AM
  10. podsnap's Avatar
    I so called it!

    On the phone to Samsung, "So it's not an Android phone!?"

    I mean, what hope do you have when their own support don't know their own products!
    10-06-2011 10:53 AM
  11. TheWeeBear's Avatar
    I so called it!

    On the phone to Samsung, "So it's not an Android phone!?"

    I mean, what hope do you have when their own support don't know their own products!
    Unbelievable, but not unexpected, like you said. :(
    10-06-2011 10:55 AM
  12. selfcreation's Avatar
    I so called it!

    On the phone to Samsung, "So it's not an Android phone!?"

    I mean, what hope do you have when their own support don't know their own products!
    LOL same thing happened to me when i called.
    10-06-2011 11:10 AM
  13. TheWeeBear's Avatar
    You might find this of interest podsnap. :)

    http://www.windowscentral.com/micros...-7-now-testing

    So wonder if i'll get any newer firmware, I thought I already had it.
    10-06-2011 11:52 AM
  14. eepyaich's Avatar
    Podsnap - you're not alone. I'm also running Mango and seem to have the newer main firmware, but have the older radio firmware and am not getting any compass action.

    FWIW - I'm on Orange UK and I upgraded to the Mango RTM back in the summer when it was unofficially leaked. When the official Mango release came out, I did get a Samsung, but nothing else.

    For the record, my various firmwares are:

    OS - 7.10.7720.68
    Firmware revision: 0222.11.8.5
    Hardware revision: 3.15.0.4
    Radio software: 2424.11.7.2
    Radio hardware: 0.0.0.800
    Bootloader: 5.8.1.9
    Chip SOC version: 0.36.2.0
    10-08-2011 06:55 AM
  15. eepyaich's Avatar
    Sorry - turns out I was mistaken. My compass is now working - it just took some significant calibration.
    10-08-2011 08:44 AM
LINK TO POST COPIED TO CLIPBOARD