1. kevin_tenza's Avatar
    I got my mother a L535 but it just can't hold on to the mobile operator network whilst other phones on the same network have no issues at all. Tried updating but still nothing. Does anyone have a fix for this?
    05-24-2015 03:47 AM
  2. gpobernardo's Avatar
    I've also experienced this with an L535 I used to own.

    There are several possibilities which you may consider:

    1. The antenna of the L535 isn't as well-designed as the other phones - no fix for that.

    2. Check the cellular frequencies your mobile service provider is broadcasting and compare that with the frequencies compatible with your phone. This can be easily found in the Official Microsoft Specifications Page.

    3. Check the settings of the phone and make sure that the maximum connection speed is set to 3G.
    kevin_tenza likes this.
    05-24-2015 04:00 AM
  3. kevin_tenza's Avatar
    I've also experienced this with an L535 I used to own.

    There are several possibilities which you may consider:

    1. The antenna of the L535 isn't as well-designed as the other phones - no fix for that.

    2. Check the cellular frequencies your mobile service provider is broadcasting and compare that with the frequencies compatible with your phone. This can be easily found in the Official Microsoft Specifications Page.

    3. Check the settings of the phone and make sure that the maximum connection speed is set to 3G.
    I gguess it's the antenna. I just tried the sim on another L535 and the network bar was full
    gpobernardo likes this.
    05-25-2015 03:39 AM
  4. gpobernardo's Avatar
    You might be able to have your phone replaced or repaired depending on the policy of the store from which you bought your L535.
    05-25-2015 01:19 PM
  5. nzmbe's Avatar
    Ok so 8 months ago I got Nokia Lumia 630. So for the first few months the phone was working perfectly but after the update of the system my phone started to glitch out. Then the NO NETWORK FOUND problem started. I restarted my phone and it worked and after few hours it showed the same error. I had 3 bars of frequency but when I want to go into my cellular and SIM setting it says no network found. I can't recieve messages, I can't send messages, when i call someone it doesn't ring it's just stuck on the call screen. And of course I can't use my mobile network... Can someone help me btw I sent it to service twice and they said the phone is working properly. I changed my SIM and it still gets the same error. Can someone please help me?
    06-13-2015 04:25 PM
  6. vipme's Avatar
    06-13-2015 06:26 PM
  7. nzmbe's Avatar
    I tried that actually... I was doing the factory reset myself and they did it in service but I'm not going to lose anything so I'll give it a try... Thanks
    06-13-2015 10:37 PM

Similar Threads

  1. Why won't OneDrive update in Windows 10 mobile?
    By rubicj in forum Windows 10 Mobile Insider Preview
    Replies: 4
    Last Post: 05-25-2015, 09:00 AM
  2. wifi calling for T-Mobile
    By xoxoxo5000 in forum Microsoft Lumia 640
    Replies: 1
    Last Post: 05-23-2015, 09:42 PM
  3. How large is the new Windows mobile 10 file
    By Hisham Thajudheen in forum Ask a Question
    Replies: 1
    Last Post: 05-23-2015, 03:04 PM
  4. Don't update MSN Weather on Windows 10 Mobile!
    By natan man in forum Windows 10 Mobile Insider Preview
    Replies: 0
    Last Post: 05-23-2015, 02:59 PM
  5. Problem with internet explorer on 3G network.
    By vikrant1982 in forum Nokia Lumia 920
    Replies: 0
    Last Post: 05-23-2015, 02:07 PM
LINK TO POST COPIED TO CLIPBOARD