1. roi_noir's Avatar
    Good morning to all;

    Ive changed my Lumia 630 DS to a Lumia 640 XL DS not lte.
    Ive used a Nanosim card for my 3g/2g flat rate and another one from the same operator to make calls.
    Im under WP 8.1 and all is updated.
    For me, both sim cards have stopped. In the cellular menu +sim, I cannot find my sim cards.
    Indeed, its displayed in grey Sim 1 setting , sim card one, and its the same for im 2.
    I cant put my phone in plane mode, and I have then to restart my device. It works fine for a time and and restarts again.
    Ive changed my internet sim card, but the problem persists. Ive permuted the Sim cards,,, its the same.
    I add a screenshot.
    What I must do ? change the device ? the sim cards ? or other thing ?

    Thanks
    Attached Thumbnails cell.jpg  
    09-22-2015 04:22 PM
  2. Derausgewanderte's Avatar
    Is it possible that you didn't insert the SIM cards correctly? The 640XL takes micro SIM cards, not NANO. You could either get an adapter that takes the nano to a micro or you could carefully slide the nano SIM into the micro slot. You need to move it all the way to the right side (going by sliding in direction) and move it slightly further than flush with the back. If you look at the image in the link of a micro adapter you can get an idea of how far in and how far right you have to push the SIM into the slot.
    capture.png

    I've done this on mine and my wife's and it works.

    Hope it's as simple as that.

    good luck
    roi_noir likes this.
    09-22-2015 06:45 PM
  3. roi_noir's Avatar
    I'm very very sorry. I use 2 microsims, not nanosims.
    Thank you, You're right.
    And now ? 😥
    09-22-2015 07:49 PM
  4. micallan_17's Avatar
    Have you tried a factory reset?
    roi_noir likes this.
    09-22-2015 07:58 PM
  5. roi_noir's Avatar
    Yes, I reseted the phone 5 times.
    After each reset it works correctly only for some period.
    09-22-2015 08:07 PM
  6. Derausgewanderte's Avatar
    Yes, I reseted the phone 5 times.
    After each reset it works correctly only for some period.
    odd, have you tried with just a single SIM inserted and tried to reproduce the problem?
    roi_noir likes this.
    09-22-2015 08:11 PM
  7. yasfer21's Avatar
    Ive permuted the Sim cards
    That is not recommended. Purchase and test the phone with an actual micro SIM.
    roi_noir likes this.
    09-22-2015 09:46 PM
  8. Derausgewanderte's Avatar
    That is not recommended. Purchase and test the phone with an actual micro SIM.
    I think he means he simply swapped them.
    roi_noir likes this.
    09-22-2015 09:57 PM
  9. roi_noir's Avatar
    Yes, I tried with the sim card used for calls, and there is no problem.
    But, the 2 sim cards work nicely in my Lumia 630 ds.
    09-22-2015 11:54 PM
  10. roi_noir's Avatar
    The 2 sim cards are new.
    Yes, by permute I mean interchange them.
    Derausgewanderte likes this.
    09-22-2015 11:58 PM
  11. roi_noir's Avatar
    With one sim, there is no problem.
    I haven't try with sim for internet, only with sim for calls.
    09-23-2015 12:10 AM
  12. roi_noir's Avatar
    Do You think that the problem will ne solved if I return my device and replace it by a new one ?
    If there is an incompatibility between my sim cards and all Lumia 640 ds models, I prefer keep my phone.
    Thanks.
    09-23-2015 12:37 PM
  13. Derausgewanderte's Avatar
    Do You think that the problem will ne solved if I return my device and replace it by a new one ?
    If there is an incompatibility between my sim cards and all Lumia 640 ds models, I prefer keep my phone.
    Thanks.
    I do not know. I have not tried two sims simultaneously yet. I suspect there are limitations after reading some of the other threads here. E.g.
    this one
    http://forums.windowscentral.com/mic...al-sim-4g.html

    some folks having problems reported on MS forums.
    http://answers.microsoft.com/en-us/m...54fed8a?auth=1

    indicates it may also be operator related too. Certainly contact your provider.
    Last edited by Derausgewanderte; 09-23-2015 at 05:52 PM.
    roi_noir likes this.
    09-23-2015 05:30 PM
  14. roi_noir's Avatar
    Thank you amigo.
    With your help I know I am not the only to have some issues with Lumia 640 xl ds.
    I think that will be useless to return back the phone to Nokia seller, the problem is in the Lumia 640 model (this is my conclusion).
    Anyway , my next phone will not be a Microsoft phone. They took my 300 € quickly, but they took all the time response their costumers.
    Good bye.
    09-23-2015 07:15 PM
  15. djeire84's Avatar
    Have you tried cleaning the Sims? Have you used compressed air to clean the sim point on the phone? Does your sim card need to be replaced with a new one (just transfer your details to the new sim your carrier will do this for you)
    09-23-2015 07:52 PM
  16. roi_noir's Avatar
    Yes, I cleaned them.
    The 2 SIM cards work nicely in other phones. And I replaced them by new cards. They are new.
    09-23-2015 08:06 PM
  17. Mohamed Ahmed Nader's Avatar
    I had a 630 DS and it behaved the same as urs and then it just stopped getting any signal one day. And that's from both sim cards!! Sent it to Nokia care and they wanted to charge me almost the price of the phone for a new antenna and said the antenna was wet or so I thought, had it sent to a private shop to give it a look and he said that someone messed with some antenna pins and ruined the PCB also told me that the signal transmission line is right next to the power line from the charger so basically it wasn't about being wet it was bad PCB architecture.

    Morale of the story. U should change it/the phone while u can
    roi_noir and Derausgewanderte like this.
    09-23-2015 08:54 PM
  18. roi_noir's Avatar
    to yasfer,
    I don't threat. I just share my experience with you about Windows phone Lumia 640.
    And about trying different operators SIM cards, I ask if it is normal that a phone works with 2 different operators cards but not with same operators, when other phones work with every/any SIM cards like Nokia Lumia 630 ds !?.
    Have a nice day/night.
    09-23-2015 09:17 PM
  19. roi_noir's Avatar
    Thanks bro.
    09-24-2015 05:24 AM
  20. roi_noir's Avatar
    I had a 630 DS and it behaved the same as urs and then it just stopped getting any signal one day. And that's from both sim cards!! Sent it to Nokia care and they wanted to charge me almost the price of the phone for a new antenna and said the antenna was wet or so I thought, had it sent to a private shop to give it a look and he said that someone messed with some antenna pins and ruined the PCB also told me that the signal transmission line is right next to the power line from the charger so basically it wasn't about being wet it was bad PCB architecture.

    Morale of the story. U should change it/the phone while u can
    Thanks bro.
    09-24-2015 05:25 AM
  21. Derausgewanderte's Avatar
    sounds like you tried everything you could and it looks like it is your 640XL that doesn't play well with two SIM cards inserted. Definitely try to get it exchanged. If you can try this in a store near by even better (MS or provider). Only walk out of the store with it working.
    roi_noir likes this.
    09-24-2015 05:22 PM
  22. roi_noir's Avatar
    Thanks,
    Actually, I am waiting for the last answer from a MS helper from answer.microsoft.com, after that I will go to the store.

    Have a nice day.
    09-24-2015 05:42 PM

Similar Threads

  1. Replies: 2
    Last Post: 09-23-2015, 01:28 AM
  2. Why is my Nokia 920 not charging or turning on?
    By Windows Central Question in forum Nokia Lumia 920
    Replies: 1
    Last Post: 09-23-2015, 01:12 AM
  3. Will the Nokia Lumia Icon get the new upcoming Windows 10 update?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-22-2015, 05:23 PM
  4. Both sim cards have stopped, how can I get them working?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-22-2015, 04:26 PM
  5. How do I get windows 10 to replace the builders version on my laptop?I
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-22-2015, 03:33 PM
LINK TO POST COPIED TO CLIPBOARD