11-07-2015 01:18 AM
28 12
tools
  1. ZUBA1R's Avatar
    Hello all I am new to the forum I've got a problem, recently I bought a Nokia Lumia 520 and its working smoothly well but the only problem is SD card is not detecting. I tried my old 1GB card first it didn't worked and SD card shows "Not Found" then i read that you have to format the SD card FAT32 I did the same but again SD card shows "Not Found" then I tried another SD card this time a 2GB but again SD card shows "Not Found" finally I tried a 4GB card but same problem (Note: All these 3 cards I tried on Lumia 520 are working well on other phones). I am very worried and want this problem to be solved quickly . So please help me an advice how should I solve this problem. Thanks *Waiting for all your replies* Thanks
    07-31-2013 06:31 AM
  2. WanderingTraveler's Avatar
    Hmm. If you upgraded from Symbian, try formatting it using your old phone.

    If not, and the info on your microSD card isn't really important, buy a new one, and test it if it works first.

    This is from a 620 user who doesn't need a microSD card.
    07-31-2013 07:31 AM
  3. Rob Betts's Avatar
    Hi Zuba1r,
    I had similar problem, wouldn't recognise 3 sd's but cured after a hard reset..
    Bob
    07-31-2013 04:12 PM
  4. ZUBA1R's Avatar
    @Rob Betts How to do the "Hard Reset" ? Could you please explain the procedure how did you solve this problem ? Thanks
    08-01-2013 01:25 AM
  5. Rob Betts's Avatar
    ZUBA1R,
    Assuming you have swapped the sd's then you are doing a hard reset by removing the battery to do it. I finally had to resort to a "software" reset. This puts the phone back to an out of the box state. Full linstructions given here:
    http://files.nokia-x.com/pdf/Nokia%2...e%20Manual.pdf
    Use at your own risk, backup what you can.
    Bob
    08-01-2013 11:11 AM
  6. pratikhjoshi's Avatar
    I have purchased new lumia 520 and with sandisk 16gb SD card but i have done with sd installation as per on site but yet not getting detection message on my phone kindly help me out on this.

    Thanking you in Advance..
    09-07-2013 08:04 AM
  7. jimkraz's Avatar
    I get this info if I restart my Lumia 520, but once boot is finished, I check and my Music and Photo Albums are there, yet it has asked me to re-format card, but it does pick it up and play my music fine.
    I was getting same on my new 820, but after Amber it "seems" ok. Jim
    09-07-2013 08:30 AM
  8. eugie's Avatar
    Your card defective...
    09-07-2013 08:38 AM
  9. pratikhjoshi's Avatar
    I get this info if I restart my Lumia 520, but once boot is finished, I check and my Music and Photo Albums are there, yet it has asked me to re-format card, but it does pick it up and play my music fine.
    I was getting same on my new 820, but after Amber it "seems" ok. Jim
    Thank you for your revert back..

    Amber? i dont have an idea about that can you please explaining?

    I have check with other phone samsung and also check with pc its working fine in both.. so my card is okay there is a no diffectivness...
    09-07-2013 12:57 PM
  10. rakesh1995's Avatar
    I had to soft reset my phone for sd card to show up. 16gb sandisk.

    Sent from my Lumia 520 using tapatalk
    09-07-2013 10:27 PM
  11. Adnan Javed's Avatar
    I had the same issue after i bought my phone, when i booted it up the phone said that there's a problem with the SD card, but after a few seconds the phone just automatically picked it up .. all my music from the card was showing up in the hubs and the phone settings was showing my SD card space with the internal memory.
    09-07-2013 10:42 PM
  12. pratikhjoshi's Avatar
    I have done with all possible way even i have checked my memory card with other device SD card have not an issue but yet not get detecting my SD card into phone... so guys kindly help me out for the same to resolve this issue..
    09-10-2013 07:31 AM
  13. ASHISH JAIN2's Avatar
    Or card slot is not solded properly


    Sent from my RM-914_im_india_269 using Tapatalk
    09-10-2013 07:35 AM
  14. pratikhjoshi's Avatar
    I have checked but i dnt thik so there is a probs with that even i have tried it to use other memory cards to use it but not getting success...
    09-10-2013 07:47 AM
  15. rakesh1995's Avatar
    I have checked but i dnt thik so there is a probs with that even i have tried it to use other memory cards to use it but not getting success...



    go to nokia care





    Sent from my Lumia 520 using tapatalk
    09-11-2013 12:34 PM
  16. Callum Barber's Avatar
    hi, i had the same problem but i formatted my micro sd card on my computer then put it back in my phone then when to settings then about and pressed reset then the phone came back on and and asked me to use the micro sd card.
    09-18-2013 10:59 AM
  17. INT49S's Avatar
    Guys, my Nokia Lumia 520 also didn't recognize my 16 GB Kingston Class 4 microSD card and while booting on it froze at NOKIA logo, but after I put a SanDisk 16 GB Class 10 microSD card, it booted up perfectly and accepted my SanDisk card. However, I searched for differences I had in those cards, obviously, Class ratings was different, but that wasn't the case this time. I went to properties for both cards, Kingston was formatted as follows: devided in two partitons, first partition - File system was FAT32 and Type was Logical (!), second partition - just unallocated space. SanDisk was formatted as follows: one partition, File system was also FAT32, but Type Primary. After that, I reformatted Kingston card with partition manager (I used EASEUS Partition Master) with those settings - one partition with FAT32 file system and type of this partition - Primary! After that, Nokia 520 booted up and recognized microSD.

    Summary:
    Check if your card's partition is formatted as Primary! If not, format it as FAT32, Primary. Worked well for me. Hope it helps.
    microsd-wp-primary.png
    12-20-2013 07:21 AM
  18. Roach26's Avatar
    The 520 is selling on Amazon right now for $39.99
    12-20-2013 07:27 AM
  19. Mandak Zdravo's Avatar
    Guys, my Nokia Lumia 520 also didn't recognize my 16 GB Kingston Class 4 microSD card and while booting on it froze at NOKIA logo, but after I put a SanDisk 16 GB Class 10 microSD card, it booted up perfectly and accepted my SanDisk card. However, I searched for differences I had in those cards, obviously, Class ratings was different, but that wasn't the case this time. I went to properties for both cards, Kingston was formatted as follows: devided in two partitons, first partition - File system was FAT32 and Type was Logical (!), second partition - just unallocated space. SanDisk was formatted as follows: one partition, File system was also FAT32, but Type Primary. After that, I reformatted Kingston card with partition manager (I used EASEUS Partition Master) with those settings - one partition with FAT32 file system and type of this partition - Primary! After that, Nokia 520 booted up and recognized microSD.

    Summary:
    Check if your card's partition is formatted as Primary! If not, format it as FAT32, Primary. Worked well for me. Hope it helps.
    Click image for larger version. 

Name:	microSD for WP as Primary.png 
Views:	4 
Size:	2.9 KB 
ID:	52398
    Try copy all folders from SD Card on your PC, and after format your SD Card, back your folders from your PC on your SD Card.
    Curtieson likes this.
    12-20-2013 09:59 AM
  20. yellowspark007's Avatar
    I had the same problem.... But it was manufacturing defect... Got Lumia 620 replaced....
    12-22-2013 11:28 PM
  21. windoors's Avatar
    I had same problem, than I noticed that I had set password on my SD card from my previous S40 device.
    I just removed the password and it solved the problem!

    12-25-2013 09:59 AM
  22. siljupothera's Avatar
    Hi all,
    I am also having one nokia lumia 520
    my phone is not working when i insert memory card
    anbody can help me
    01-02-2014 03:26 AM
  23. windoors's Avatar
    Hi all,
    I am also having one nokia lumia 520
    my phone is not working when i insert memory card
    anbody can help me
    Is your phone not starting or what? Please describe your problem!
    Harsh Zalavadiya likes this.
    01-02-2014 07:43 AM
  24. Harsh Zalavadiya's Avatar
    Yup it is not starting but starting when sd is not inderted please some tell me how time takes for first startup with sd card
    01-04-2014 07:01 AM
  25. windoors's Avatar
    Yup it is not starting but starting when sd is not inderted please some tell me how time takes for first startup with sd card
    It takes same time to startup with or without the SD card. Isn't it starting at all or taking a lot of time?
    01-04-2014 01:39 PM
28 12

Similar Threads

  1. Ativ S + Sd card
    By DanteJ25 in forum Samsung ATIV S
    Replies: 5
    Last Post: 07-31-2013, 04:20 PM
  2. New htc 8x boots to :-(
    By Amal Francis in forum HTC 8X
    Replies: 1
    Last Post: 07-31-2013, 09:22 AM
  3. Lumia 520 hell Lotta Problems.
    By saikrishna yellanki in forum Nokia Lumia 520
    Replies: 5
    Last Post: 07-31-2013, 07:31 AM
  4. Can not update some nokia apps
    By ygtgngr in forum Windows Phone 8
    Replies: 7
    Last Post: 07-31-2013, 05:53 AM
  5. Lumia 925 sport usage?!
    By autumnride in forum Nokia Lumia 925
    Replies: 1
    Last Post: 07-31-2013, 02:53 AM
LINK TO POST COPIED TO CLIPBOARD