1. Jessica Lares's Avatar
    It's 4:43AM February 22nd, and my 520 says it's 11:15PM January 2nd... I've restarted it five times and it's still the same issue. What is going on?
    02-22-2014 04:52 AM
  2. PxuLL's Avatar
    Happened to me on my L820 this is another reason why Im gonna switch to Android :P
    02-22-2014 05:39 AM
  3. EasilyTheBest's Avatar
    I know 3 people with 520s who have the exact same problem.
    02-22-2014 05:52 AM
  4. OsamaAdam98's Avatar
    Go to settings > Date+Time and set it manually.
    02-22-2014 06:20 AM
  5. Jessica Lares's Avatar
    I know 3 people with 520s who have the exact same problem.
    Blah! That's interesting to know. Are they on the Lumia Black update too? Just wondering if it's related to that...
    02-22-2014 07:25 AM
  6. Himanshu Chowdhary's Avatar
    my mom's device is working perfectly , she never had this issue , she is running the latest Lumia black update with GDR# update from Microsoft ; to solve your issue Jessica , go to settings ->Date+Time->and see if set it automatically works for you if not try to set it manually , and if it still changes try to do a soft reset .GOOD LUCK :)
    02-22-2014 07:43 AM
  7. Jessica Lares's Avatar
    my mom's device is working perfectly , she never had this issue , she is running the latest Lumia black update with GDR# update from Microsoft ; to solve your issue Jessica , go to settings ->Date+Time->and see if set it automatically works for you if not try to set it manually , and if it still changes try to do a soft reset .GOOD LUCK :)
    Now it says July 18th. I'm just going to do a hard reset, no big deal.
    Himanshu Chowdhary likes this.
    02-22-2014 11:19 AM
  8. Himanshu Chowdhary's Avatar
    Now it says July 18th. I'm just going to do a hard reset, no big deal.
    brave , be sure to backup all your data on your 130 GB skydrive (photos ,videos and documents ) and contacts ;)
    02-22-2014 11:36 AM
  9. Jessica Lares's Avatar
    ���� brave , be sure to backup all your data on your 130 GB skydrive (photos ,videos and documents ) and contacts ;)
    A hard reset still gives me the same problem. :( I just set it manually.
    02-22-2014 12:04 PM
  10. Himanshu Chowdhary's Avatar
    A hard reset still gives me the same problem. :( I just set it manually.
    :( but finally you are able to set your local time manually. When I first did a hard reset , I didn't even bothered to create a backup and aftermath , lost all the saved games , messages and music files lol i never tried after that even though I have some bugs , they tend to get resolved themselve by time and new update by Microsoft.
    02-22-2014 12:14 PM
  11. DHHSMichael's Avatar
    I encounter the same issue on my lil' 520. If I turn the device off or restart it, occasionally the time (and even date) will be totally off. Never had this happen on my 920 though, both are running black.
    02-22-2014 07:02 PM
  12. Rob Betts's Avatar
    Loose Battery!!!!! Try a bit of card behind it...cured it for me months ago, no such problem since.
    02-24-2014 02:32 PM

Similar Threads

  1. Replies: 8
    Last Post: 03-30-2014, 12:42 PM
  2. Group messaging on the icon?
    By stingray389 in forum Nokia Lumia Icon
    Replies: 14
    Last Post: 03-04-2014, 12:58 PM
  3. Replies: 6
    Last Post: 03-03-2014, 01:20 AM
  4. Replies: 1
    Last Post: 02-23-2014, 02:04 AM
  5. search on just the phone
    By Jonah Travisano in forum Nokia Lumia 920
    Replies: 2
    Last Post: 02-22-2014, 03:28 AM
LINK TO POST COPIED TO CLIPBOARD