1. Boyan Yordanov's Avatar
    Unfortunately, my first post on this forum would be problem related.
    The thing is, whenever I enter an area where there's only 2G coverage, I lose signal, and the only way I can temporarily fix this is by restarting the phone or turning airplane mode on/off. Still, after doing that, I lose coverage in a minute or so.
    On 3G - no problem at all.
    I run the 8.1 Developer Preview, but had this problem even before that - I have had the device for two months now.
    Before I send the phone for repair, I wanted to know what I can expect - is this software or hardware related?
    Any thoughts would be greatly appreciated!
    Thank you all in advance!
    06-26-2014 03:37 PM
  2. Laura Knotek's Avatar
    Which device do you have? Which carrier are you using? Which carrier is your device branded to?

    Some carriers do not have a 2G network, for instance Bell and Telus in Canada do not.
    06-26-2014 07:48 PM
  3. Boyan Yordanov's Avatar
    I have the Lumia 820, which is not branded, and my carrier here in Bulgaria - Globul - supports and maintains 2G. 2G is actually the only available network outside the cities. As I mentioned in my first post, I actually do connect to the network, but the signal drops and is lost in a minute.
    06-27-2014 01:34 AM
  4. Boyan Yordanov's Avatar
    Anyone? :(
    06-30-2014 04:50 AM

Similar Threads

  1. Hard decision... But I think I am passing on the Pro3
    By jaimeastin in forum Microsoft Surface Pro 3
    Replies: 30
    Last Post: 01-03-2015, 09:05 AM
  2. Replies: 3
    Last Post: 06-27-2014, 10:11 AM
  3. How to know if DP is on your phone
    By Sicka Altaar in forum Windows Phone 8.1 Preview for Developers
    Replies: 4
    Last Post: 06-26-2014, 03:27 PM
  4. Use 'Sleep Study' to learn what drains your battery on the Surface Pro 3
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-26-2014, 01:50 PM
  5. Adobe Photoshop Express now available on Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-26-2014, 12:42 PM
LINK TO POST COPIED TO CLIPBOARD