1. bmw3wags's Avatar
    I just bought a used Lumia 822 and I inserted my sim from my Galaxy Nexus into it and I haven't been able to get 4G to work. Does anyone know why this might be? I live in an area that is blanketed with 4G so it should have a good signal.

    PS I'm still using it on Verizon.
    04-13-2013 10:12 AM
  2. raul_junior's Avatar
    Want the galaxy nexus for sprint only? If so I don't think you can use the same SIM card
    04-13-2013 10:33 AM
  3. HYDR0SH0K's Avatar
    The person that had it before most likely messed with the cellular settings. I did this before, trying to momentarily turn my 4g off manually, but made the 4g disappear. This was awhile ago, but I think I just refreshed the phone the fix that problem; if this is even the problem you are having. Hope this helps!
    04-13-2013 10:37 AM
  4. cameradork's Avatar
    AFAIK, Verizon doesn't use SIMs for 4G, only for 3G GSM roaming. If it was a Verizon phone that you bought, I believe you have to call Verizon to activate it on their network to take advantage of the faster speeds.
    04-13-2013 10:38 AM
  5. bmw3wags's Avatar
    Verizon uses LTE for 4G and LTE requires sim cards. Do you guys really not know this? It was a Verizon Galaxy Nexus that I switched from I have switch my sim from multiple Android phones in the past and never had a issue. I tried resetting the phone and that still didn't work. Thanks for the replies so far though.
    04-13-2013 10:47 AM
  6. bmw3wags's Avatar
    On a side not everything else works perfectly fine except for LTE.
    04-13-2013 10:48 AM
  7. gapost's Avatar
    I deal with Verizon all the time, and you are correct, it should work. I would look online and see if you can put in esn for your 822. And I am assuming that you started from a fresh factory reset. If that doesn't work, as much as I hate to call, I would call them.
    04-13-2013 11:55 AM
  8. cameradork's Avatar
    Verizon uses LTE for 4G and LTE requires sim cards. Do you guys really not know this? It was a Verizon Galaxy Nexus that I switched from I have switch my sim from multiple Android phones in the past and never had a issue. I tried resetting the phone and that still didn't work. Thanks for the replies so far though.
    Nope - did not know that. I had 3G Verizon, and didn't realize they switched to SIMs for LTE. Learn something new every day...
    04-13-2013 03:55 PM
  9. ttsoldier's Avatar
    Verizon uses LTE for 4G and LTE requires sim cards. Do you guys really not know this? It was a Verizon Galaxy Nexus that I switched from I have switch my sim from multiple Android phones in the past and never had a issue. I tried resetting the phone and that still didn't work. Thanks for the replies so far though.
    A Factory reset?
    04-13-2013 04:12 PM
  10. bmw3wags's Avatar
    Yeah it was a factory reset. Looks like I will probably just have to call Verizon. Its not to big of a issue since SMS and MMS work fine and so does 3G. Just a minor annoyance thanks again everyone.
    04-13-2013 06:02 PM
  11. falconrap's Avatar
    Before you reset anything, go into your cellular settings and set Mode Selection to" LTE and CDMA" then, if you are on a plan with free data roaming, set data roaming to on. I had a number of issues with data roaming off and the mode set to Global.
    04-13-2013 09:51 PM
  12. Gavin Mazey's Avatar
    This exact same thing happened to me coming from a galaxy nexus to a used lumia 822. I talked to tier 2 tech support and they told me that the phone was defective. So i took it to the local Verizon store and the rep there told me i probably need a new sim card and we put a active sim from the store in a voila lte worked. He activated me a new microsim and after about 20 min everything was updated and working great. Im really loving this phone now.
    04-17-2013 09:58 PM

Similar Threads

  1. Replies: 22
    Last Post: 10-29-2014, 12:43 PM
  2. Replies: 7
    Last Post: 03-10-2012, 12:29 PM
  3. Rowi updated....now won't work
    By 1jaxstate1 in forum Applications
    Replies: 8
    Last Post: 09-18-2011, 09:45 AM
  4. Relationship Between Mango and 4G
    By cckgz4 in forum Windows Phone 7
    Replies: 4
    Last Post: 09-12-2011, 08:10 PM
LINK TO POST COPIED TO CLIPBOARD