1. Sir-Ryan Williams's Avatar
    I have a late version of the Lumia 900 and I kinda accidentally dropped it outside on a wet night, for about ten minutes until I realized it was missing, luckily I found it and it still held battery but slightly wet, it wasn't long until the battery did die and my friend gave me a car AC to Micro B usb to charge the phone up from the Van that was being driven, but It came up with the following screen. picture055.jpg
    Even when I got home and connected it to my computer it remained the same and Zune did the usual start up but prompted me to restore a previous version, so I did.. Twice and still the same, should I keep restoring until the problem is resolved?
    Last edited by Muessig; 10-14-2013 at 01:22 PM. Reason: Title typo
    10-14-2013 01:18 PM
  2. DBDev's Avatar
    Unfortunately the phone is probably water damaged and some hardware has probably broke
    10-14-2013 01:24 PM
  3. Sir-Ryan Williams's Avatar
    But it was perfectly fine before the battery ran out..
    10-14-2013 02:42 PM

Similar Threads

  1. No extra tile row for the lumia 920?
    By Fade_z in forum Developers Corner
    Replies: 71
    Last Post: 07-28-2014, 03:48 AM
  2. Replies: 13
    Last Post: 10-17-2013, 02:40 AM
  3. Lumia x30 series ??
    By Ashish Saraf1 in forum Windows Phone 8
    Replies: 2
    Last Post: 10-14-2013, 08:23 PM
  4. Video-GDR3 in Lumia 925
    By khader_moham in forum Nokia Lumia 925
    Replies: 3
    Last Post: 10-14-2013, 07:54 PM
LINK TO POST COPIED TO CLIPBOARD