07-12-2016 12:51 AM
60 123
tools
  1. Kasey Pierce's Avatar
    Ha, my icon shows a dead connection symbol from time to time and im on Verizon. I think more or less that's just an issue with the phone itself :)
    09-12-2014 11:12 PM
  2. shawnmos's Avatar
    Has anyone gotten SMS to work properly yet? I have gotten everything else to work properly including MMS and internet sharing but SMS still does not work on 3G. It works fine on LTE or if I disable cellular data. Hoping to find a permanent fix.
    06-23-2015 10:41 PM
  3. Generalheed's Avatar
    Does this still work on Windows 10 Mobile? I've read that some people were able to get this working without even having to change the APN settings. What's the most up to date and simplest method for getting my Lumia Icon to work on T-Mobile?
    05-24-2016 08:23 AM
  4. Generalheed's Avatar
    Ok I finally got the chance to try it myself on my Icon. I'm running the latest Windows 10 Mobile release build .103 I think. Calling and texting work great for me, however I cannot get the internet to work. The Nokia access point app is not available for Windows 10 it seems and therefore I can't enter all the settings that were described in the original post. Anybody else manage to figure out how to get internet to work on Windows 10?

    EDIT: Nevermind, after letting the phone sit for half an hour, it just magically started working. It works great now in fact although LTE is a rare thing to have, but H+ works fine and is fast enough for my needs at the moment.
    Last edited by Generalheed; 05-25-2016 at 10:12 PM.
    05-25-2016 08:38 PM
  5. Galway 77's Avatar
    Ok I finally got the chance to try it myself on my Icon. I'm running the latest Windows 10 Mobile release build .103 I think. Calling and texting work great for me, however I cannot get the internet to work. The Nokia access point app is not available for Windows 10 it seems and therefore I can't enter all the settings that were described in the original post. Anybody else manage to figure out how to get internet to work on Windows 10?

    EDIT: Nevermind, after letting the phone sit for half an hour, it just magically started working. It works great now in fact although LTE is a rare thing to have, but H+ works fine and is fast enough for my needs at the moment.
    I have a lumia icon I got to try windows 10. I use it on wifi, but I'm thinking of switching to tmobile and was wondering if you had to change anything to get it working on tmobile or just insert a Sim? Your the most recent post, and was wondering with Windows 10, as most of the posts are from 2 years ago. Thanks for any info!

    Posted via the Windows Central App for Android
    07-09-2016 07:46 PM
  6. wp8-1's Avatar
    I set up my icon on t-mobile today. All I did was throw in the sim card and it works fine. Only problem Is I can't receive picture messages. If you could help with that it would be great. I haven't updated it to win 10 and don't plan on it until I find a way to solve issues as well.
    07-09-2016 11:23 PM
  7. Galway 77's Avatar
    I set up my icon on t-mobile today. All I did was throw in the sim card and it works fine. Only problem Is I can't receive picture messages. If you could help with that it would be great. I haven't updated it to win 10 and don't plan on it until I find a way to solve issues as well.
    I was wondering if the problem with picture messages include whatapp and Facebook messenger also or just regular text messages?

    Posted via the Windows Central App for Android
    07-10-2016 05:25 AM
  8. libra89's Avatar
    I was wondering if the problem with picture messages include whatapp and Facebook messenger also or just regular text messages?

    Posted via the Windows Central App for Android
    Probably just group messages and picture messages most likely.
    07-10-2016 07:26 PM
  9. skiboysteve's Avatar
    Originally posted by wp8-1
    I set up my icon on t-mobile today. All I did was throw in the sim card and it works fine. Only problem Is I can't receive picture messages. If you could help with that it would be great. I haven't updated it to win 10 and don't plan on it until I find a way to solve issues as well.
    Check out my post on this same forum. I had the same exact issue but I fixed it in that thread. I'd link it but I'm in the w10 app and there is no support for that. Just go look for my mms post in the icon forums. It's near the top
    07-12-2016 12:32 AM
  10. skiboysteve's Avatar
    Originally posted by skiboysteve
    Originally posted by wp8-1
    I set up my icon on t-mobile today. All I did was throw in the sim card and it works fine. Only problem Is I can't receive picture messages. If you could help with that it would be great. I haven't updated it to win 10 and don't plan on it until I find a way to solve issues as well.
    Check out my post on this same forum. I had the same exact issue but I fixed it in that thread. I'd link it but I'm in the w10 app and there is no support for that. Just go look for my mms post in the icon forums. It's near the top
    It's here http://forums.windowscentral.com//no...n-mms-apn.html
    07-12-2016 12:51 AM
60 123

Similar Threads

  1. Does the Xbox Music pass ever go on sale?
    By Jeffrey Fox in forum Groove Music
    Replies: 8
    Last Post: 04-22-2014, 01:31 AM
  2. How is this new Icon for Clipr?
    By venu238 in forum Applications
    Replies: 10
    Last Post: 04-13-2014, 03:14 AM
  3. Time to bring other Mobile Nations Blogs apps to Windows Phone
    By rdubmu in forum Site Feedback & Help
    Replies: 1
    Last Post: 04-11-2014, 08:15 AM
  4. Replies: 2
    Last Post: 04-10-2014, 05:50 PM
  5. Nokia phones and further wp updates
    By snakerider in forum Nokia Lumia 930
    Replies: 2
    Last Post: 04-10-2014, 05:41 PM
LINK TO POST COPIED TO CLIPBOARD